Autoexec

Autoexec.bat

Файл Autoexec.bat тесно связан с файлом Config.sys и, не смотря на обработку интерпретатором другого языка, в связи с наличием сходств во многих языках программирования, имеет некоторые сходные с ним черты (в том числе аналогичные и, даже, дублирующие команды). В нем так же применяется команда REM и загрузка в верхнюю память, только для последней, вместо окончания High применяется дополнительная команда LH (Load High), как и команда REM, отделяемая от основной команды пробелом. Например: LH mouse.com.

Поскольку .bat файлы представляют собой набор команд операционной системы, их называют так же, командными файлами.

Составляя Autoexec.bat, стоит учесть, что некоторые нестандартные программы, при установке требуют в памяти большего места, чем займут, установившись. Такие программы следует устанавливать в первую очередь, чтобы потом не оказалось, что они не могут развернуться (соответствующее сообщение будет выведено на экран).

Команды.

Path

Устанавливает каталоги, содержащие исполняемые файлы. В одной строке можно указать несколько каталогов (но не более 127 символов), каждый из которых должен отделятся точкой с запятой. Например:

Path C:\Windows; C:\Windows\Command

При вводе файла без расширения или с расширением .exe, .com, .bat, они ищутся в текущем каталоге, корневом каталоге и каталогах заданных этой командой, что позволяет запускать программы не указывая путь к ним. При этом поиск начинается с первого указанного каталога и, чем больше каталогов установлено командой Path, тем дольше он происходит. Кроме того, каждая новая команда Path отменяет предыдущую.

Pause

Приостанавливает исполнение программы до нажатия пользователем какой-нибудь клавиши, с выводом на экран сообщения аналогичного выводимому при исполнении некоторых программ с параметром /p: “Нажмите любую клавишу…”. Используется, например, перед исполнением в командном файле команды по запуску программы; если вместо любой клавиши будет нажато сочетание CTRL+BREAK или CTRL+C, исполнение команды будет предотвращено.

CLS

Очистка экрана. В основном применяется для удобочитаемости сообщений, выводимых MS-DOS.

Echo

Эта команда имеет несколько отличных модификаций.

Echo off – отключение вывода исполняемых команд на экран, чтобы они не вытесняли предшествующие им сообщения.

Echo on – восстановление вывода.

Echo – служит для вывода текстовых сообщений или звуковых сигналов, записываемых, по крайней мере, через интервал от самой команды. Например:

ECHO LOADING

(каждый лишний пробел будет выводиться на экран, смещая сообщение вправо).

При этом русскоязычные сообщения должны записываться в коде ASCII (шрифт Terminal) и не могут использоваться, пока командами MODE не будет обеспечен вывод на экран русифицированных шрифтов. А запись звукового сигнала в файл производится нажатием и отпусканием клавиши 7 калькуляторной клавиатуры, при нажатой клавише ALT (для выполнения этой операции подойдет не каждый редактор, и у каждого из подходящих свои особенности; в MS-DOS редакторе Edit, входящем в состав Windows, переход на вставку управляющих кодов осуществляется нажатием CTRL+P).

Echo. – (с точкой) вывод пустой строки для удобочитаемости.

@

Не выводить данную команду (аналог Echo off, однократного действия). Часто применяется в сочетании с ней, для того чтобы и сама команда ECHO off не выводилась: @Echo off.

SET

Присваивает значение переменным. Стандартными переменными, устанавливаемыми автоматически, являются:

Cmdline – содержит имя последней внешней команды.

Winbootdir – устанавливает папку, содержащую ядро Windows, по ней же, ориентируются инсталяторы программ.

Windir – аналогичная переменной Winbootdir, но появляется только при загруженом Windows, в режиме MS-DOS она отсутствует.

Blaster – устанавливает параметры саундкарты

Temp – указывает место хранения временных файлов

Comspec – определяет имя и расположение интерпретатора команд для режима MS-DOS (начальная стадия загрузки Windows)

Prompt – указывающая параметры командной строки

Path – указывающая пути к приложениям

Cdrom – указывает синоним (букву) компакт-диска

Ramd – указывает синоним виртуального диска

А наиболее часто устанавливаемые в ручную:

WinPmt – определяет вид командной строки для сеанса MS-DOS, отличный от того, какой она имеет в режиме MS-DOS или режиме Command Prompt Only.

TMP – вместе с переменной Temp, указывающая место хранения временных файлов, чтобы программы не задавали об этом вопросов.

PkTemp – задает отличный от текущего каталог для временных архивов архиватора PkZip.

NC – определяет каталог в котором программа Norton Comander должна искать свои компоненты.

Между переменной и присваиваемым ей значением обязательно устанавливается оператор присвоения “=”. Например:

Set Temp=C:\Windows\Temp

Отмена значений переменной осуществляется либо вводом новых, либо вводом ее без значения. Например:

Set Path=

При этом, отмена значений, может применяться для удаления лишних переменных с тем, чтобы освободить место в области отведенной для их хранения.

Введенная без переменных, команда SET приводит к выводу на экран отчета о переменных уже установленных.

Заключение переменной в символы процента, интерпретируется как значение переменной. Например, после создания переменной NC со значением C:\NC\nc.exe, ввод %nc% будет означать запуск Norton Commander из папки C:\NC. Эту возможность можно применить при необходимости создания команды Path большой длины или добавления нового пути, без перезаписи всей команды. Set Path=%Path%; НОВЫЙ ПУТЬ – добавит к существующим путям еще один.

Переменная DirCmd позволяет установить параметры команды Dir (просмотр каталога в MS-DOS), автоматически присваиваемые этой команде, наиболее насущными из которых являются = /ogn /p. После установки Set dircmd= /ogn /p при введении команды Dir, содержимое каталога будет сортироваться по именам, начиная с папок, и выводится на экран с паузой после каждого заполнения (добавление /B позволит просматривать каталоги без дополнительных комментариев со стороны операционной системы, а добавление /A приведет к отображению файлов с любыми атрибутами).

Prompt

Установка вида командной строки. Возможные параметры:

$P – отображать путь в командной строке (без него работа проблематична).

$N – отображать текущий дисковод.

$T – отображать текущее время

$V – отображать версию операционной системы

$_ – переход на новую строку

$S – пробел

$H – каждый такой знак удаляет один предыдущий символ (например, сотые долей секунды из показаний времени)

$E – символ с кодом 27 (клавиша Escape)

$G – символ >

$1 – символ <

$B – символ |

$$ – символ $

Например, Prompt $P$G – стандартное приглашение выглядящее как (например) C:\Windows>.

Кроме стандартных параметров начинающийся с символа доллара, команда позволяет ввести в командную строку любой текст, не содержащий специальных символов.

Например: prompt Common!$_$P$G красноречиво говорит о том, что это строка приглашения. Результат ее исполнения выглядит так:

Common!

C:\>

Подключение через Config.sys драйвера Ansi.sys позволяет с помощью этой команды менять цвета.

Ver

Вывод на экран версии операционной системы. В отличии от Prompt $v, имеет однократное действие.

More

Команда вывода на экран с паузами после каждого заполнения. Для продолжения вывода требуется нажатие любой клавиши.

Например: More C:\Autoexec.bat – постраничный вывод на экран содержимого файла Autoexec.bat Содержащегося в корневом каталоге диска С.

Dir | more – постраничный вывод содержимого текущего каталога (аналогично Dir/p)

Эта команда внешняя, требующая указания пути к программе More.exe, если путь к каталогу ее содержащему не отмечен в команде Path. Обычно данная программа содержится в каталоге C:\Windows\Command, а он в свою очередь, указывается в Path по умолчанию, так что пользователь может выдавать ее, не задумываясь, о путях. В противном случае, она принимает вид:

C:\Windows\Command\More C:\Autoexec.bat

Attrib –r –h –s –a

Внешняя команда установки и снятия атрибутов. Где указание атрибута со знаком отрицания, приводит к его удалению, а без отрицания – к установке. Если атрибут не указан, он остается без изменений. При этом:

R – Только для чтения

A – Архивный (не имеющий копии в архиве)

H – Скрытый

S – Системный

Дополнительный параметр /S – может устанавливаться для обработки так же и файлов содержащихся во вложенных каталогах, например: ATTRIB –r C:\*.* /S

Call

Вызов командного файла из другого командного файла для выполнения записанных в нем команд. Например, Call SetRamd.bat. Если вызвать командный файл иным способом (без Call), управление перейдет к нему и дальнейшее выполнение команд вызвавшего его файла прекратится.

For

Выполнение команды для указанного подмножества файлов.

For %%x in (1.txt 2.txt) do del %%x

Где x – любая буква, назначаемая временной переменной для хранения имен файлов назначеного подмножества.

Означает:

Для указанных файлов (1.txt и 2.txt) сделать Del (удалить)

Или:

For %%x in (Config.sys Autoexec.bat) do copy %%x C:%%x

Скопировать указанные файлы на диск C:

Или:

For %%x in (*.Zip) do PkUnZip %%x

Распаковать все ZIP-архивы текущего каталога программой PkUnZip.

Данные примеры приведены для аналогии. Реальное удаление или распаковку проще выполнять без всяких FOR. Однако, в случае програм не умеющих работать со списками или шаблонами, оператор FOR окажется безценным. Например:

For %%n in (*.exe *.com) do PkLite -o -b %%n

Сожмет все програмы текущего каталога, зарезервировав их в Bak-файлах и перезаписав оригиналы.

Или:

For %%n in (*.*) do expand %%n C:\Prog

Распакует текущий дестрибутив в каталог C:\Prog.

При выдаче FOR из командной строки, вместо %% применяется % (второй % в командные файлы добавляется для избежания неоднозначности при наличии дополнительных параметров их вызова).

Command

Временный вызов интерпретатора команд MS-DOS (командного процессора) из командной строки Windows или программы-оболочки. Выдача этой команды с параметром /E позволяет изменить величину памяти отведенную для хранения переменных, что может потребоваться при появлении сообщения: “Out of Environment Spase” (Нет памяти в окружении).

Exit

Выход из командного процессора с возвращением в вызвавшую его программу (если он был временно вызван).

Эта команда не может применяться в командных файлах, если они выполняются первичным интерпретатором, а не вызванным поверх него вторичным например, второй копией Command.com, Command.com вызванным из Windows (сеанс MS-DOS) или чем-то еще в том же духе.

Goto

Команда безусловного перехода (Go to – идем к) к указанному, через один интервал, блоку. Например: GOTO END. При этом блоки начинаются с метки, обозначаемой двоеточием, а символы следующие через пробел после названия блока, игнорируются, и могут использоваться для комментариев. В частности, заглавие блока END может иметь вид:

:END Этот блок содержит общие программы.

После получения команды перехода, процессор начинает исполнять команды следующие за указанной меткой, минуя все предшествующие команды.

Применение команды перехода в командной строке невозможно.

If

Команда проверки условия (команда “если”) за которой следует команда, выполняемая в случае его соблюдения. При этом условия бывают четырех типов:

Exist – существует

Строка1==Строка2

ERRORLEVEL – код завершения предшествующей условию программы

NOT – не (условие ложно)

Например, команда “Если на диске С существует Autoexec.bat, сообщить, что он существует”, имеет вид:

if exist C:\Autoexec.bat echo Существует

А команда “Если нет файлов .bak в каталоге С:, идем к метке “NO_BAK”, а если есть – удалить эти файлы” имеет вид:

If Not Exist C:\*.Bak GoTo No_Bak

If Exist C:\*.Bak Del C:\*.Bak

Или проще:

If Not Exist C:\*.Bak GoTo No_Bak

Del C:\*.Bak

Применение условий:

Exist – для выполнения операции только при наличии некоторых файлов

Строка1==Строка2 – для выполнения операции только в случае если некому параметру, включаемому в первую строку, присвоено значение указанное пользователем (без пробелов) во второй. При этом, в качестве параметров первой строки (иногда второй), часто применяются символы от %0 до %9 при исполнении принимающие значение имени и параметров командного файла.

%0 принимает значение пути и имени файла с расширением

%1 принимает значение первого параметра

%2 второго

и т. д.

Тогда команда выполняется, если оно аналогично значению второй строки, благодаря чему, можно, несколько командных файлов объединить в один, разделенный на блоки (до 9), исполняемые в зависимости от параметра, заданного при вызове этого файла. Например, ввод команды “Choice.bat Y” приведет в исполнение команду (допустим, по запуску соответствующего блока), файла Choise.bat следующую за условием IF %1==Y . Однако, для избежания ошибок могущих возникнуть в случае, когда файл вызывается с количеством параметров меньшим предусмотренного, замену строки на символ %, лучше производить с вводом дефиса (иначе часть строк1 будут иметь значение пустой строки):

IF -%1==-СТРОКА2

Еще лучше, если обе строки берутся в кавычки:

if “%1==СТРОКА2” или If “%1”== “СТРОКА2”

в таком случае, даже пустая строка, заключенная в кавычки может иметь значение.

Так же, в качестве строки может применяться переменная заключенная с обеих сторон в проценты (что означает ее фактическое значение, о чем говорилось в описании команды Set).

Errorlevel – для выполнения операции, только если выполнение предыдущей программы закончилось с результатом (называемом кодом завершения или возврата), равным или превосходящим тот, что определен в условии Errorlevel (поскольку команда срабатывает при равных или больших кодах возврата, последовательность из нескольких подобных команд должна начинаться с тех, что имеют наибольшее значение). Например:

If errorlevel=5 goto end

If errorlevel=4 copy 1.txt C:

Для применения условий содержащих ссылку на коды возврата, необходимо знание этих кодов.

По умолчанию, переменная Errorlevel=0 (то есть, ее нет).

Not – для выполнения команды, только если условие Exist, строки или Errorlevel не соблюдается (например, для перехода к следующему блоку, чтобы миновать команды обработки файлов, если таковых не существует).

Choice

Внешняя команда выбора, предназначенная для генерации кодов возврата. При исполнении, она выдает некоторое сообщение и предлагает несколько вариантов ответа, нужный из которых вводится нажатием соответствующей клавиши.

Формат команды:

CHOICE /C… ПАРАМЕТРЫ “СООБЩЕНИЕ”

Где СООБЩЕНИЕ – сообщение, которое программа должна вывести на экран

… – варианты ответов.

ПАРАМЕТРЫ – дополнительные параметры, среди которых:

/tN,nn –автоматический выбор варианта N после nn секунд ожидания.

/N – исполнение Choice без вывода, каких либо вопросов и сообщений (имеет смысл при сочетании с предварительным сообщением выведенным иным способом).

После исполнения программы, Errorlevel приобретает значение равное соответствующему порядковому номеру выбранного символа. Например, ввод Choice без параметров аналогичен “Choice /CYN”, где выбор Y дает код возврата 1, а выбор N дает код возврата 2.

Break

Команда проверки нажатия Ctrl+Break (или Ctrl+C) может вводиться не только в Config.sys, но и в командной строке или командном файле. Варианты: Break on или Break off. Просто Break приводит к выводу на экран текущего состояния режима проверки.

Многие программы во время работы устанавливают режим BREAK ON самостоятельно, даже если он отключен пользователем.

Shift

Сдвиг параметров, заданных при вызове командного файла, на значение следующего по старшинству параметра.

Например, если файл 1.Bat вызван командной строкой 1.bat aa bb, то изначально, %0==1.bat, %1==aa, %2==bb, а после команды Shift, %0==aa, %1==bb, а %2 утрачивает значение.

Сдвиг происходит при каждом исполнении команды и применяется для расширения возможностей команды IF строка1==строка2, позволяя задавать вызываемому файлу, бесконечное число параметров (после первого сдвига, %9 принимает значение десятого параметра).

Многократный сдвиг до тех пор, пока не будет найден нужный параметр, осуществляется комбинацией команд:

If -%1==- GoTo No_Param

If -%1==-Требуемый_параметр GoTo Stop

:Cicle Сдвиг параметров, вслучае, когда условие не верно.

Shift

If -%1==-Требуемый_параметр GoTo Stop

echo Не тот параметр. Для остановки цикла и прекращения поиска, требуется нажатие CTRL+C

Pause

GoTo Cicle

:No_Param

echo Параметры не указаны. Будут выполнены команды, предусмотренные на этот случай.

GoTo End

:Stop Далее пойдут команды выполняемые, если параметр совпал.

…

:End

Sort

Сортировка данных в алфавитном порядке (или в обратном, с параметром /R)

Команды переадресовки

КОМАНДА > ФАЙЛ вывод команды в указанный файл, с заменой существующего или созданием нового. Может использоватся для создания файла, подлежащего дальнейшей обработке, что актуально для программ-оболочек имеющих средства редактирования файлов, но не имеющих средства их создания.

КОМАНДА >> ФАЙЛ вывод сообщения в конец файла, с сохранением ранее записанной информации.

КОМАНДА < ФАЙЛ чтение данных для обработки не с клавиатуры, а из указанного файла.

КОМАНДА | КОМАНДА использование сообщений выводимых первой командой в качестве вводных данных для второй.

Например:

Sort < файл 1 > файл 2 – сортировка данных из указанного файла с записью результатов в другой файл.

Echo Y | Win – запуск Windows из режима MS-DOS без запроса на подтверждение (заранее отвечено “Yes”).

Dir /OGN > C:\1.txt – отсортировывает оглавление указанной в команде DIR папки (здесь – текущей папки) и записывает его в файл 1.txt на диске С, создавая его, если он еще не существует.

CON

Экран и клавиатура. Применяется в сочетании с командой MODE или для перенаправления ввода и вывода. Например:

COPY файл CON – заменяет команду TYPE, выводя содержимое указанного файла на экран.

Может иметь несущественные параметры.

NUL

Пустота. Имеет разнообразное применение. Например:

Copy A:\*.* nul – проверяет читаемость диска А.

> nul – переадресовывает сообщение пустому устройству, а заданное после какой-то команды, дает ей понять, что ее сообщения никому не нужны (работай молча).

Echo Y | Win > nul – запускает Windows из режима MS-DOS не только без необходимости ввода подтверждения, но и без вывода сообщений о начале загрузки Windows.

Подобные переадресовки, наряду с командами @ и Echo off позволяют не засорять экран. Например:

@ Mouse.com > nul – устанавливает драйвер мыши под MS-DOS без вывода на экран команды установки и итогового сообщения о том что, драйвер мыши установлен (в тихую).

Ctty

Меняет устройства используемые для ввода-вывода. Например:

Ctty nul – указывает, что ввод команд будет осуществляться из ниоткуда (на ввод не реагировать).

Включение в командный файл этой команды приводит к невозможности прервать выполнение командного файла, однако, вслед за командами, прерывание которых требуется предотвратить (если это не способ подшутить над приятелем), необходимо включение в командный файл команды CTTY CON, иначе работа с компьютером будет невозможной.

Subst

Сопоставление пути к какому-либо файлу с фиктивным диском. Например, после ввода:

SUBST H: C:\Windows\Command\EBD – запуск программы Edit.exe находящейся в каталоге C:\Windows\Command\EBD можно осуществить выдачей команды “H:\Edit”.

При этом буква пути не должна соответствовать реальному диску и не должна превышать буквы установленной командой LastDrive файла Config.sys. Кроме того, некоторые команды и программы не реагируют на подобные синонимы (например, команда Copy).

Copy

Копировать.

COPY ФАЙЛ1 ФАЙЛ2 ПАПКА – копировать несколько файлов в указанную папку.

COPY ФАЙЛ1+ФАЙЛ2 ФАЙЛ3 – объединяет первые два файла в третий, дописывая второй в конец первого.

Параметры:

/-Y – запрашивать перед заменой файлов (принимается по умолчанию).

/Y – замещать файлы при совпадении имен без запроса (чтобы замена без запроса принималась по умолчанию, требуется с помощью команды SET ввести переменную CopySMD=/Y)

Команда COPY не распространяется на каталоги, скрытые и системные файлы, не замещает файлы имеющие атрибут “только для чтения” и не копирует файлы нулевой длины.

XCopy

Внешняя команда MS-DOS, для копирования не только файлов, но и вложенных каталогов (внутренняя команда Copy предназначена только для файлов). Из множества возможных параметров команды, наибольшее значение имеют следующие:

/S – копирование всего содержимого, кроме пустых каталогов, если таковые имеются.

/S /E – абсолютное копирование, даже если каталоги пусты.

/V – убедится в том, что при копировании не возникло ошибки.

При этом:

Команда не распространяется на файлы предназначенные только для чтения;

При недостаточности места, вместо “Диск переполнен”, команда выводит сообщение “Ошибка в создании файла”;

Команда не создает каталог, если папка, в которой он должен находиться имеет файл с таким же названием (в таком случае, требуется предварительное создание каталога другими средствами).

DelTree

Внешняя, для удаления каталогов. Возможен параметр /Y для удаления без запроса на подтверждение.

Mode

Внешняя команда установки режимов работы посимвольных устройств под управлением MS-DOS (например, при запуске компьютера).

Mode con Codepage prepare=((номер) файл)

устанавливает локализованный экранный шрифт (кодовую страницу) для которого указывается номер и файл его содержащий (русскую – 866 – страницу содержит файл Ega3.cpi).

Mode con codepage select=номер

переводит работу системы на использование установленного предыдущей командой шрифта (приводит к выбору кодовой страницы).

Возможные сокращения:

CP – Codepage

PREP – Prepare

SEL – Select

Дополнительно обеспечиваемые режимы:

BW40 – черно-белое изображение, 40 символов в строчке.

BW80 – черно-белое изображение, 80 символов.

CO40 – цветное изображение, 40 символов.

CO80 – цветное изображение, 80 символов.

Mono – монохромный монитор (черно-белое изображение).

Keyb сокращение, номер, файл

Внешняя команда настройки клавиатуры, где:

Сокращение – абривиатура клавиатуры (буквенный код), для русского языка – RU.

Номер – необязательный номер кодовой страницы (русская страница – 866)

Файл – ссылка на локализованный файл описания (драйвера) клавиатуры.

При пропуске параметра, запятые должны оставаться, например:

keyb ru,,C:\WINDOWS\COMMAND\keybrd3.sys

Verify

Контроль над выполнением записи на диск – аналог параметра /V при вводе некоторых команд, действующий постоянно. Возможные параметры:

ON – включить контроль

OFF – выключить

По умолчанию OFF.

VERIFY без параметров выводит текущее состояние контроля.

Ошибок при выполнении записи на диск обычно не возникает и проверку ее правильности можно не включать, но… береженого и Бог бережет. Появление общих кластеров чревато серьезными последствиями, по этому, команду Verify on лучше включить в Autoexec.Bat. Выполнение записи при этом несколько замедлится, но на современных компьютерах это вряд ли станет заметно.

SmartDrv

Внешняя, создает кеш жесткого диска, выполняя функции аналогичные команде Buffers, но более эффективно и, только для жестких дисков. Возможны параметры S и /A где S – размер кеша в килобайтах (по умолчанию 256), /A – отправляет кеш в отображаемую память (тогда, по умолчанию, он занимает всю бездействующую память).

LH

Команда отправки программы в верхнюю память (Load High). Для ее исполнения необходима загрузка из Config.sys менеджеров (драйверов) верхней памяти.

Дополнительно

В состав Windows входят некоторые еще не описанные исполняемые файлы (внешние команды):

Chkdsk.exe – отчет о состоянии диска

Debug.exe – отладчик программ

Diskcopy.com – копирование дискет с соблюдением физического расположения файлов

Doskey.com – резидентная программа редактирования командной строки

Extract.exe – распаковка Каб-файлов

Fc.exe – сравнение файлов

Find.exe – поиск текста

Label.exe – изменение метки тома

Move.exe – перемещение файлов

Restart.com – перезапуск компьютера

Scanreg.exe – программа проверки, восстановления, исправления и резервирования реестра.

Share.exe – обеспечение совместного использования файлов

Start.exe – запуск приложений Windows из сеанса MS-DOS (вообще-то, они и без нее запускаются)

Все они (кроме Restart.com), находятся в папке Command. Параметры их запуска, если таковые потребуются, можно узнать, вызывая их с параметром /?.

Между строками обязательно должны находиться два знака равенства, поскольку, как знак равенства, интерпритируется только второй из них, а первый, интерпретируется как оператор присвоения. В результате, буквальное значение команды таково:

“Если после выполнения первой строки (например, ввода реального значения параметра %1), ейприсвоено значение равное второй строке...”


Config

Config.sys.

Команды.

Общий вид команд: КОМАНДА=ЗНАЧЕНИЕ. Для освобождения доступной MS-DOS основной памяти, команды задаются с окончанием HIGH, например, Buffershigh, в этом случае загрузка происходит в верхнюю память, а если таковая недоступна, она происходит как обычно. Добавление к команде ключа /L:n где n – номер блока, позволяет загрузить драйвер точно по указанному адресу, чтобы свободная память представляла собой единый блок (найти подходящие адреса позволяет программа mem с ключами /f и /p – последний для выдачи поэкранного отчета), однако столь тщательная сортировка в подавляющем числе случаев не имеет смысла . Для временной отмены команды можно снять установленный возле нее флажок в Программе настройки системы, запускаемой из меню “Сервис” программы “Сведенья о системе” (MsInfo), или вставить команду REM перед нежелательной командой, например, “Rem Buffers=15”. Эта же команда применяется для вставки комментариев (отсюда возник термин “заремить” или “закомментировать”), например, “Rem Дальнейшие строчки внесены Windows, не изменяйте их”.

Buffers=n,m /x

Определяет число буферов обмена (n) каждый из которых требует 512 байт, число считываемых за раз секторов (m от 1 до 8) и расположение (/x отправляет все это в верхнюю память, заменяя приставку HIGH). Благодаря этой команде, при считывании информации с диска, она помещается в зарезервированный в оперативной памяти буфер и при следующем обращении, считывается из него (с огромной экономией времени), если к этому времени не была вытеснена другой информацией. Таким образом, чем больше буферов, тем быстрее работает компьютер (и тем меньше остается свободной оперативной памяти).

При считывании секторов более одного, задействуются сразу несколько считывающих головок и, чтение получается упреждающим, так что, для извлечения следующей информации, может не потребоваться новое обращение к диску (с вытекающим из этого выигрышем в скорости).

По умолчанию, для Windows98 Buffershigh=20. Значения m и /x, по умолчанию не задаются. При работе с гибких дисков, этот показатель можно уменьшить до четырех (число к которому пришли многие специалисты опытным путем), поскольку большие массивы информации с них не читаются, однако, уменьшение его ниже 12 приводит к замедлению загрузки с дискеты, а ниже 6 – к общему замедлению работы.

При создании виртуального кеша, число буферов, без ощутимой потери производительности, можно уменьшить в десяток раз.

Files=

Определяет максимальное количество одновременно открываемых MS-DOS файлов. По умолчанию оно равно тридцати и обычно не требует вмешательство пользователя. Если же появилось сообщение об исчерпании обработчиков файлов (File handles), заданное число оказалось недостаточным и его требуется изменить. При этом увеличение числа обработчиков, уменьшает количество свободной памяти.

Stacks=n,s

Формирует объем (пул) из N (от 0 до 64) стеков размером в S (от 0 до 512 байт) для обработки повторных прерываний. По умолчанию Stackshigh=9,256. Увеличение ведет к уменьшению свободного места в памяти, уменьшение – замедляет работу.

LastDrive=

Определяет максимальную букву для диска (по умолчанию =Z). Ни один логический диск не может иметь букву большую указанной в Lastdrive, в связи с чем, в качестве последней буквы часто задается Z, либо команда Lastdrive вообще не выдается, для установки параметров принятых по умолчанию. Однако, поскольку для каждой буквы отводится по 80 байт для хранения информации о текущем каталоге, при такой запасливости, до двух килобайт доступной MS-DOS оперативной памяти расходуется в пустую .

Break=

Проверка нажатия клавиш Ctrl+Break (Ctrl+C) завершающих выполнение программы – универсальная команда предназначенная не только для файлов конфигурации, но и для командной строки. Возможные значения: on, off соответственно включающие и выключающие режим проверки. Заданная без значений приводит к выводу информации о текущем режиме Break.

По умолчанию Break=on (режим проверки включен) и его задание в файлах конфигурации вряд ли имеет смысл.

Numlock=off

Отключает калькуляторную клавиатуру.

Shell=Command.com /e: число /p

Установка размеров области памяти отведенной для хранения переменной среды (окружения оболочки операционной системы), где число – размер области в байтах, кратный 16 (от 128 до 32768).

Применение команды необходимо, если задаваемых по умолчанию 128 байт недостаточно (сообщение “Out of environment space”).

В ней же, можно заменить Command.com другим интерпретатором (если таковой имеется), или указать к нему путь, если он перемещен из корневого каталога.

Country=страница,код,имя.

Определяет символы допустимые в именах файлов и каталогов, порядок символов при сортировке, формат даты, времени и денежной единицы; позволяет MS-DOS работать с неанглоязычными каталогами и файлами. Код России 007, страница 866. Указываемое в команде имя определяет название и местонахождение драйвера обеспечивающего выполнение команды (обычно Country.sys).

Для русифицированной версии Windows Country=007,866,C:\Windows\Country.sys.

Device=

Установка драйвера (возможно с дополнительными параметрами).

Devicehigh=

Установка драйвера в верхнюю память (возможно, с параметрами).

Install=

Применяется в Config.sys для загрузки резидентных программ (расширение .com и .exe), обычно загружаемых через Autoexec.bat. Загужаясь через Config.sys они занимают меньше места, однако их перенастройка и удаление из памяти становится невозможными.

Независимо от расположения в файле Confif.sys, команды Install выполняются в последнюю очередь.

InstallHigh=

Аналогично предыдущей, но устанавливает програмы в верхнюю память.

FCBS=

Определяет количество блоков управления памятью (от 1 до 225) по умолчанию равное 4.

Dos=High,Umb

Позволяет, после подключения драйверов верхней памяти, производить загрузку в нее, для освобождения основной памяти, большой объем которой необходим большенству программ MS-DOS.

SWITCHES= /F

Отключает двухсекундную задержку перед стартом операционной системы (это лучше сделать, откорректировав Msdos.sys). Возможно так же дополнительное значение /N для невозможности обойти загрузку указанных в Config.sys драйверов путем пошаговой загрузки. Остальные параметры данной команды (/K и /E) применяются для имитации клавиатуры, на которой работали неандертальцы.

DOS=NoAuto

Означает, что драйвера Himem.sys, Ifshlp.sys, DblBuff.sys и программа Setver.exe загружаются, только если их загрузка указана в файле Config.sys. По умолчанию DOS=Auto, что фактически означает:

Buffershigh=20

Fileshigh=30

Fcbshigh=4

Lostdrivehigh=Z

Stackshigh=9,256

(если соответствующие команды не указаны пользователем с другими параметрами).

Плюс загрузка указанных драйверов (указание их загрузки находится в файле Io.sys).

Драйвера.

В файлах конфигурации может быть подключено множество драйверов, однако, реальный интерес представляют лишь драйвера входящие в состав Windows, а потому, имеющиеся на каждом компьютере.

Drvspace.sys и Dblspace.sys

Драйвера Drvspace.bin и Dblspace.bin обеспечивают доступ к уплотненным дискам. В зависимости от программы, примененной для уплотнения, требуется соответствующий драйвер. При загрузке компьютера они загружаются из корневого каталого до выполнения команд из файлов Config.sys и Autoexec.bat, когда верхняя память еще не доступна, вследствие чего, могут загрузиться только в обычную память, занимая в ней по 110 килобайт, каждый.

Драйвера Drvspace.sys и Dblspace.sys позволяют переместить их в верхнюю память, для чего в Config.sys вводится ссылка на Drvspace.sys или Dblspace.sys (соответственно), начинающейся с команды DEVICEHIGH. Однако, размер верхней памяти тоже не безграничен, поэтому, на компьютерах не имеющих сжатых дисков, Drvspace.bin и Dblspace.bin из корневого каталога лучше удалить.

Display.sys

Обеспечивает вывод на экран русифицированных шрифтов.

Driver.sys

Позволяет задавать фиктивные дисководы.

RamDrive.sys

Создает в оперативной памяти виртуальный диск для ускорения запуска программ (но замедляет процесс загрузки компьютера), принимаемый за очередной жесткий логический диск и символизируемый соответствующей для очередного логического диска буквой. Для его использования требуется скопировать желаемые программы на созданный диск и указать к ним путь командой Path (для большего эффекта, этот путь, в общем наборе путей, лучше сделать первым), что удобно выполнить с помощью Autoexec.bat.

Вместе с драйвером обязательно, указывается размер и, возможно, в определенной последовательности, другие параметры создаваемого диска:

Ramdrive.sys m n p /e :q

Где:

m – размер создаваемого диска в килобайтах (не менее 16, хотя в разных версиях эта величина различна).

N – размер сектора в байтах имеющий допустимые значения 128; 256; 512 (по умолчанию 512).

P – кратное 16 максимальное число элементов (папок или файлов) в его корневом каталоге (от 2 до 512, по умолчанию – 64).

/e – параметр с независимой последовательностью (может находиться в любой позиции среди параметров), позволяющий создать диск не в основной, а в расширенной памяти (по умолчанию, создается в основной). Вместо него может применяться параметр /a для отправки диска в отображаемую память, но для этого предварительно следует активировать драйвер XMA2EMS.sys.

:q – определяет количество считываемых за раз секторов (от 1 до 8, по умолчанию 8).

Большинство параметров принимаемых по умолчанию, устроят любого пользователя. В таком случае, при создании виртуального диска достаточно указать размер и область занимаемой памяти, например:

Ramdrive.sys /E 3072

где 3072 – указание создать диск в три мегабайта.

Mouse.sys

Некоторые драйвера мыши под MS-DOS имеют расширение .sys. Их установка производится в файле Config.sys (точнее, резидентные программы, с расширением .com, не являются драйверами и, выполняя ту же функцию, могут загружаться из Autoexec.bat или командной строки).

HiMem.sys

Открывает доступ MS-DOS к 64 килобайтам верхней памяти. Именно после его применения приобретают смысл приставка HIGH, команда DOS=High и аналогичные команды в Autoexec.bat.

EMM386.exe

Вводится после Himem.sys, открывая для MS-DOS еще 83 килобайта. После его установки приобретает смысл команда DOS=Umb (обычно выдаваемая в одной строке с DOS=HIGH). Программа EMM386.exe может иметь множество параметров. Параметр NOEMS, практически всегда обеспечивает наибольшую эффективность ее применения, однако при работе с Windows, параметр RAM бывает предпочтительнее. Дополнительный параметр HIGHSCAN увеличивает доступную память еще на 35 килобайт. С приведенными параметрами, команда запуска, имеет вид:

Device=EMM386.exe NOEMS HIGHSCAN

IfsHlp.sys

Вспомогательный драйвер необходимый для хранения длинных имен. Если DOS=Auto (по умолчанию), загружается автоматически в соответствии с указанием из Io.sys.

SetVer

Команда загрузки одноименной резидентной программы.

Многие программы MS-DOS предназначены для работы лишь в некоторых версиях MS-DOS. Setver.exe перехватывает их запросы о версии DOS и в любом случае сообщает: “О, да это как раз, та самая версия!” – доВЕРСИвые программы развешивают уши, после чего с ними можно делать все что угодно.

Для обмана програм, по команде

Setver каталог програма версия

где каталог - путь к каталогу содержащему требуемый экземпляр Setver (если этот каталог являеься текущим, его явное указание не требуется),

програма - програма, требующая обмана,

версия - ожидаемая ей версия DOS в формате 0.00

SetVer.exe записывает данные в свою внутреннюю таблицу, чтобы, при следующей загрузке компьютера, загрузившись, подобно драйверу, командой Device(high)= из файла Config.sys, водить эту программу за нос. Например, после команды "Setver C:\windows\command Dosshel.exe 6.22" и последующей перезагрузке со строкой "Devicehigh=C:\windows\command\setver.exe" в файле Config.sys, программа Dosshel будет считать что, запущена в Dos 6.22.

По мере увеличения числа вводимых в заблуждение програм, внутренние таблицы Setver заполняются и, для поддержания работоспособности следующей програмы, требуется либо освободить немного места в данном экземпляре Setver, либо создать пустой Setver в другом каталоге, скопирова его и очистив. Для просмотра содержимого таблиц Setver, программа вызывается с одним-лишь указанием каталога (при этом экранный вывод желательно перенаправить в файл или програму More), а для удаления лишней строки, после названия программы, избавляемой от попечения Setver, указывается параметр /D, например "Setver C:\windows\command Dosshel.exe /D".

Ansi.sys

Драйвер для представления MS-DOS в цвете. Он позволяет менять режимы работы дисплея, менять цвета, перемещать курсор по дисплею и переопределять клавиши. Может иметь параметр /x разрешающий переопределять все кода клавиш и /L обеспечивающий сохранение установленного режима, даже если какая-либо программа пытается его изменить (что может привести к зависанию компьютера и, если такое произойдет, параметр /L лучше удалить).

Среди возможностей предоставляемых этим драйвером, наибольший интерес представляет возможность управления цветом, для чего не экран различными способами выводится символ ¬ имитирующий нажатие клавиши Escape, после которого задаются режимы общего вида: [s… s,m где s является режимом отображения и может иметь множество значений.

Устанавливаются режимы отображения в командных (пакетных) файлах или из командной строки и может изменяться по ходу работы. Но установка самого драйвера осуществляется только через Config.sys.

Дополнительные сведенья о командах Config.sys, можно получить, открыв файл C:\Windows\Config.txt и MSDOSDRV.txt в том же каталоге, но удобней всего это сделать, открыв, находящийся там же HTML документ Readme.htm и перейдя на нужную гиперссылку. Выбрав в оглавлении интересующие сведенья, легко разыскать посвященный им раздел с помощью команды “Правка\Найти” (в поле ввода для поиска, искомое слово можно просто скопировать через контекстное меню).

Такие “мелочные” подсчеты в MS-DOS не напрасны. Сэкономив на каждой команде по килобайту, можно получить дополнительные 10-20 килобайт для размещения прикладных программ, которым этих 10-20 килобайт может и не хватать.


Титульный лист

Энциклопедия

Предварительные сведенья

Оптимизация на простейшем уровне

Компоненты ядра MS-DOS

Порядок загрузки компьютера

Меню загрузки Windows 98

Работа в MS-DOS

Загрузка MS-DOS, установка Windows

Некоторые расширения

Создание и форматирование дисков

Инсталляция оборудования

Команды клавиатуры

Некоторые программы

Файлы конфигурации

Config.sys

Autoexec.bat

Коды возврата

Представление MS-DOS в цвете

Вирусы

Виртуальный диск

Доступ к CDROM

Архиваторы MS-DOS

Русификация MS-DOS

Диалоговые файлы

Создание загрузочных дискет

Системный реестр

Разрешение проблем MS-DOS

Нечитаемость и неудаляемость

Отказ компьютера от загрузки

Резервное копирование


Оптимизация и спасение IBM PC

Эта страница содержит рамки, однако текущий обозреватель их не поддерживает.


Начинайте обзор с файла Main.htm. Значек Справочник.ico может пригодится для создания ярлыка.


Автоматический поиск виртуального диска.

В отношении оперативной памяти применима та же система адресации, что и в отношении дисковой, в результате чего, часть оперативной памяти может использоваться под временное хранение файлов, подобно обычному диску, со свойственной ему файловой структурой и системой каталогов. Поэтому, память отведенную для хранения файлов, называют виртуальным (электронным) диском.

Виртуальный диск используется для ускорения выполнения программ и временного хранения файлов извлекаемых из дискет. Однако, создание виртуального диска и копирование на него программ для ускорения их запуска, процесс довольно продолжительный, ни чуть не уступающий по продолжительности запуску этих же программ с обычных дисков, и применение виртуального диска только лишь для ускорения запуска программ вряд ли имеет смысл. Но при работе с дискетами, виртуальный диск может оказаться необходимым. Он позволяет использовать программы, не вмещающиеся на одной дискете (посредством сборки на нем единой программы из разрозненных частей расположенных на нескольких дискетах или распаковки программы содержащейся на дискете в сжатом виде).

Поскольку виртуальный диск по своим функциям полностью аналогичен жестким дискам, при его образовании, ему назначается синоним, соответствующий очередному жесткому диску (синонимы CDROM и других съемных носителей при этом смещаются на один символ к концу алфавита) и определение буквы вмртуального диска не представляет какой-либо сложности. Тем не менее, во многих случаях удобно использовать ее автоматическое определение.

Подобная автоматизация полезна для дискет могущих применятся на разных компьютерах или на компьютере, в котором количество жестких дисков может быть изменено (при изменении числа дисков на компьютере, переделка однажды составленной и проверенной дискеты с автоматическим определением буквы, не потребуется), а так же для случаев, когда какой-либо из дисков оказался недоступен, а значит и не занял соответствующую ему букву.

Для создания виртуального диска достаточно через Config.sys подключить драйвер RamDrive.sys и указать требуемые параметры создаваемого диска, например:

Devicehigh Ramdrive.sys /E 5120

Остальное управление происходит либо через Autoexec.bat, либо в ручную.

Через Autoexec.bat на него можно скопировать необходимые файлы и установить пути их поиска командой Path. Например:

Copy a:\Файл Буква:

Path Буква:

Где буква – буква, символизирующая созданный виртуальный диск.

Если файлы сжаты, их распаковку так же можно произвести автоматически, указав в этом же файле команду запуска MS-DOS-распаковщика.

Если же требуется, чтобы буква диска определялась автоматически, требуется обнулить переменные Ramd и CDROM и запустить программу FindRamd.exe (имеющую размер 7 килобайт), которая выдаст код возврата соответствующий букве полученной диском (зависящей от количества доступных логических разделов). После чего, по коду возврата устанавливается переменная Ramd и CDROM.

Наиболее удобно все эти процедуры произвести через специальный файл, обычно называемый SetRamd.bat, вызываемый из файла Autoexec.bat. Перед его вызовом в Autoexec.bat устанавливается переменная, содержащая параметры вызова, что позволяет сократить SetRamd.bat в несколько раз. Команды установки переменной имеют вид:

set LglDrv=27 * 26 Z 25 Y 24 X 23 W 22 V 21 U 20 T 19 S 18 R 17 Q 16 P 15

set LglDrv=%LglDrv% O 14 N 13 M 12 L 11 K 10 J 9 I 8 H 7 G 6 F 5 E 4 D 3 C

В таком случае, команда вызова SetRamd.bat выглядит так:

call setramd.bat %LglDrv%

Сам файл при этом имеет следующее содержание:

@echo off

set RAMD=

set CDROM=

a:\findramd

if errorlevel 255 goto no_ramdrive

if not errorlevel 3 goto no_ramdrive

goto do_shift

:loop

if errorlevel %1 goto no_shift

:do_shift

set cdrom=%2

shift

shift

if not %1*==* goto loop

goto no_ramdrive

:no_shift

set ramd=%2

if "%RAMD%"=="C" goto c_drive

goto success

:c_drive

cls

echo Disk C no FAT32!

Pause

goto success

:no_ramdrive

cls

echo No Virtual Disk!

Pause

:success

И выполняет все необходимое для установления переменной RAMD, содержащей букву символизирующую виртуальный диск, а так же, сообщающий о проблемах, если таковые возникнут при создании диска. При этом, сообщение “No Virtual Disk!”, как правило, выдается при невозможности создать виртуальный диск из-за недоступности должного количества оперативной памяти, а сообщение “Disk C no FAT32!”, соответствует недоступности диска С, например, из-за несоответствия операционных систем или из-за повреждения главной загрузочной записи, в том числе, действием вирусов.

После автоматического определения буквы диска, операции с ним можно производить через переменную Ramd и, вышеприведенные команды Autoexec.bat видоизменяются до:

Copy A:\Файл %Ramd%:

Path %Ramd%:

И тому подобное, в результате чего, запланированные операции выполняются именно с виртуальным диском, не зависимо от назначенного ему символа, действия вирусов и разницы операционных систем. Обращение к диску непосредственно через букву, остается в силе, но в автоматически исполняемых файлах не срабатывает, если диск по каким-либо причинам получил не ту букву, которая планировалась.


Вирусы

Понятие компьютерного вируса

Вирусы представляют собой небольшие программы, при своем запуске дописывающие себя к другим программам, чтобы уже, при их, запуске, производить новые, более опасные действия. Аналогом вируса служит следующий Bat-файл:

@ATTRIB –r C:\Autoexec.Bat

@ECHO @cls >> C:\Autoexec.Bat

@ECHO @echo _______________________СУШИ ВЁСЛА. ______>> C:\Autoexec.bat

@ECHO @CTTY NUL >> C:\Autoexec.Bat

@DEL %0

Принцип действия которого становится ясен после знакомства с командами Bat-файлов (последняя команда “заметает следы”).

Если в команде удаления указать реальное название файла-вируса, а перед ней вставить команды “@for %%n in (*.bat) do copy /y %%n+%0 > nul” и “@CLS” (последнее – опять для маскировки), вирус будет еще и размножатся , заражая все командные файлы находящиеся в одной папке с его носителем (при желании можно увеличить область распространения и разрушающий эффект, но с этим лучше не экспериментировать).

И, хотя настоящие вирусы построены более изощренно и вместо обращения к командам операционной системы, обращаются непосредственно к командам процессора, принцип действия у них тот же. Они пишутся, обычно на Ассемблере и программами-компиляторами превращаются в Exe-файлы, понять назначение которых могут только программы-антивирусы.

Вирусы заражают только файлы, которые могут быть приведены в исполнение – программы, загрузочные сектора (в загрузочном секторе любого отформатированного диска содержится программа загрузки операционной системы, которая, собственно, и заражается), и драйвера. Документы и другие файлы не могут содержать готовых к исполнению вирусов, но могут быть ими повреждены или уничтожены (для чего вирусы и создаются). Тем не менее, некоторые файлы, не относимые непосредственно к программам, содержат в себе программы и могут быть заражены (стать носителями). К таким файлом относятся оверлейные файлы и интерактивные документы, содержащие макросы – простейшие программы управления документом. Вирусы, содержащиеся в макросах, заражают шаблоны, вследствие чего зараженными оказываются все созданные на их основе документы. В таких документах периодически возникают спонтанные, неподконтрольные изменения, вплоть до удаления из них всей информации.

Попадание вируса в компьютер приносит если не материальный, то, по крайней мере, моральный ущерб. Их преднамеренное распространение равносильно злостному хулиганству и отсутствие соответствующих статей в уголовном кодексе необъяснимо.

Типы вирусов

Простейшие вирусы истребляются при первых же попытках распространения и их появление на компьютере – нечто из области фантастики. Реальную возможность распространятся, имеют только:

САМОМОДИФИЦИРУЮЩИЕСЯ ВИРУСЫ – систематически меняющие собственный код (полиморфные), в результате чего, антивирусные программы никогда не знают, в каком обличии те предстанут, а потому, не всегда умеющие их распознать.

МАКРО-ВИРУСЫ – содержащиеся в макросах и практически нераспознаваемые в силу того что, программы не знают, является ли действие, запрограммированное в макросе вирусным или же, так и должно быть.

СТЕЛС-ВИРУСЫ – находящиеся в памяти резидентно и полностью контролирующие операционную систему, в результате чего, антивирусные программы работают под их управлением и могут обнаружить их только в том случае, если они сами того захотят.

Защита от вирусов

Для защиты от вирусов, нужно, прежде всего, на все, на что только возможно, поставить атрибут “Только для чтения”. Есть вирусы равнодушные к этому атрибуту, но, по крайней мере, часть вирусов, ничего не смогут сделать с файлом его имеющим.

Помимо защиты атрибутом, для защиты компьютера требуется перед установкой, запуском или копированием новых программ и документов проверить их на наличие вирусов. Для этой цели лучше всего подходит программа AVP (AntiViral Toolkit Pro), содержащая непревзойденную по своим размерам базу данных (библиотека от 20.04.1999г. содержит описание для распознания 26 369 вирусов). Как и все приличные программы, она так же производит эвристический анализ, выискивая в программах подозрительные места, так что фактически, обнаруживает любые вирусы, если не находится под их гипнозом (а пока вирусы не приведены в исполнение, никаким гипнозом они не обладают). К тому же, программа имеет хорошие сервисные функции: для проверки свежеприобретенного диска, достаточно вставить его в дисковод и, щелкнув по его ярлыку правой кнопкой мыши, выбрать в появившемся контекстном меню пункт “AntiViral Toolkit Pro” (аналогично с папкой и конкретным файлом). Желательно, чтобы при этом, она была настроена на проверку всех файлов, в том числе, внутри архивов. То, что сканирование займет пару-тройку минут – не страшно – не так уж и часто подобную процедуру требуется проводить.

Эта же программа наиболее эффективна в борьбе с самомодифицирующимися вирусами и, не распознав их перед установкой, наверняка вычислит при попытке навредить – для чего служит ее резидентный модуль “AVP Монитор”.

Правда, AVP Монитор не только перехватывает подозрительные операции, но и сверяет все запускаемые программы со своими не мерянными библиотеками, что неизбежно отражается на скорости их запуска – при этом, совершенно напрасно, ведь программы проверялись перед установкой, а для их заражения после установки потребовалось бы активировать вирус, действия которого, AVP Монитор должен был бы заблокировать. То есть он проверяет заведомо чистые программы или программы, зараженные вирусом, который ему просто не по зубам.

К сожалению, отключение этой функции не предусмотрено и для ее выполнения требуется установить проверку по маске, а саму маску оставить пустую.

Кроме того, при эвристическом анализе, позволяющем обнаружить действительно все вирусы (если это не активировавшиеся стелс-вирусы), программа склонна к ложной тревоге, объявляя вирусом, например Format.com (при чем, на всех проверенных дистрибутивах), в силу того что тот содержит установки на форматирования диска, считаемые AVP откровенно-преступными. Но ведь на то он и Format.com чтобы форматировать диск! А ввести исключения, для каких-то заведомо чистых программ в AVP нельзя.

По этому, при условии, что все входящее в компьютер программное обеспечение перед установкой проверялось на наличие вирусов, для непрерывного мониторинга, даже при работе в сети, лучше применять более скромные программы, которые так же остановят вирус при попытке нагадить, но менее заметно отразятся на быстродействии компьютера. Например, антивирусный сканер из нортоновских утилит или автозащиту из Norton Antivirus 5.0. Возможности последнего гораздо скромней чем у AVP (библиотека от 10.05.99 содержит данные всего на 21 753 вируса, кроме того, блуждающих по калифорнии, а не в степях Украины), но, учитывая, что это всего лишь подстраховка, такого количества вполне достаточно. Тем более что, главная задача – схватить вирус на месте преступления будет выполнена. Да и с распознанием неизвестных вирусов он знаком, хотя не вполне адекватно на них реагирует и, вместо "подозрение на неизвестый вирус", сообщает: "Обнаружен Bloodhound Virus" (Bloodhound – технология поиска еще неизвестеых вирусов).

Программа очень покладиста и до тех пор, пока не будет предпринята попытка привести к исполнению инфицированный файл, о работе автозащиты можно и не подозревать – приятно, когда не возникает лишних тревог – а, кроме того, позволяет вводить исключения и автоматически проверяет загрузочные сектора дискет – главный источник стелсов. И, что так же, не мало важно, нортоновская автозащита загружается в память до загрузки основных программ Windows – гораздо раньше, чем AVP монитор – а значит, имеет больше шансов не допустить загрузку вирусов.

Norton Antivirus хорошо так же и тем, что делает “критические снимки” хранимых данных для отслеживания всевозможных изменений, некоторые из которых могут быть вызваны действием вирусов, а в случае чего, предоставляет возможность восстановить данные по этим снимкам независимо от способа их порчи (хотя конечно не всесилен). Подобный сервис имеет и AVP, но выполненый в виде отдельной утилиты – AVP инспектор, что не очень удобно, хотя и предоставляет большие возможности.

Антивирусный датчик из нортоновских утилит не является подлинным монитором, он – автоматический сканер, проверяющий диски и память через указанное ему время, и не преграждает путь вирусоподобным действиям. К тому же, его вирусные библиотеки обычно на год отстают от Norton Antivirus, по этому, его применение имеет смысл лишь в условиях, где заражение вирусами практически исключено или, в условиях отсутствия настоящих мониторов.

Лечить антивирусный датчик не может.

В борьбе с макровирусами лучше всего участвовать самому. Для этого в общих параметрах редактора Microsoft Word следует установить значок “Защита от вирусов в макросах” (аналогично с ярлыками интернет). Тогда при попытке открытия документа содержащего макрос, на экране появится соответствующее предупреждение, после которого можно либо открыть документ, не открывая макросов, либо вообще отменить открытие.

При желании рискнуть, можно проверить документ с помощью AVP и если тот даст добро, открыть вместе с макросами. Но сколько бы добра не давал AVP, перед открытием документа с макросом, желательно убедится в наличии резервной копии шаблона NORMAL, а еще лучше, зарезервировать все документы и если с течением времени с документами начнется непонятное, обновить шаблон из резерва. Если это не поможет (документы уже заражены), и если никакие антивирусы не помогают, документы либо отчищаются от макросов в ручную, либо резервируются в ТХТ-формате, где не остается ни одного макроса, либо копируются без макросов в Word Pad. После перенесения в другой формат, все исходные документы и шаблон уничтожаются, из резерва восстанавливается чистый шаблон (или создается заново) и документы опять открываются в нем. Все это занимает какое-то количество времени, но если большинство из них имеют копии в архиве – очень небольшое.

Однако, поскольку это все же занимает какое-то количество времени, из одного только любопытства макросодержащие документы и неблагонадежные ярлыки интернета лучше не открывать.

Борьба с вирусами-невидимками (стелс-вирусами) – головная боль любого антивируса. Главное тут – не допустить их запуска. Тогда их можно обнаружить и удалить (лечить, зачастую, не удается).

Norton Antivirus для этой цели загружает свой небольшой модуль NAVDX.EXE через Autoexec.bat, когда программы только начинают загружаться, и сразу же проверяет память и наиболее важные файлы (можно проверить все остальное, но тогда загрузка затянется действительно на долго). Такая мера полезна, но мало эффективна, так как, во первых, если в силу ограниченности антивирусных библиотек и области поиска NAVDX не распознал вирус, тот может загрузиться в промежутке между проверкой NAVDX и загрузкой программы-монитора (в таком случае монитор станет послушной игрушкой в руках стелс-вируса), во вторых, как это обычно у таких вирусов и происходит, вирус может загрузиться, прямо с загрузочного сектора, опережая даже загрузку Io.sys и MSDOS.sys, вследствие чего запуск NAVDX практически теряет смысл, и хотя обычные резидентные вирусы будут им обнаружены и обезврежены, прежде чем успеют навредить, качественный стелс обведет его вокруг пальца.

Классический AVP рассчитан для работы в Windows и до его загрузки ни чего не предпринимает, и если Norton Antivirus с невидимками хоть как-то борется, то AVP против них фактически бессилен – действительный удар по стелс-вирусам можно нанести, только загружаясь с чистого диска. По этому, при подозрении, что на компьютере злочинствует вирус (если это не макро-вирус), не обнаруживаемый ни одной антивирусной программой, работу компьютера требуется немедленно прекратить, пока этот вирус (если это действительно вирус), не отобедал чем-нибудь, особо ценным и загрузится с чистой, защищенной от записи загрузочной дискеты. При такой загрузке, попасть в оперативную память стелс-вирус может только из BIOS, а значит, антивирусная программа будет работать в стерильной обстановке.

MS-DOS-антивирусы

DrWeb

Вообще, MS-DOS-антивирусы хромают на обе ноги и нуждаются в костылях. Широко распространенная программа DrWeb – ярчайший тому пример. Ее убогая база данных (библиотека от 30.04.99г. содержит данные всего на 11 427 вирусов) и другие недостатки вызывают у составителей вирусов смех. В свой “продукт” они даже включают издевательские послания И. А. Данилову – автору DrWeb (для них причинение ущерба окружающим – только способ доказать что они умнее всех).

Вот одно из них (отредактированное):

“NAME: MPEI

Данилов, ты – чайник, такой же тормоз как и Билл Гейтс (ты поймешь).

Вирус, которому ты дал имя "AMD" на самом деле назывался

“Windows 95 MUST DIE!!!”,

А строчку “Windows 95 MUST DIE!!!”, он слал в виде мессаги по сети.

Принеси свои извинения и, кстати, напиши Upgrade для юзеров.

DRWEB очень хорошо разносит заразу по компьютеру. Эффект на 1000%

И еще, лучше бы ты через DMA-бластер программил!

Жду версий под Windows 9-ых – вот там ты поработаешь через DMA.

Балбес, ты Лозинского без работы оставил!!!

Copyleft © Down'niloff Corp.,2000. All Lefts Preserved.

Григорчук.”

Некоторые вирусы отечественного производства, действие которых DrWeb должен распознавать, сами распознают запуск DrWeb и начинают водить ее за нос…

…но если где-то, на начальном этапе загрузки компьютера в систему проникает стелс-вирус (если это действительно, стелс-вирус), иного способа борьбы с ним может не быть.

В состав DrWeb входят:

DRWEB.EXE – Программа Doctor Web

DRWEB.HL1 – Файл интерактивной справки на русском языке

DRWEB.INI – Файл настройки

DRWEB.PGP – Удостоверяющая подпись программы

DRWEBASE.VDB – Основная вирусная база

DRWvvvnn.VDB – Дополнительные вирусные базы, где VVV – номер версии программы, а NN – номер дополнительной базы.

Все эти файлы можно скопировать на загрузочную дискету (исключение справки крайне нежелательно, поскольку в ней содержатся так же и сообщения программы, но ее можно отредактировать, удалив лишнее), чтобы иметь не только заведомо чистую операционную систему, но и заведомо чистую антивирусную программу.

Для того чтобы скрыть факт запуска программы DrWeb от не в меру интеллектуальных вирусов, И. А. Данилов рекомендует присвоить файлам DrWeb.exe, DrWeb.ini и DrWeb.hl1 новое имя (например: Волкодав.exe, Волкодав.ini и Волкодав.hl1 – вообще, неанглоязычные имена уже и сами по себе достаточно хорошее прикрытие), но при загрузке с действительно чистой дискеты, это не понадобится: пока вирусы мирно дремлют на убитом ими винчестере, DrWeb передушит их как котят.

Вызов DrWeb возможен как в интерактивном, так и в обычном MS-DOS-режиме (пакетном).

Многие пользователи почему-то считают, что программа сканирует только память, (вероятно потому, что с этого все и начинается), но это не так. Она сканирует все что угодно, но для этого не достаточно просто вызвать программу: требуется указать область сканирования. По этому, по окончании сканирования памяти нужно открыть меню “тест” и выбрать пункт “тестирование”. Но лучше выбрать “лечение”, предварительно в пункте “параметры” меню “настройки” указав, что зараженные файлы нужно лечить с запросом перед лечением. Тогда, с одной стороны, в случае обнаружения вирусов, не придется искать их заново для лечения, с другой – ничто с диска не исчезнет автоматически. А сканирование памяти, с которого обычно начинается работа программы, можно вообще отключить – для этого при ее вызове указывается параметр /NM .

Среди прочих параметров полезно назначить временным диском виртуальный диск (для этого перед настройкой параметров требуется создать этот диск – DrWeb, даже теоретически не признает не существующих дисководов и не может смотреть в будущее) и на виртуальном же диске создавать файл отчета (захочешь – посмотришь, не захочешь – он сам исчезнет после перезагрузки и не будет бес толку валяться в компьютере). Остальную информацию можно получить, прочитав файл DrWeb.Me прилагающийся к программе. Как и все документы MS-DOS, он написан в коде ASCII (Terminal). Однако, на всякий случай (трудно просмотреть файл, на убитом вирусами компьютере):

/AL – проверка всех файлов (по умолчанию только имеющих внутреннюю структуру программ, в том числе и документов Word – чего вполне достаточно, чтобы уморить ожиданием)

/CL – работа в пакетном режиме, без диалоговой оболочки

/FN – загрузить собственный знакогенератор (русификатор экранного шрифта)

/SD- – не проверять вложенные каталоги

/HA – избыточное сканирование (эвристический анализ) с максимальной подозрительностью

ESC – клавиша прекращения сканирования, при работе в интерактивном (диалоговом) режиме

F10 – открытие меню

ALT+F4 – закрыть программу

F1 – справка

ВНИМАНИЕ: если нет гарантии, что в памяти компьютера не находится резидентный вирус-невидимка (а такую гарантию может выдать только сам, находящийся в памяти вирус), при проверке дисков, через меню “Настройки\Параметры” необходимо установить опцию контроля над резидентными вирусами, иначе, при чтении программ для проверки на наличие вирусов, программы будут автоматически заражаться (и антивирус распространит вирусы по всему компьютеру). Если же, данная опция установлена, то при первом же заражении, вирус выдаст себя неизбежным изменением размера программы и DrWeb схватит его за руку (правда, для этого необходимо чтобы вирус либо “не знал” о запуске DrWeb, либо не был обучен затихать на время его работы).

Для установки контроля над резидентными вирусами в пакетном режиме, его вызов производится с параметром /RV.

NAVDX

Это вполне серьезная антивирусная программа MS-DOS. Являясь частью Norton Antivirus под Windows, она использует одни с ним библиотеки и распознает вирусов в два раза больше чем DrWeb.

К сожалению программа не вмещается на одной дискете, а наши хакеры, только благодаря которым и стало возможным распространение вычислительной техники на территории бывшего СНГ, не догадываются выпускать компакт-диски с готовым к применению нортоновским антивирусом под MS-DOS. По этой причине, использование NAVDX при загрузке с дискеты имеет некоторые трудности.

В состав программы входят:

Exclude.dat

Excludel.dat

Navdx.exe

Navdx.ovl

Navex15.exp

Navopts.dat

Navstart.dat

Virscant.dat

И еще несколько файлов Virscan1.dat, Virscan2.dat и так далее, в которых, собственно и содержатся данные о вирусах. Расположены указанные файлы в нескольких папках: часть из них расположена в папке содержащей Norton Antivirus, часть – в одной из подпапок Program Files\Common Files\Simantec Shared\VirusDefs – дальнейший путь может различаться в зависимости от версии.

Разместить все эти файлы целиком на одной дискете не удастся (если не сокращать библиотеку), так же, не удастся их нормально разделить. Файл Navex15.exp должен находится в одной папке с “вирсканами”, а это уже более полутора мегабайт (остальные файлы могут содержатся отдельно, в таком случае работоспособность программы обеспечивается добавлением файлов DefLoc.dat и DefInfo.dat с соответствующими указаниями, где первый указывает расположение второго, а тот – расположение библиотек или вводом адреса библиотек в виде параметра при вызове NAVDX).

Программа Rescue входящая в состав Norton Antivirus, автоматически создавая загрузочные дискеты, поступает весьма хитро: она делит NAVDX на две части, (из трех изготовляемых ей дискет первая содержит программу Rescue и системные файлы MS-DOS, а две следующие отдаются под антивирус) ограничивая число переносимых на дискету библиотек. За неимением лучшего, пойдет и урезанная версия, но кто сказал, что лучшего нет?

Был бы MS-DOS-распаковщик, а сжатый чуть ли не до мегабайта NAVDX будет к нему приложен. После загрузки с чистой загрузочной дискеты, дискета с NAVDX вставляется в дисковод, ее содержание копируется на виртуальный диск и распаковывается – гуд бай 21 753 вируса. Правда виртуальный диск имеет один недостаток: существует несколько вирусов, шифрующих загрузочные записи так, что без них доступ к жесткому диску не возможен; NAVDX справляется с этим, читая диски не средствами MS-DOS, а напрямую, но при создании в этой ситуации виртуального диска, виртуальный диск получает букву “С” (как единственно доступный жесткий диск) и как тогда NAVDX найдет реальный диск С, неизвестно. Впрочем, в этом (очень редком) случае, существуют компьютеры у знакомых, где NAVDX можно распаковать и перезаписать на три дискеты, где первая будет содержать сам антивирус с оверлеем, а две следующие – по половине библиотеки и Navex15.exp.

Важнейшие параметры запуска программы:

/Heur3 – максимальная подозрительность к объектам

/Prompt – запрос на санкции к подозрительным и зараженным (по умолчанию только поиск)

/Repair – автоисправление

/Delete – автоудаление зараженных

/DoallFiles – проверять все файлы (по умолчанию только программы – именно они источники заражения, даже если остальные файлы испорченны, заразить они не могут и, учитывая что, сканирование в MS-DOS занимает невероятно много времени, их проверку лучше проводить из Windows).

/Zips – проверять так же, в архивах (только самораспаковывающийся архив – содержащий программу распаковки – может быть заражен, остальные могут быть только испорчены, если, конечно, в них не упаковали уже инфицированные программы и то, эти программы самостоятельно из него не вылезут)

/Mem – проверить только память

/Log: – создать файл отчета (с указанием имени файла)

Значения по умолчанию содержатся в файлах NavOpts.dat – маски тестирования и принимаемые меры; NavStart.dat – определения тестирования при запуске с параметром /Startup (обычно используется на стадии загрузки в Autoexec.bat); Exclude.dat – нетестируемые файлы – и задаются при конфигурировании Norton Antivirus под Windows.

Дополнительные параметры, применяемые при разделении программы:

/cfg: – каталог, содержащий библиотеки

/Opt: – каталог, содержащий файлы настройки

Если при вызове программы не задан объект тестирования, но задана функция лечения, запроса на санкции или удаление, это расценивается как команда проверки памяти и всех файлов имеющих структуру программ, на всех доступных дисках. Если вообще ничего не задано, это работает как вызов справки.

Работает программа в два раза быстрее, чем DrWeb.

AVP под MS-DOS (версия 3.0 Build 129).

Полностью аналогична своему старшему брату из Windows и пользуется теми же библиотеками. В сжатом виде она вмещается на дискету и является наилучшим средством для борьбы с вирусами из заведомо чистой среды . Однако, ее немерянные антивирусные базы требуют немерянного места в памяти и, тут уж приходится попотеть над каждым байтом. Однако, если сокращение загружаемых драйверов и прочего не желательно, вместо AVP можно воспользоваться ее безынтерфейсным вариантом – AVPlite – занимающим меньше места в оперативной памяти и управляемым из командной строки.

В состав AVP под MS-DOS входят:

AVP.KEY

AVP.LNG

AVP.OVL

AVP.SET

AVP.VND

AVP.EXE

AVPLITE.EXE

DEFAULT.PRF

И множество файлов с расширением .AVC являющимися антивирусными описаниями.

Важнейший параметр вызова:

/LR! – после которого программа принимает русский язык по умолчанию.

Работает программа в два раза быстрее Navdx и в четыре раза быстрее DrWeb.

AdInf.

Эта программа аналогична программе AVP инспектор и, по сути, не является истинным антивирусом. Она предназначена для отслеживания всевозможных изменений на диске, произошедших за прошедшие сутки – те же функции выполнит программа поиска файлов входящая в состав Windows, в режиме поиска всех измененных файлов за последний 1 день. Однако, наличие дополнительных функций делает программу AdInfo удобной для обнаружения вирусов, сумевших просочится сквозь антивирусную оборону, а подключаемый к ней лечащий модуль позволяет их не только найти, но и обезвредить (поэтому, многие вирусы, считают своей первостепенной задачей найти и обезвредить программу AdInfo).

Проверяет программа, также, и изменения в оперативной памяти, что позволяет ей обнаруживать активированные резидентные вирусы, в том числе и стелс.

Большим плюсом программы является наличие собственного знакогенератора, позволяющего ей загрузится сразу после загрузки Command.com, не дожидаясь загрузки экранных русификаторов, а значит – обнаружить вирусы на самом раннем этапе загрузки, пока они еще не успели натворить новых бед.

Большим минусом программы является обнаружение вирусов задним числом, после того, как некоторые файлы от него уже пострадали. Однако, если другие антивирусы проморгали вирусную атаку, то AdInfo, не допустит хотя бы дальнейших бедствий.

Различные вирусы

3apaзa – файлово-загрузочный вирус. Заражает Boot-сектора дискет и Io.sys жесткого диска.

При загрузке с инфицированной дискеты вирус считывает в память 5 секторов корневого каталога загрузочного раздела жесткого диска, проверяя наличие метки тома. Если она установлена, диск считается уже зараженным и никаких действий не производится.

Если же атрибут метки тома не установлен, вирус считывает с жесткого диска файл IO.SYS, копирует его в последние 256 кластеров логического раздела, проверяя, достаточно ли там места; корректирует FAT в соответствии с дублированием IO.SYS благодаря чему, средствами операционной системы отображается только этот дублер; копирует служебные поля IO.SYS в третий элемент корневого каталога, сдвигая все оглавление с третьего элемента по 80, и тем самым, уничтожая 80-ый элемент (файл или каталог); устанавливает для третьего элемента (копии IO.SYS) новый начальный кластер и, вдоволь натрудившись, подкрепляется оригиналом IO.SYS, записывая в него 1024 байта своего кода. После чего, устанавливает метку тома, чтобы остальная братва знала: домик занят. Когда же, при загрузке системы с жесткого диска, в память загружается файл под именем Io.sys, в память, на самом деле, резидентно загружается вирус, поскольку от настоящего Io.sys, там осталось только название (размер свободной памяти, при этом, сокращается на два килобайта).

Получив управление при загрузке с жесткого диска, вирус находит и считывает в память запрятанный в конце диска дубликат IO.SYS, благодаря чему, дальнейшая загрузка системы происходит как обычно и подозрений не вызывает. Между тем, вирус понемногу перехватывает INT 13h – прерывание, служащее для чтения и записи на диск (или INT 16h, служащее для ввода команд с клавиатуры – если это 3APA3A 2), и заражает загрузочные сектора попадающих в компьютер дискет, шифруя при этом свой код, для усложнения распознания одним из 12 имеющихся при нем кодировщиков. А для разнообразия, при загрузке системы в августе месяце он выводит сообщение: “B BOOT CEKTOPE 3APA3A!”

При попытке вылечить заразу, загрузившись с чистого диска и введя команду SYS C: (для перезаписи системных файлов), вирус не удаляется. Команда, основываясь на данных FAT (откорректированных вирусом), произведет перезапись только файла-дублера IO.SYS. И если она его вдруг запишет на новое место, то система вообще перестанет загружаться с жесткого диска, т.к., вирус не найдет этот файл, чтобы загрузить его в память.

Anarchy – резидентный полиморфный стелс-вирус. Заражает COM, EXE файлы, а также DOC-файлы для WinWord версий 6.0-7.0.

При открытии инфицированного, документа с помощью Microsoft Word, вирусный макрос создает на диске EXE-файл в формате Win NewExe (NE), записывает в него код вируса и приводит в исполнение. Тот, в свою очередь, производит заражение командного процессора (COMMAND.COM) и программы WIN.COM, после чего удаляется, заметая следы.

При следующей загрузке компьютера, вирус запускается из зараженного Command.com или Win.com, еще до загрузки Windows и рассчитанных под Windows антивирусов, что позволяет ему контролировать их загрузку и работу, а при открытии любого документа текстовым процессором Word, автоматически его заражает, зачастую, полностью разрушая. В довершение ко всему, 8 и 30 апреля, а также 9 мая вирус выборочно уничтожает содержимое первого жесткого диска.

Предусмотренная в MsWord защита от вирусов в макросах в отношении данного вируса срабатывает только до тех пор, пока тот не стал резидентным, иначе она им просто отключается.

Amz – нерезидентный вирус. В зависимости от модификации, 24 сентября, 1 марта или 13 сентября выборочно уничтожает информацию на всех доступных дисках. Amz.1100 также иногда уничтожает содержимое CMOS-памяти (энергозависимая, перезаписываемая составляющая BIOS) и создает файл BOPS-BOP.S.

Dead – резидентный вирус. Ведет счетчик заражений внутри файлов. Как только число зараженных файлов достигает 255, вирус уничтожает содержимое диска D.

Ear.Leonardo – нерезидентный шифрованный вирус. В зависимости от своих счетчиков может удалить все файлы в текущей директории, файлы c:\autoexec.bat и c:\config.sys, или записать в начало файла c:\io.sys текст "Leonardo v 2.0".

ExeBug – загрузочный стелс-вирус. Иногда записывает в EXE-файлы троянский код, уничтожающий содержимое жесткого диска. Некоторые модификации вируса постоянно включают и выключают в CMOS-памяти признак наличия флоппи-дисководов. При обращении к флоппи-дискам вирус “включает” наличие дисководов в CMOS, после обращения – “отключает”. В результате, при загрузке с чистой системной дискеты, дисководы могут оказаться “неустановленными”, и система начинает загружаться с инфицированного жесткого диска. Вирус, первым получив управление, установит свою резидентную копию в память, “включит” наличие дисководов и отдаст управление Boot-сектору диска A, так что, подключение и активизация вируса останется незамеченной. В результате, вирус получат управление даже при загрузке с чистого гибкого системного диска и, достижение чистой среды, при заражении этим вирусом, без проверки данных CMOS, практически невозможно.

Ls.1829 – не опасный нерезидентный вирус. Иногда приводит к зависанию компьютера, может вывести текст: “I love you, girls! You are so beautiful!”.

Ck.761 – резидентный вирус. Удаляет файлы CHCKLIST.MS. В 0 часов выводит текст: “You iave a •GLUCK•!!!” и “трясет” экран. При старте программы DRWEB.EXE выводит текст “Error reading fat!” и завершает ее работу.

CMOSDead – резидентный шифрованный вирус. Примерно через год после попадания на определенный компьютер, уничтожает содержимое CMOS-памяти.

Bauman – нерезидентный вирус. Будучи запущен из какой–нибудь программы в пятницу, во второй половине дня уничтожает информацию на первом жестком диске. Оставляет в памяти резидентную копию, которая “гуляет” по разным адресам памяти и удаляет антивирусные программы с именами DRWEB и AVP при их запуске.

BAT.Batalia.2011 – полиморфный вирус, заражающий BAT-файлы в текущем каталоге. При заражении файлов вирус использует архиватор ARJ, если тот доступен через переменную среды PATH (вообще, этот архиватор очень любим вирусами).

Инфицированный вирусом BAT-файл состоит из двух частей: первая содержит пять команд DOS, а вторая, является заархивированным с помощью ARJ-архиватора BAT-файлом, имеющим случайное имя. Заархивированный BAT-файл, в свою очередь, также содержит команды DOS и еще один ARJ-архив. При этом команды DOS являются основным телом вируса, производят поиск файла-жертвы, заражение и создание полиморфного кода . Они выбираются случайным образом и, выполняемые ими действия в каждом конкретном случае различны. Вторая часть – ARJ-архив – защищена случайным паролем, запрещающим доступ к архиву и, не распознаваема антивирусами.

При запуске инфицированного BAT-файла, вирусные команды запускают архиватор ARJ для распаковки второго BAT-файла и передают ему управление. Этот BAT-файл создает временный подкаталог S_G_W_W, разархивирует туда файлы из второго архива, обеспечивающие заражение всех найденных им BAT-файлов, затем удаляет временный каталог и заканчивает свою работу.

BAT.Highjaq – нерезидентный вирус-червь. Записывает свой код в WINSTART.BAT, ARJ-архивы и создаваемый вирусом системный драйвер. При старте инфицированного WINSTART.BAT-файла вирус создает файл C:\Q.COM, записывает в него свой код и запускает его из BAT-файла строкой: “dir \*.arj/s/b|c:\q.com/i” (команда DIR производит поиск всех ARJ-файлов и передает их имена вирусному файлу C:\Q.COM). Найденные архивы заражаются путем приписывания к ним еще одного поля в формате ARJ, содержащего неупакованный инфицированный файл WINSTART.BAT (данный файл, будет автоматически запускаться при старте Windows). После чего вирус (C:\Q.COM) проверяет, установлена ли его резидентная копия в памяти. Если нет, генерирует соответствующий код завершения (errorlevel) и заканчивает свою работу.

По данному коду завершения (если память не инфицирована) вирус в BAT-файле переименовывает файл C:\Q.COM в C:\ABCDEFGH.IJK (генерируя случайное имя) и дописывает в конец файла C:\CONFIG.SYS строку “INSTALLHIGH=C:\ABCDEFGH.IJK” для установки резидентной копии вируса при загрузке компьютера. Эта копия (вирус) будет перехватывать INT 8 и 21h и тем самым сообщать Bat-файлу о своем наличии, чтобы тот больше не суетился, и заодно, перехватывая обработчик INT 21h, блокировать запуск программ начинающихся на “W”. Однако, главная задача не в этом: загрузившись в память, вирус устанавливает контроль над COM-портами и отправляет по модему предназначенные для хакеров сигналы.

После получения этих сигналов, ожидающий их хакер звонит на модем и, получая от вируса управление, делает с компьютером все, что хочет, в том числе, добывает программы для обеспечения ими постсоветских пользователей или опустошает чужие счета в банке.

Общая стратегия

1. Запись и сохранение некоторых данных CMOS (количество головок диска и т. д.), чтобы потом, в случае чего, иметь возможность восстановить их вручную.

2. Метка тома на каждом диске и каждой дискете.

3. Защита от записиПроверка, перед копированием и установкой, программой AVP

4. Подключение первой строчкой Autoexec.bat программы AdInfo

5. Подключение через Autoexec.bat программы NAVDX с параметром /Startup или AVPlite с ограниченным числом проверяемых файлов, на худой конец – переименованной DrWeb, (последнюю, за счет собственного знакогенератора, заменяющего Display.sys и Ega3.cpi, можно выполнить раньше, чем любую другую команду Autoexec.bat).

6. Установка в MsWord режима защиты от вирусов в макросах

7. Проверка макросов с помощью AVP

8. Непрерывный мониторинг за вирусоподобными действиями (лучше всего – автозащитой от Нортона)

9. Периодическое сканирование компьютера на предмет содержания вирусов

10. Периодическая проверка при загрузке с эталонной дискеты

11. При возникновении подозрительный событий, перед исправлением ситуации различными утилитами, выяснить, нет ли на компьютере вирусов. При этом, перед загрузкой с дискеты, следует убедится, что наличие флопи-диска действительно обозначено в CMOS

12. Если вирусам удалось отформатировать диски, восстановить содержимое, во многих случаях можно программой UnFormat из нортоновских утилит; программа UnErase, из того же комплекта, поможет восстановить системные файлы, если было произведено только удаление, а не полное форматирование; программа Rescue восстановит данные CMOS и другие записи – перечисленные программы должны быть соответственно подготовлены и сохранены на дискете (UnErase и UnFormat, без какого-либо ущерба для дела могут быть запущенны прямо с CDROM, если находятся там в готовом к применению виде).

13. Необходимо наличие хотя бы одного загрузочного флоппи-диска или загрузочного диска CD-ROM.

Дополнительно

Антивирусные сканеры делают упор на поиске известных им вирусных кодов, но существование множества способов, позволяющих инсталлированным в память вирусам спрятать свой код (авторы антивирусов бессильны что-либо предпринять), приводит к тому что, если уж, использующий эти механизмы вирус установился, они его не замечают. Поэтому, надежная защита от стелсов обеспечивается ими только во время предварительной проверки данных перед перенесением на диск. Однако, если вирус еще и шифрован или слишком нов, они могут не обнаружить его и на этом этапе. В таком случае, не допустить активации вируса должен непрерывно включенный антивирусный монитор, но бывают ситуации когда применение монитора невозможно (например при перезагрузке в режиме MS-DOS), кроме того, заражение может происходить вполне легальным способом, не вызывая никаких подозрений… В общем, иногда вирусам все-таки удается заразить BOOT-сектор и файлы первоначальной загрузки и тогда, единственным гарантом безопасности (опять же – не абсолютным) могут служить только программы-ревизоры типа AdInf. Эти программы запоминают множество данных о состоянии диска и количестве свободной памяти, а при каждом новом запуске, проверяют, какие со всем этим произошли изменения. Организовываемые ревизорами проверки занимают не мало времени и проводить их чаще раза в сутки вряд ли целесообразно. Но если компьютер приходится перезагружать более одного раза в сутки (например, он выключается на время обеденного перерыва или его требуется перезагрузить после установки какой-либо программы), какая-то защита от загрузочных стелс-вирусов все-таки нужна.

Простой и эффективный способ обнаружения резидентных вирусов загружаемых на первоначальном этапе загрузки компьютера предоставляет программа NDOS, входящая в состав нортоновских утилит 8.0 для MS-DOS. Эта программа является интерпретатором команд, понимающим не только команды операционной системы MS-DOS, но и многое другие, не вошедшие в систему команд Command.com, но свойственные остальным высокоуровневым языкам программирования (в частности, языку QBASIC, с которым у NDOS наблюдается прямая аналогия), что существенно расширяет его возможности и сферу применения. Программа создавалась для замены Command.com, но может работать параллельно с ним, благодаря чему, ее применение не мешает загрузке Windows.

Несколько команд NDOS предназначены для проверки наличия свободной оперативной памяти. Именно они и интересны в данном контексте.

@DosMem[b] – генерирует число равное количеству доступной для MS-DOS оперативной памяти выраженной в байтах.

@EMS[b] – равное количеству свободной отображаемой памяти.

@Extended[b] – расширенной.

@XMS[b] – памяти подключенной драйвером HiMem.sys.

Команда “IF” имеет много дополнительных функций, одна из которых – оператор GE означающий “больше либо равно”. Комбинация этих команд позволяет определить наличие в памяти вирусов следующим образом:

Создается файл Test.bat содержащий четыре строки (в зависимости от применения менеджеров памяти, вторая строка может потребовать соответствующей коррекции):

@Echo off

Echo %@Eval[%@EMS[b]% + %@DosMem[b]%]

Pause

Exit

Команда NDOS /C Test для вызова этого файла помещается в Autoexec.bat вслед за командами устанавливающими русификацию экранных шрифтов, после чего компьютер перегружается. Появившаяся при перезагрузке цифра указывает суммарное количество памяти определенное математическим оператором @Eval. Она переписывается на листок, после чего нажимается любая клавиша для выхода из NDOS и продолжения обычной загрузки. Затем создается, собственно, программа-ревизор, включающая три бат-файла.

Первый (1.bat):

@echo off

set real=%@eval[%@dosmem[b]% + %@xms[b]% - 32868896]

if %real% ge 0 exit

SET NU=C:\DOS

be C:\dos\2.bat

echo Величина изменения байт.

Screen 20 45

echo %real%

screen 21 3

beep /d9 /f349 /d9 /f233 /d9 /f349 /d9 /f233 /d9 /f349 /d9 /f233 /d9 /f349 /d9 /f233

beep /d9 /f349 /d9 /f233 /d9 /f349 /d9 /f233 /d9 /f349 /d9 /f233 /d9 /f349 /d9 /f233

be C:\dos\3.bat

delay 10

be reboot /c /v

exit

где вместо приведенной цифры подставляется реальная величина свободной памяти, полученная при тестировании файлом Test.bat; программа Be из тех же утилит облегчает достижение интерактивности; каталог “DOS” – каталог расположения бат-файлов, NDOS и BE.

Второй (2.bat):

sa whi on bla /cls

window 3 12 18 69 bright gre on whi

window 5 15 15 65 blu on red explode shadow

rowcol 7 19 "Общее количество свободной памяти уменьшилось." Bright green on red

rowcol 8 23 "Если в память не были инсталлированы" bright green on red

rowcol 9 19 "незафиксированные при тестировании драйверы," bright green on red

rowcol 10 18 "значит, в нее инсталлировались незафиксированные" bright green on red

rowcol 12 33 "В И Р У С Ы ." bright yel on red

rowcol 20 3

Третий (3.bat):

sa whi on bla /cls

window 3 14 18 67 bright gre on whi

window 5 18 15 62 red on blu explode shadow

rowcol 7 33 "В Н И М А Н И Е !" bright yelow on blue

rowcol 9 20 "Загрузка операционной системы прекращена."

Rowcol 10 24 "Чеерез 10 секунд будет произведена"

rowcol 11 26 "х о л о д н а я перезагрузка."

Rowcol 12 26 "Приготовте дискету для загрузки" bright whi on blue

rowcol 13 30 "чистой среды и нажмите Y." Bright whi on blue

rowcol 20 3

После написания этих файлов, строка вызывавшая из автоэкзека файл Test.bat заменяется вызовом файла 1.bat, на чем создание самодельного антивируса заканчивается.

Описанная программа рассчитана на чистую загрузку (со стандартным драйвером Himem.sys) и применение дополнительных менеджеров памяти, должно учитываться во второй строке первого бат-файла.

Проверить действие программы, можно либо, запустив перед ней дополнительный драйвер или резидентную программу, например, DosKey, либо вызвав из Windows сеанс MS-DOS и, повторив команду Autoexec.bat (Ndos /c C:\dos\1) .

Программа сверяет количество памяти с имеющимися у нее данными и в случаи расхождения значений, довольно наглядно (а также, “наслышно”), о нем сигнализирует. Никакая другая программа не способна с такой точностью учесть конфигурацию конкретного компьютера и в этом ее несомненное преимущество. Естественно, ее нельзя назвать панацеей и, она может быть обманута каким-нибудь хитроумным вирусом, но поскольку абсолютного антивируса не существует, чем больше на компьютере антивирусных программ, тем надежней его защита.

Сравнение количества памяти занимает не более сотой доли секунды, так что ее подключение ни как не сказывается на скорости загрузки компьютера, чего, к сожалению, не скажешь о других антивирусах.

Без способности к размножению, это на самом деле не вирус, а троянская программа.

При этом указание полного пути к библиотекам в Definfo.dat не обязательно, если папка содержащая библиотеки вложена в папку содержащую Definfo.

Вообще, лучшим антивирусом, по многим параметрам, признан McAfee VirusScan (в частности, его библиотека от 6.05.99г содержит данные на 43 612 вирусов), но он не имеет русскоязычной версии (куда смотрят хакеры?), а применение программ с интерфейсом на малознакомом языке обычно не позволяет использовать их в полной мере, а иногда не менее опасно, чем проникновение вирусов. По этому ее краткое описание бессмысленно.

Корректируя базовый модуль операционной системы (Io.sys), Зараза, фактически, создает собственную операционную систему, в которой, становится частью ядра.

Все операции производятся средствами операционной системы и любым антивирусом воспринимаются как вполне законные (иначе бы, антивирус реагировал на любое действие пользователя).

Отсутствие в разделе “Standard CMOS Setup”, процедуры SETUP, в строке “Drive A:” указания на наличие дисковода гибких дисков, служит прямым указанием на действие вирусов. Это указание можно внести вручную, главное – не полениться и заглянуть в SETUP.

При этом по заголовку окна сеанса, легко будет проследить, как управление процессом переходит от одной программы к другой.


Диалоговые командные файлы и загрузочное меню пользователя.

Диалоговые командные файлы.

Диалоговыми, называются командные файлы, производящие те или иные действия в зависимости от выбора пользователя.

Для создания диалогового командного файла (Bat-файла), в нем требуется указать команду вызова входящей в состав Windows програм мы Choice.com занимающей 6 килобайт дисковой памяти или заимствованной из нортоновских утилит под MS-DOS программы BE.exe занимающей 21 килобайт. Последняя занимает больше места, но и предоставляет большие возможности, в результате чего, ее применение более удобно, а иногда и незаменимо. Однако, в большинстве случаев, можно обойтись, имеющейся на любом компьютере, программой Choice.com.

За вызовом программы Choice.com (описана в главе посвященной файлу Autoexec.bat) в бат-файле должны следовать команды условного перехода к метке, за которой начинаются команды выполняемые в случае данного кода завершения. Причем, начинаться они должны с команды перехода, запускаемой наибольшим кодом, а команда, запускаемая наименьшим кодом, в переходе не нуждается. Например:

@echo off

choice /cYNR “Сделай свой выбор”

if errorlevel=3 goto tre

if errorlevel=2 goto tu

echo Код возврата равен единице.

Goto end

:tre

echo Код возврата равен трем.

Goto end

:tu

echo Код возврата равен двум.

:end

Применение диалогов в командных файлах различно. Например, можно удалить команду “Pause” из файла SetRamd.bat, исполняемую, когда переменная Ramd принимает значение “С”, а вместо нее, в Autoexec.bat (или тот же SetRamd.bat) включить команды:

If %ramd%==C GoTo Error

:ERROR

Choice /cYN “Нет доступа к диску С. Продолжить загрузку?”

Собственное загрузочное меню.

В отличии от управления загрузкой программ, управление загрузкой драйверов может происходить только тремя способами:

1. путем пошаговой загрузки

2. путем перезагрузки с новым Config.sys

3. путем создания загрузочного меню.

При этом последний способ является единственно удобным.

Файл Config.sys, назначение которого состоит в установке драйверов, не вошедших в комплект BIOS и замене некоторых содержащихся в нем, но не соответствующих требованию данной системы или пользователя, начиная с MS-DOS 6.22, получил блочную структуру, в которой обычный Config.sys, устанавливаемый Windows является лишь частным случаем, представленным одним блоком. Разделенный на блоки Config.sys имеет много общего с содержащими метки бат-файлами, где команды, идущие вслед за меткой, по сути, являются теми же блоками. Однако, поскольку интерпретацией Config.sys занимается не Command.com, а Io.sys, организация переходов в нем несколько иная.

Все блоки Config.sys (если их более одного) обязаны начинаться с заголовков (меток) заключенных в квадратные скобки. Сама структура загрузочного меню при этом, имеет следующий вид:

[MENU]

MENUITEM=метка1, Сообщение 1

MENUITEM=метка2, Сообщение 2

MENUITEM=метка3, Сообщение 3

MENUCOLOR=б,ф

MENUDEFAULT=метка,время

Где

[MENU] – блок, содержащий главное загрузочное меню

MENUITEM – пункт меню, после которого указывается имя исполняемого при его выборе блока и необходимый комментарий. Поскольку вывод загрузочного меню происходит раньше установки каких-либо драйверов, комментарий должен содержать только английские символы, иначе он будет выглядеть как узелковые письмена инков.

MENUDEFAULT – необязательный пункт, определяющий время ожидания реакции пользователя, вслед за которым указывается заголовок, автоматически выбираемый, если по истечении указанного времени, пользователем не предпринято никаких действий и, время ожидания в секундах. Если этот пункт не указан, ожидание длится, пока пользователь не созреет.

MENUCOLOR – пункт выбора цветового оформления, сохраняющегося до тех пор, пока какая-нибудь программа не переведет его в режим по умолчанию (серое на черном) , после которого указывается цифровой код цвета букв (б) и фона (ф). Если этот пункт не указан, для вывода меню применяется цвет по умолчанию. Из возможного набора цветов:

0 – черный

1 – синий

2 – зеленый

3 – бирюзовый

4 – красный

5 – фиолетовый

6 – коричневый

7 – белый

8 – серый (ярко-черный)

9 – ярко-синий

10 – ярко-зеленый

11 – ярко-бирюзовый

12 – ярко-красный

13 – ярко-фиолетовый

14 – желтый (ярко-коричневый)

15 – ярко-белый

В качестве цвета символов может вибираться любой, а в качестве цвета фона, только те, в которых к основному цвету не добавлено яркости (то есть, только первый столбец, цвета с кодами от 0 до 7).

Белый цвет лучше не применять, поскольку выделение варианта предлагаемого по умолчанию происходит именно белым и, либо это выделение не будет заметно на белом фоне (что неудобно), либо белые буквы не будут различимы при их выделении (что неудобно еще в большей степени). Впрочем, применение белого фона может применяться специально, чтобы сделать выделение невидимым. Наиболее щадащими зрение сочетаниями цветов являются 0,3 и 6,0. Неплохо, так же, воспринимается 10,0.

Выбор пункта меню, как и в меню загрузки Windows, вызываемом клавишей CTRL, осуществляется нажатием цифры соответствующей его порядковому номеру или клавишами перемещения курсора. После выбора (и нажатия ENTER) происходит:

1. Исполнение команд указанных в блоке соответствующем значению выбранного меню (как и заголовок меню, заголовок блока должен заключатся в квадратные скобки ).

2. Генерация переменной Config, принимающей значение имени выбранного блока, которая затем может быть использована в бат-файлах и командной строке (тем самым, во многих случаях заменяя вызов команды Choice.com или BE.exe), например, набором команд:

GoTo %Config%

:Метка1

Соответствующие команды.

GoTo END

:Метка2

Соответствующие команды.

:END

или, более кратко, но не так явно:

If %config%==метка1 GoTo метка

Команды исполняемые при %Config%=метка2

GoTo END

:метка

:END

Интерпритация Autoexec.bat в любом из случаев переходит к метке с именем, соответствующим значению выбрангого в Config.sys пункта меню . При этом, переменная унаследует регистр заданных символов и при обработке Autoexec.bat, некоторыми интерпритаторами (например Command.com) этот регистр учитывается.

Загрузка некоторых драйверов может требоваться сразу в нескольких конфигурациях. В таких случаях, для сокращения файла Config.sys, их можно записать отдельным блоком, а в блоки требующие их загрузки включить команду вызова – INCLUDE :

[Блок]

Команды исполняемые в первую очередь.

INCLUDE=отдельный_блок

Команды исполняемые последними.

[отдельный_блок]

Общие команды.

Если какие-то команды выполняются для всех конфигураций, их можно без всяких команд вызова записать в специальный блок COMMON, помещаемый в любое место Config.sys (лишь бы не во внутрь другого блока). Причем, количество таких блоков не ограничивается.

Каждый из блоков Config.sys может иметь вложенное меню, озаглавленное как SUBMENU, полностью аналогичное первоначальному (но поскольку наличие вложенного меню требует повторного вмешательства пользователя в процесс загрузки, наиболее удобным является перечисление всех возможных ее вариантов в едином меню, чтобы из-за необходимости постоянного выбора, загрузка не уподобилась пошаговой).

Таким образом, система команд загрузочного меню сводится к командам:

[MENU] – блок, содержащий главное загрузочное меню.

[COMMON] – блок, исполняемый при любых условиях.

[SUBMENU] – блок дополнительного (вложенного) меню.

MENUITEM – пункт меню.

MENUDEFAULT – необязательный пункт, определяющий время ожидания реакции пользователя.

INCLUDE – команда включения блока содержащего наборы команд, общих для нескольких блоков, например: “INCLUDE=BLOCK”.

MENUCOLOR – пункт выбора цветового оформления

Оператором присвоения (знаком равенства), как и везде в Config.sys, к каждому пункту присоеденяется значение, которое будет ему присвоено, если он будет выбран пользователем, а через запятую и пробел, необходимый коментарий. При чем, все это – только английскими символами.

Применение блоков COMMON и INCLUDE могут вызвать проблемы у программ настройки конфигурации MemMeker и Optimize (созданных задолго до появления загрузочных меню). По этому, в случае их применения, Config.sys лучше сделать длиннее, но проще по структуре.

Примеры загрузочного меню.

Меню загрузки с жесткого диска.

Config.sys:

[MENU]

menuitem=W, Windows

menuitem=N, NDOS

menucolor=0,3

menudefault=w,15

[W]

device=C:\windows\himem.sys

device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)

Country=007,866,C:\WINDOWS\COMMAND\country.sys

[N]

dos=high,umb

device=C:\windows\himem.sys

Buffers=20,3/x

Stackshigh=9,128

Fileshigh=15

fcbshigh=4

lastdrivehigh=h

device=C:\windows\emm386.exe noems highscan

devicehigh=C:\windows\command\display.sys con=(ega,,1)

Country=007,866,C:\WINDOWS\COMMAND\country.sys

devicehigh=C:\DOS\oakcdrom.sys /D:mscd001

devicehigh=C:\Windows\ramdrive.sys /E 5120

Shell=c:\ndos.com @c:\dos\ndos.ini /p

devicehigh=C:\Windows\Command\ansi.sys

Autoexec.bat:

@echo off

cls

C:\ADINF\Virkill.exe -a -b -d -l C: D:

verify on

mode con codepage prepare=((866) C:\WINDOWS\COMMAND\ega3.cpi) > nul

mode con codepage select=866 > nul

If exist C:\моидок~1\авп.prf goto NORM

Echo Труба твоей русификации (No Rusification)

Pause

:NORM

PATH C:\windows;C:\windows\Command;C:\DOS;C:\dos\nc

if %config%==N goto gud

C:\dos\ndos /c C:\DOS\1.bat

rem set path=%path%;C:\PROGRA~1\MICROS~1\OFFICE

Set DirCMD= /OGN /p /b

:gud

C:\PROGRA~1\NORTON~1\NAVDX.EXE /Startup

Cls

C:\dos\be rowcol 5 35 "L O A D I N G" red

lh keyb ru,,C:\WINDOWS\COMMAND\keybrd3.sys > nul

set temp=C:\windows\temp

if %config%==W goto exit

set dircmd= /p

SET NU=C:\DOS

set nc=C:\dos\nc

LH C:\DOS\mouse > nul

lh C:\windows\command\mscdex /d:mscd001 > nul

SET SYMANTEC=C:\Dos\SYMANTEC

prompt $E[1;37m F12 $E[0;32m- Вызов оболочки Нортон$_$e[33m$P$G

alias @F12 lh NORTON

alias @F11 saver

alias @F5 `*dir /a /t | list /s^cls`

diskmon /protect+ /light+ > nul

saver

:exit

Загрузочное меню дискеты содержащей лечащие модули AdInf (переименованной в VirKil), AVP Inspector, программу DrWeb (переименованную в Test) и оболочку Volcov Commander.

Config.sys:

[menu]

menuitem=Test, AntiVirus Test

menuitem=NO, No Test

menuitem=AD, AdInfo

menuitem=NOCD, No Test, No CD

menuitem=NORAMD, No Ram Disk

menudefault=NO,10

menucolor=0,3

[AD]

Buffers = 40,8

Files = 20

Shell = \AdinfExt\Switcher.shl C:\ADINF

[TEST]

include Driv

devicehigh=ramdrive.sys /E 5120

devicehigh=ansi.sys

[NOCD]

include Driv

devicehigh=ramdrive.sys /E 5120

devicehigh=ansi.sys

[NO]

include Driv

devicehigh=oakcdrom.sys /D:mscd001

devicehigh=ansi.sys

[NORAMD]

include Driv

[DRIV]

dos=high,umb

device=himem.sys

Buffers=12/x

Stackshigh=9,128

Fileshigh=15

fcbshigh=4

lastdrivehigh=h

device=emm386.exe noems highscan

devicehigh=Display.sys con=(ega,,1)

country=007,866,country.sys

Autoexec.bat:

@echo off

CLS

Echo L O A D I N G

Verify on

SET DIRCMD=/ogn /p

If %config%==NORAMD GoTo NO

set LglDrv=27 * 26 Z 25 Y 24 X 23 W 22 V 21 U 20 T 19 S 18 R 17 Q 16 P 15

set LglDrv=%LglDrv% O 14 N 13 M 12 L 11 K 10 J 9 I 8 H 7 G 6 F 5 E 4 D 3 C

call setramd.bat %LglDrv%

copy A:\Block\*.* %ramd%: > nul

copy A:\command.com %ramd%: > nul

set comspec=%ramd%:\command.com

%ramd%:

Path %ramd%:

pkunzip -d %ramd%:\Arhiv.zip > nul

mode con codepage prepare=((866) ega3.cpi) > nul

mode con codepage select=866 > nul

lh keyb ru,,keybrd3.sys

LH Mouse.com > nul

if %config%==NOCD goto cd

lh mscdex.exe /D:mscd001 > nul

:cd

del %ramd%:\Arhiv.zip > nul

prompt $E[32mVolcov Commander$E[33m$_$P$G

md %ramd%:\temp

Set Temp=%ramd%:\temp

Set tmp=%ramd%:\temp

if %config%==NO GoTo NO

if %config%==NOCD GoTo NO

Test

:NO

if not %config%==NORAMD GoTo END

A:\block\Test /fn

:END

cls

Простое загрузочное меню жесткого диска, в случае необходимости, загружающее файловый менеджер Norton Commander в режиме "Command prompt only", и продолжающее загрузку Windows по выходе из него.

Config.sys:

[MENU]

menuitem=W, Windows

menuitem=D, DOS

menucolor=0,3

menudefault=w,5

[W]

include D

[D]

device=C:\windows\himem.sys

device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)

Country=007,866,C:\WINDOWS\COMMAND\country.sys

Autoexec.bat:

@echo off

cls

verify on

mode con codepage prepare=((866) C:\WINDOWS\COMMAND\ega3.cpi) > nul

mode con codepage select=866 > nul

lh keyb ru,,C:\WINDOWS\COMMAND\keybrd3.sys > nul

set temp=C:\windows\temp

PATH C:\windows;C:\windows\Command;C:\DOS;C:\dos\nc

goto %config%

:D

lh C:\dos\mouse

C:\dos\nc\nc

Mouse /UNINSTALL

:W

В связи с чем, если в Config.sys предполагается загрузка драйвера Ansi.sys, для большего эстетического эффекта, команду его загрузки, следует указывать последней.

В отличие от подобных процедур в бат-файлах, команды следующих блоков не исполняются и, включение в блок строки аналогичной “GoTo END” переводящей исполнение на метку в конце файла, не требуется.

Учитывая возможность использования переменной Config, иногда имеет смысл создавать в Config.sys пустые блоки (если варианты конфигурации отличаются только на уровне бат-файлов). Наличие заголовка блока при этом остается обязательным.

Это, пожалуй, единственная команда Config.sys (не считая заголовков влоков), которая может обходиться без операторов присвоения.


Инсталляция оборудования.

После установки Windows на свежеотформатированный диск, система автоматически начинает поиск незарегистрированных устройств и неизбежно их находит, поскольку хотя бы одно такое устройство – видеокарта – на компьютере имеется, а, найдя его, сообщает о своей находке в небольшом диалоговом окне: “Обнаружено новое оборудование и выполняется поиск программного обеспечения для него. Пожалуйста подождите”.

По окончании возни с одним обнаруженным устройством, система принимается за другое. В процессе всех этих мытарств, компьютер может зависнуть, и тогда его требуется отключить, а затем включить заново. В конце концов, список неизвестных устройств заканчивается и, система приходит в работоспособное состояние. Однако оно вряд ли кого удовлетворит, и чтобы имеющееся в компьютере оборудование заработало в полную силу, для него необходимо установить поставляемые вместе с ним драйверы.

Драйверы дополнительных устройств поставляются либо на компакт-дисках, либо на дискетах. Некоторые устройства имеют сразу оба комплекта драйверов – один для удобства, другой – на случай допотопного компьютера не снабженного CD-ROM. Драйвера для Windows98 обычно содержатся в папке Windows95, Win95 или что-то еще в этом роде (принципиальной разницы между инсталляцией оборудования под Windows95 и Windows98 не существует, а Windows98 обычно не признается за некую новую операционную систему, правомерно считаясь лишь очередной версией Windows95), но лучше об этом узнать из прилагаемой к дистрибутиву инструкции по его установке. Раздел с необходимой информацией имеет название близкое к “Installation sous Windows 98” или “Installing on Windows 95”. Конкретная строка с адресом драйвера выглядит как “D:\WIN95\SETUP”, (где под “D:”, на самом деле, имеется в виду символ, закрепленный за данным дисководом), хотя, может выглядеть и несколько иначе.

Перед установкой драйвера, желательно войти в панель управления, открыть диалоговое окно “система” и перейти в ней на вкладку “устройства”. Имеющийся там переключатель, должен быть установлен в положение “Устройства по типам”. Во вкладке “Панель управления\Система\Устройства\по типам” требуется проверить наличие неопознанных и конфликтующих устройств – они обозначаются вопросительным или восклицательным знаком (соответственно) желтого цвета. Все эти устройства, требуется удалить, отметив их указателем мыши и щелкнув по кнопке “Удалить”. На предупреждение: “Предупреждение. Сейчас устройство будет удалено из системы” отвечают утвердительно – компьютер шутит, никакое силовое поле не примется выдирать платы дополнительных устройств из системного блока. Удалится только их не удовлетворяющая регистрация.

После этого, можно запустить программу “Установка и удаление программ” и установить драйверы. За их установкой должен последовать перезапуск компьютера, но если компьютер об этом не догадается, его можно перезапустить вручную. Удаленные устройства вновь окажутся для компьютера неизвестными и для их опознания, ему придется порыться в базе данных драйверов, теперь уже оснащенной необходимыми. Этоприведет к правильной регистрации дополнительных устройств, которые останется только настроить, задав желаемое количество цветов, громкость звука и тому подобное. Некоторые устройства, при своей установке, требуют от Windows определенных дополнений и, на этот случай, дистрибутивный комплект Windows, при инсталляции оборудования, должен быть под рукой.

В случае невозможности подключить все устройства за один прием (например, за установкой одного из драйверов следует автоматический перезапуск системы и часть устройств отправляются на перезагрузку не успев обзавестись собственными драйверами), устройства не получившие удовлетворительной регистрации, повторно удаляются; для них весь процесс выполняется заново.

Установка видеокарт имеющих вход и выход (или только выход) имеет свои особенности: устройство видеовхода и видеовыхода может регистрироваться отдельно, если это не учесть, случится так, что видеокарта, исправно работающая с монитором, ни как не отреагирует на попытку подключения к ней телевизора или видеомагнитофона. Инструкции по их инсталляции содержится в разделе “TV in/out instaiiation” (или что-то вроде того), документации прилагаемой к видеокарте.

Инсталляция устройств не поддерживающий стандарт “Plag&Play” более проблематична, для нее требуется задействовать программу “Установка и удаление оборудования”. Но это никому не нужный анахронизм – устройств, требующих настоящей установки (помимо той, которая производится при вставлении его в компьютер впервые), в природе давным-давно не существует.


Использование архивов в MS-DOS.

В повседневной жизни использование MS-DOS-архиваторов подобно применению каменного топора, однако, при восстановлении работоспособности системы, применение MS-DOS-программ разархивации не только полезно (сжатые файлы не только занимают меньше места, но и быстрее копируются, а их распаковка на виртуальном диске происходит практически мгновенно), но иногда и необходимо. Наиболее целесообразно, применение с этой целью программы PkUnZip.exe (версия 4.1 имеет размер 28 килобайт), входящей в MS-DOS-вариант Zip-архиватора. Его упаковывающий собрат интереса не представляет, поскольку подготовку архивов удобней производить в среде Windows (применение для этой цели встроенного архиватора Norton Commander для Windows 95 обеспечивает наилучшее сжатие).

Программа PkUnZip не входит в состав Windows, но еще недавно, она применялась наравне с архиваторами для Windows и, имеется у многих пользователей. Так что, даже если у кого она и не имеется, найти ее будет не сложно.

Команды управления модулем распаковки

Просмотр оглавления

PkUnZip –VBN АРХИВ – просмотр оглавления архива, с сортировкой по именам, где “АРХИВ” – путь и имя архива. При выдаче команды содержимое архива быстро выводится на экран и, если оно слишком велико и не вмещается на него целиком, приостановить вывод можно нажатием CTRL+S. Эти же клавиши следует нажать для продолжения.

Для большего удобства команду просмотра можно переадресовать программе MORE. В таком случае, вывод будет автоматически приостанавливаться после каждого заполнения:

PkUnZip –vbn АРХИВ | More

Просмотр сжатых файлов

PkUnZip –cm АРХИВ ФАЙЛ(Ы) – просмотр содержимого сжатых файлов с приостановкой после каждого заполнения экрана.

Сообщение “More”, появляющееся после заполнения, свидетельствует о том что, файл(ы) имеют продолжение. В этом случае, нажатие клавиши

Пробел приводит к выводу следующего экрана

ENTER – следующая строчка файла

ESC – прекратить вывод данного файла

CTRL+C – прекратить вывод для всех файлов (если он задан для множества)

Распаковка архивов

PkUnZip АРХИВ ФАЙЛ ПАПКА – распаковывает указанные файлы из указанного архива в указанную папку. Последние два параметра не обязательны, при их отсутствии, архив распакуется целиком, в текущую папку.

Дополнительные параметры:

-N – распаковать только файлы, не имеющие аналогов в указанной папке и новые версии имеющихся там файлов (иначе все файлы при совпадении имен заменяются файлами из архива).

-D – сохранить пути (если таковые имеются) и создать в указанной папке соответствующие им подкаталоги.

-F – только заменить имеющиеся версии, если версии, содержащиеся в архиве, имеют более свежую дату.

Некоторые сообщения выдаваемые PkUnZip

(E09) Can’t find:АРХИВ – архив не найден

(E11) No file(s) found – файлы не найдены

(W18) warning! ФАЙЛ alreadi exist – файл существует, заменить?

(E50) Disk full file: ФАЙЛ – диск переполнен и дальнейшая распаковка невозможна, последним распакован указанный файл (поскольку распаковка происходит в алфавитном порядке, начиная с цифр и заканчивая русскими буквами, данное сообщение позволяет определить, какие именно файлы остались не распакованными).

В зависимости от варианта завершения, переменная Errorlevel (E) принимает значения 9, 11, 50 – соответственно.


Коды завершения некоторых программ.

DiskCopy (копирование дискет с соблюдением физических адресов файлов)

0 – успешное выполнение

1 – невосстановимая ошибка

2 – выполнение завершено пользователем (нажатием CTRL+BREAK)

3 – критическая ошибка (невозможность чтения исходного диска или форматирования, перед копированием, диска – получателя)

4 – некорректная выдача команды или для ее выполнения недостаточно памяти.

XCopy (копирование, включая вложенные каталоги)

0 – успешное выполнение

1 – файлы не найдены

2 – выполнение завершено пользователем

4 – некорректная выдача команды

5 – критическая ошибка ввода-вывода, на которую пользователь ответил “А” (прекратить)

Replace (копирование с заменой файлов при совпадении имен)

0 – успешное выполнение

2 – файл не найден

3 – не найден маршрут

5 – доступ запрещен атрибутом “Только для чтения”

8 – недостаточно памяти

11 – ошибка при задании параметров

15 – не найден требуемый диск

Backup (резервное копирование)

0 – успешное выполнение

1 – не выбраны файлы для резервирования

2 – часть файлов зарезервировать не удалось

3 – выполнение завершено пользователем

4 – выполнение прекращено из-за ошибки

Restore (восстановление файлов из резерва)

0 – успешное выполнение

1 – файлы не найдены

3 – выполнение завершено пользователем

4 – выполнение прекращено из-за ошибки

Find (поиск текстовой строки в файле)

0 – Заданый фрагмент найден

1 – Заданый фрагмент не найден

2 – Поиск не дал результатов (возможно, указанный файл не существует)

Keyb (обеспечение переключения клавиатуры)

0 – успешная установка

1 – не правильная форма команды

2 – описание клавиатуры не найдено

3 – не удается разместить кодовую страницу в памяти

4 – ошибка клавиатуры (не подходит описание)

5 – кодовая страница еще не подготовлена

6 – запрашиваемая страница отсутствует в памяти

7 – несоответствие версий операционной системы и программы Keyb

Format (инициализация диска)

0 – Успешное выполнение

3 – выполнение прервано пользователем

4 – ошибка при выполнении

5 – пользователь отказался от форматирования жесткого диска

DiskCmp (сравнение дискет)

0 – содержимое идентично

1 – содержимое различно

2 – выполнение завершено пользователем

3 – команда не выполнена из-за ошибки ввода-вывода

4 – некорректная выдача команды

DrWeb (антивирусная программа)

0 – вирусы не обнаружены

1 – обнаружен известный программе вирус

2 – подозрение на неизвестный вирус

AntiViral Toolkit Pro (антивирус)

0 – вирусов не обнаружено;

1 – сканирование не закончено;

2 – найдены объекты, содержащие измененный или поврежденный вирус;

3 – найдены объекты, подозрительные на вирус;

4 – обнаружен вирус;

5 – все обнаруженные вирусы удалены;

7 – файл AVP32.EXE поврежден;

10 – внутренняя ошибка программы AVP.

Navdx (антивирус)

0 – ошибок нет, вирусов не обнаружено

10 – в памяти найден вирус

11 – произошла внутренняя ошибка

13 – на диске обнаружены вирусы

15 – ошибка самоконтроля, NAVDX либо поврежден, либо заражен

102 – проверка прервана по желанию пользователя

AdInfo (антивирус)

0 – Изменений не обнаружено

10 – обнаруженные изменения не вызывают подозрений

20 – обнаружены подозрительные изменения

22 – выдан запрос на лечение

25 – проверка прервана нажатием клавиши ESCAPE

30 – работа закончена нажатием F10

40 – дальнейшая проверка невозможна в связи с вмешательством вируса

50 – произошел сбой программы

SetVer (эмулятор версии MS-DOS)

0 – успешное завершение

1 – неверный параметр

2 – неверное имя файла

3 – недостаток памяти

4 – задан неверный формат версии DOS

5 – удаляемая строка не обнаружена

6 – отсутствует таблица

7 – диск указан не правильно

8 – слишком много аргументов

9 – слишком мало аргументов

10 – ошибка чтения таблици

11 – Setver.exe поврежден

12 – данный экземпляр Setver.exe не поддерживает таблицу

13 – в таблице не осталось места для новой строки

14 – ошибка записи таблицы

Rar (архиватор)

0 – успешное завершение

1 – были незначительные сбои

2 – серьезный сбой при работе

3 – при распаковке обнаружено расхождение контрольной суммы

4 – попытка изменения архива заблокированного параметром K

5 – ошибка записи на диск

6 – ошибка открытия файла

7 – неверные параметры командной строки

8 – для завершения операции не хватило памяти

255 – прервано пользователем

PkZip for DOS v 2.50 (Zip-упаковщик)

0 – успешное выполнение

1 – не удалось создать архив (обычно, из-за неверного имени)

2, 3 – указаный в командной строке архивный файл неисправен

4 -11, 19 - 23 и 29 – недостаток памяти

12 – указанные для обработки файлы не найдены

13 – архив или файл списка не найден

14 – на диске нет места для временного файла

15 – архив имеет атрибут "только для чтения" или блокирован другой програмой

16 – ошибка при задании параметров

17 – слишком много файлов (поскольку PkZip поддердивает архивы до 16 383 файлов, это сообщение скорее соответствует нарушению внутренней структуры архива).

18 – не удается открыть файл

24 – фатальная ошибка EMS-памяти

25 – фатальная ошибка XMS

26 – неподдерживаемая версия DOS (ниже 3.0, а для очистки дискеты перед архивированием, ниже 3.2)

27 – архивация непосредственно на данное устройство не поддерживается

28 – имя источника или временого файла совпадает с результирующим

255 – операция прервана пользователем

PkUnZip for DOS v 2.50 (Zip-распаковщик)

0 – успешное выполнение

1 – при распаковке были небольшие проблемы

2, 3 – архив поврежден

4 - 8 – недостаток памяти

9 – не удалось найти указанный архив

11 – указанные файлы либо отсутствуют в архиве, либо он защищен паролем

50 – на диске не осталось места для извлечения

51 – файл неожидано оборвался

255 – прервано пользователем

Zip2exe (преобразование Zip-файла в exe)

0 – успешное преобразование

1 - 2, 8 – Zip-файл поврежден

3 - 4 – недостаток памяти

6 – указанные параметры неверны

7 – архив не удалось открыть

9 – ошибка при записи итогового файла

11 – при создаини самораспаковывающегося архива диск переполнился

12 – не поддерживаемый метод сжатия

13 – на запрос о замене существующего файла получен отрицательный ответ


Команды клавиатуры

Выделение текста

Удобно выделять текст:

по символам shift + стрелка вправо;

весь ctrl+a (русская ф).

Для выделения могут использоваться те же команды, что и для перемещения курсора, но с нажатой клавишей shift:

стрелка перемещает курсор в любом направлении (при нажатом shift выделяя текст)

end - до конца строки

home - до начала строки

ctrl+стрелка - до конца либо начала абзаца

Page Down - на весь экран в низ

Page Up - на весь экран вверх

Ctrl + home - до начала документа

Ctrl + End - до конца

Рисование

Alt Позволяет рисовать от центра

Shift Помогает создавать геометрически безупречные линии и фигуры, выравнивая их относительно осей и следя за соблюдением диаметра.

Выделение файлов

Неоценимую услугу при выделении файлов для групповых действий оказывает комбинация клавиатуры с мышью:

Для выделения большой группы файлов достаточно выделить мышью крайний файл с одной стороны предполагаемой группы, а затем, нажав Shift выделить крайний файл с другой стороны.

Выбор файла при нажатой клавише Ctrl позволяет добавить файл к выделенному или удалить его из группы. В сочетании с клавишей Shift, эту клавишу удобно использовать для удаления и прибавления других групп.

Операции мышью:

Обычно при перетаскивании с диска на диск объекты копируются. При перетаскивании в пределах одного диска, обычно, перемещаются файлы данных и документы – для программ, вместо перемещения создаются ярлыки. Внесение коррекции в эту ситуацию возможно с помощью клавиш:

Ctrl – для копирования

Shift – для перемещения

Shift+Ctrl – для создания ярлыка

Escape – для отмены операции, если случайно, ухвачено не то.

С помощью клавиш можно внести коррекцию и в контекстное меню: целчек правой кнопки мыши при нажатой клавише Shift добавляет в контекстное меню пункт "Открыть с помощью...".

Дополнительно:

Для удаления, минуя корзину, при удалении нажимается клавиша Shift

Для игнорирования автозагрузки компакт-дисков: нажатие и некоторое удерживание Shift.

Предотвращение запуска программ, запускаемых из меню автозагрузки – удерживание Shift с момента появления рабочего столо и до окончания загрузки компьютера.

Ускорение перезагрузки компьютера – удержавание Shift при нажатии кнопки «OK», после выбора пункта «Перезагрузить компьютер» (перегружается только графическая оболочка).

Снятие задачи и перезагрузка компьютера: Ctrl + Alt + Delete

Переход из окна в окно можно производить с помощью сочетания клавиш Alt+Tab

Копирование экрана в буфер обмена Print Screen

Копирование активного окна Alt+Print Screen

Переименовать F2

Включить поиск F3

Обновить содержимое окна F5

Открыть меню программы F10

Свернуть все окна “Windows”+D

Выбрать следующую вкладку Ctrl+Tab

Закрытие программы Alt+F4

Закрытие полноэкранного режима MS-DOS: Alt+Escape

Просмотр свойств выделенного объекта Alt+Enter

Дополнительные сведенья о командах клавиатуры, можно получить, открыв, через меню “Пуск” справочную систему Windows, раздел “Знакомство с компьютером”


Компоненты ядра MS-DOS

BIOS

Содержит драйвера стандартных устройств, (в частности, накопителей гибких и жестких дисководов, драйвер основной памяти), программу тестирования оборудования, программу начальной загрузки (SETUP) и интерпретатор одной из модификаций процедурного языка программирования высокого уровня BASIC, запускаемый в случае невозможности загрузить операционную систему.

Программа, прошитая в BIOS, не зависит от операционной системы, однако, является ее неотъемлемой компонентой. Выход в утилиту конфигурирования BIOS осуществляется нажатием клавиши DEL, сразу после окончания тестирования памяти при запуске компьютера.

Главная загрузочная запись

Создается программой Fdisk и помещается в первый физический сектор, нулевой дорожки нулевого цилиндра. Она содержит таблицу разделов, определяющую их начальные и конечные сектора (и таким образом создающую логические диски) и, указание, какой из разделов является активным. Сама она ни в один диск не входит и средствами операционной системы не отображается.

Boot-сектор.

Загрузочная запись (она же загрузочный сектор или бут-сектор) создается программой Format.com и содержит таблицу размещения файлов (FAT), корневой каталог и системный загрузчик. Эти элементы помещаются в специальную (системную) область диска и никакими средствами операционной системы не отображаются. Увидеть их (только содержашиеся в них данные, а ни некие файлы “Системный загрузчик”, “Корневой каталог”… ) можно только с помощью низкоуровневых редакторов диска, типа DiskEdit из нортоновских утилит, обрабатывающих диски на физическом уровне.

Системный загрузчик.

Системный загрузчик, помещаемый в загрузочную запись системного диска, создается при форматировании диска и, не смотря на то, что его обязанность – загрузка операционной системы, находится на любом диске пригодном для ее использования.

Корневой каталог

Самый верхний каталог диска. Информация о корневом каталоге содержит начало всех путей и используется при каждом обращении к диску. Поэтому, для ускорения поиска файлов, она помещается не в область данных, где может быть фрагментирована (что привело бы к замедлению работы компьютера), а в специальную системную область, не отображаемую средствами операционной системы (загрузочную запись), где ей отводится участок емкостью на 512 элементов по 11 символов. В результате, элементы корневого каталога не входят в таблицу размещения файлов.

Io.sys

Содержит команды загрузки некоторых драйверов (например, DblSpase.sys, DrvSpase.sys) и системных файлов, (например, Win.com), сообщения, выдаваемые при ошибках их чтения и интерпритацию команд применяемых в файле Config.sys. Беря на себя обработку Config.sys, позволяет заменять загружаемые из BIOS драйверы, вследствие чего, иногда называется его оболочкой (исходя из таких представлений, оболочкой можно назвать все что угодно, например, Mouse.com – оболочка для работы с мышью). Он должен находится в первом (стартовом) секторе системного диска, чтобы быть найденым без помощи файловой структуры, информация о которой загружается именно им.

При просмотре в кодировке (ASCII) Io.sys выглядит как набор букв собранных из алфавитов всех времен и народов, перемешанных с игральными картами (пики, трефи и т. п.), среди которых изредка попадаются, содержащие сообщения, англоязычные фрагменты (ни один из существующих на сегодняшний день BIOS не содержит драйвер русского языка и попытка вывода рускоязычных сообщений из Io.sys бессмысленна).

Msdos.sys

Является файлом настройки, и состоит из двух блоков.

Блок [Path] содержит основные системные переменные, необходимые для нормальной загрузки Windows:

WinDir – указывает программам инсталяции приложений Windows, каталог содержащий ядро операционной системы.

WinBootDir – указывает каталог из которого должна загружатся операционная система.

HostWinBootDrv – указывает диск на котором находится операционная система.

Блок [options] содержит команды разрешающие или запрещающие некоторые функции Io.sys:

AutoScan=1– проверять диски после некорректного завершения работы

BootFailSafe=1– включить в загрузочное меню пункт "Safe Mode"

BootWarn=1– выдавать сообщение о загрузке безопасного режима

BootDelay=2 – количество секунд паузы перед загрузкой (по умолчанию=2)

BootMulti=1– разрешить загрузку нескольких операционных систем

BootKeys=1– разрешить применение клавиш при запуске

BootWin=1– загружать Windows, а не систему, поверх которой он установлен

BootGUI=1– загружать графическую оболочку (автоматическая выдача команды "WIN" после обработки файлов конфигурации)

BootMenu=1 – при запуске компьютера всегда выводить загрузочное меню

DblSpace=1 – загрузка драйвера сжатого тома

DrvSpace=1 – аналогично

DoubleBuffer=1 – загрузка драйвера двойной буферизации для ускорения работы с дисками SCSI (по крайней мере для некоторых их типов)

LoadTop=1– загружать Command.com и Drvspase.bin в верхнюю память

Logo=1 – показать логотип Windows

NetWork=1– включить в загрузочное меню безопасный режим с поддержкой сети

WinVer – содержит выдаваемую по запросам программ версию Windows.

В перечисленных строках (не считая паузы и WinVer), согласно двоичной системе исчисления ноль означает “нет”, а единица “да”. Поскольку по умолчанию (изначально) данные параметры, кроме вывода загрузочного меню и возможности использования нескольких операционных систем, предусмотрены к исполнению, “да” равносильно отсутствию строки и, в девственном Msdos.sys, они действительно отсутствуют .

При указании в Msdos.sys обязательного вывода загрузочного меню, приобретают значение команды BootMenuDelay=30 и BootMenuDefault=1 (или 3) назначение которых аналогично назначению подобных команд загрузочного меню пользователя.

Кроме переменных и команд инициализации, файл MSDOS.sys обычно содержит коментарии, начинающиеся с точки с запятой. Для совместимости с некоторыми приложениями Windows размер файла MSDOS.sys должен быть не менее 1024 байта и, эти коментарии, в основном, применяются для его принудительного увеличения. При работе в режиме командной строки, на размер MSDOS.sys ограничений не накладывается и в MSDOS.sys, помещаемом на загрузочную дискету, коментарии могут отсутствовать (хотя они обычно содержат имя программы его создавшей: Sys или Format). Более того, в MSDOS.sys, помещаемом на загрузочную дискету, отсутствует блоки [Path] и [Options], причем, первый из них, удаляется умышлено, иначе Io.sys не прекратит загрузку на режиме командной строки и загрузит с жесткого диска графическую оболочку Windows.

Command.com

Отличается от других интерпритаторов простотой интерфейса и отсутствием сервисной системы, в остальном, это тот же интерпритатор, переводящий команды операционной системы в машинный код и обратно. После загрузки, его резидентная часть находится в памяти постоянно, а транзитивная часть, периодически вытесняется выполняемыми программами и вновь загружается под управлением резидентной.

Интерпритаторы команд взаимозаменяемы и, например, на определенном этапе загрузки, Command.com заменяется Explorer.exe.

Обнуление указанных строк значительно сокращает время загрузки, так как отменяет ожидание перед ее продолжением и позволяет не тратить время на считывание лишних файлов. Однако, BootWin, BootGUI, BootKeys, BootMenuDelay и BootMenuDefault обнулять не следет.


Меню загрузки.

Выход в меню загрузки при работе с Windows 98 осуществляется при нажатии и удерживании клавиши CTRL на начальной стадии загрузки компьютера. Оно озаглавлено как Microsoft Windows Startup Menu, содержит шесть пунктов меню и сообщение: “Enter a choice” (введите свой выбор). Кроме того, нижняя часть экрана содержит подсказку о возможности вызова некоторых пунктов меню с помощью функциональных клавиш, сразу после появления таблицы прерываний, минуя данное меню (F5 – Safe mode; Shift F5 – command prompt ; Shift+F5 – Step-by-step comfirmation). Для ввода выбора пользователю предоставляется 30 секунд, по истечению которых загрузка продолжается автоматически в соответствии с пунктом, представленным в данной ситуации по умолчанию (то есть, без ручной коррекции) – данный пункт выделен серым.

По умолчанию могут определяться различные пункты. В нормальной ситуации и ряде критических, по умолчанию предполагается нормальная загрузка. В других ситуациях, например, при неправильной загрузке и последующим за ней автоматическом перезапуске системы, по умолчанию определяется пункт "Safe mode". В любом случае, этот пункт будет выделен, чтобы пользователь видел, какой вариант загрузки произойдет, если он не предпримет никаких действий или просто нажмет ENTER.

На выбор пользователю предлагаются следующие варианты:

1. Normal – обычная загрузка. Именно она во многих ситуациях предполагается по умолчанию.

2. Logged – обычная загрузка с записью отчета в файл Bootlog.txt для анализа программ участвующих в загрузке компьютера. Этот файл помещается в корневой каталог системного диска и в основном содержит информацию о компонентах первоначальной загрузки. Часть файла записывается русским языком в кодировке ASCII, и должна просматриваться либо редактором MS-DOS , либо в шрифте Terminal.

Фраза: Loading Device в протоколе указывает на попытку загрузить программу или драйвер в память.

LoadSuccess говорит об успешной загрузкею.

LoadFailed фиксирует неудачи.

3. Safe mode – режим (mode) сохранения (safe) – так называемый “безопасный” режим или, “режим защиты от сбоев”, предназначенный на тот случай, если в результате пользовательских установок не согласованных с возможностями аппаратуры, режим работы монитора или видеокарты нарушается так, что на экране уже ничего не возможно разобрать. В этом, называемом так же “защищенным” режиме, в оперативную память компьютера загружаются лишь драйвера поставляемые с самим Windows, не способные нанести разлад в работе компьютера, а все пользовательские установки, лишенные поддерживающий их драйверов, переводятся в установки по умолчанию – точно такие, какие существуют при установке Windows на свежеотформатированный диск.

Войдя в безопасный режим и исправив неправильные настройки (например, неоправданно завышенную частоту обновления экрана ), чтобы вернутся к нормальному режиму работы, требуется перезагрузиться заново – выстановленые в безопасном режиме параметры остаются в силе. Но именно в силу сохранения настроек принятых в безопасном режиме, иногда одного выхода в безопасный режим достаточно, чтобы начать настраивать комфортный интерфейс заново.

4. Step-by-step comfirmation – режим пошаговой загрузки, в котором на исполнение команд предусмотренных для нормальной загрузки, требуется подтверждение пользователя. Он применяется при необходимости ручного исключения загрузки определенных драйверов и, для людей разбирающихся в назначении команд и драйверов, является эффективным средством отладки системы.

Первым делом, при выборе этого пункта меню, компьютер запрашивает, обрабатывать ли системный реестр (Process the system registry [Enter=Y,Esc=N]?), но этот вопрос – чистая формальность и на самом деле, от ответа пользователя ничего не зависит, поскольку регестр обрабатывается в любом случае.

Второй вопрос компьютера, вести ли протокол сохраняемый как Bootlog.txt – кому интересно, может ответить – “да”.

Далее, компьютер интересуется, следует ли подключать драйверы указанные в файле Config.sys – если ответить “нет”, Config.sys полностью игнорируется, ответ “да” позволяет выбрать, какие именно драйверы из указанных в Config.sys будут подключены. При отсутствии, в файле Config.sys, команды DOS=NoAuto или ее отмене, компьютер обычно пытается подключить некоторые вспомогательные драйвера самостоятельно, даже если в файле Config.sys о них ни сказано ни слова (указание по их загрузке находятся в файле IO.SYS) – с ним лучше согласится, иначе он не отвяжется.

Отказ от драйверов, предлагаемых компьютером по собственной инициативе, имеет смысл только тогда, когда возникают подозрения (или доподлинно известно), что они могут помешать в работе.

Разобравшись с Config.sys, компьютер принимается за Autoexec.bat, на что выспрашивает соответствующее разрешение. С Autoexec.bat история такая же, как и с Config.sys, вплоть до проявления компьютером инициативы.

Затем следует: “WIN [Enter=Y(да), Esc=N(нет)]? – это вопрос о том, загрузить ли Windows, или загрузится в режиме командной строки (Command prompt only) MS-DOS . При запрете Windows, загрузка прекращается и на экране появляется приглашение MS-DOS .

После положительного ответа на вопрос “WIN?”, продолжается загрузка Windows и, если пользователь не запрещает, компьютер заговаривает, вдруг, на чистом русском: “Загрузить все драйвера Windows?” (если в файлах конфигурации русификацию запретить, вопрос будет задан на чистом китайском). Но на самом деле, это означает не то, что на самом деле означает. Ответ “нет” не означает возможности выбора подключаемых драйверов. Ответ “нет” означает загрузку в защищенном режиме (с последующей необходимостью новой перезагрузки для возвращения в нормальный режим и, возможно, необходимостью настраивать интерфейс заново). Для обеспечения возможности выбора подключаемых драйверов Windows, на вопрос “Загрузить все драйвера Windows?”, следует ответить “да”.

5. Command prompt only – остановка загрузки на уровне командной строки (после выполнения Config.sys и Autoexec.bat) – стопроцентный MS-DOS , применяемый для ремонта Windows изнутри (когда его еще возможно починить без применения загрузочной дискеты). При выборе этого пункта, после внесения необходимых изменений, загрузку Windows можно осуществить либо обычной перезагрузкой, либо введением команды WIN.

6. Safe mode command prompt only – безопасный режим для MS-DOS , исключающий выполнение файлов конфигурации (в том числе Config.sys и Autoexec.bat). В локализованных версиях его лучше не применять: без загрузки отмеченных в конфигурационных файлах русификаторов, но, все же, пытаясь изъяснятся по-русски, командная строка превратится в бред сивой кобылы.

В зависимости от конфигурации компьютера, меню может иметь еще два пункта, не требующих дополнительных коментариев:

Безопасный режим с возможностью работы в сети.

Предыдущая операционная система

Пункт "Безопасный режим", напротив, может отсутствовать.

Выбор нужного пункта меню зависит от намерений пользователя и осуществляется либо клавишами вертикального перемещения курсора, либо введением номера желаемого пункта. В обоих случаях, для исполнения требуется нажать ENTER. При любом прикосновении к клавиатуре, отчет времени прекращается и, система из автоматического режима переходит на режим управления человеком.

Разрешение загрузки запрашиваемого драйвера производится нажатием клавиши ENTER, запрет – нажатием клавиши ESC.

Данное меню не является единственным. При желании, пользователь может составить собственное меню, изменив соответствующим образом файлы Autoexec.bat и Config.sys. Вызываться оно будет автоматически, без нажатия каких-либо клавиш.

Эта часть меню страдает неточностью: данное “Command prompt” на самом деле означает “Safe mode command prompt” — безопасный режим для MS-DOS.

Чем выше данная частота, тем меньше устают глаза, но у каждого класса мониторов свой диапазон поддержки частот обновления и, чем выше класс монитора (и, как правило, цена), тем большую частоту обновления он способен выдержать. Если монитор не зарегистрирован в системе как “неизвестный”, то критические для него частоты, видеокарта и не предложит, даже когда ее способности гораздо выше.


Некоторые программы

NORTON COMMANDER

Norton Commander разработанный фирмой Peter Norton Computing в 82 году (в 1992 влившейся в состав корпорации Symantec) для удобства работы с операционной системой MS-DOS и, с тех пор не раз обновлявшийся и клонировавшийся, выполняет подавляющее большинство команд MS-DOS и Windows, от сжатия и распаковки (изъятия) до чистки диска и поиска файлов. При этом, управление командами осуществляется либо выбором требуемой команды мышью, либо нажатием соответствующей клавиши.

TAB переключение между окнами

F1 справка

F2 вызов меню пользователя, в котором допускается помещение часто используемых команд

F3 быстрый просмотр с возможностью смены шрифтов для текстовых файлов (“формат”)

F4 редактированье

F5 копирование в каталог открытый на соседней панели или другой, указанный пользователем.

F6 переместить или переименовать

F7 создать новый каталог внутри текущего

F8 удалить

F9 открыть меню

F10 закрыть NORTON COMMANDER

+ дополнительной клавиатуры выделяет все файлы

- отменяет выделение

Ctrl, Alt, Shift меняют действие клавиш, новое действие которых высвечивается внизу, на панели функциональных клавиш.

Alt+F1 и Alt+F2 выбор дисков (номер кнопки F зависит от того, для какой панели выбирается диск)

CTRL+F1 или CTRL+F2 убирает одну из панелей для удобства просмотра сообщений MS-DOS.

Ctrl+o с той же целью убирает обе.

SHIFT+F4 позволяет создать новый файл.

ALT+F1 или ALT+F2 в редакторе переключает кодировку с ANSI на ASCII и обратно.

Ctrl+Enter копирует имя файла в командную строку, что очень удобно, если требуется запустить файл с введением дополнительных параметров. В одну строку допускается последовательное копирование любого количества имен, лишь бы они в нее вмещались.

Alt+F5 архивирует отмеченный файл, предоставляя выбор методов архивации или добавляет в уже существующий архив.

CTRL+S и CTRL+D - перемещение по командной строке, без удаления символов. При убранных панелях это возможно и с помощью обычных клавиш перемещения курсора.

Установка и снятие флажков (атрибутов) в случае работы без мыши производится пробелом.

Выделение файлов – кнопкой insert, либо правой кнопкой мыши. При этом, для выделения группы файлов мышью вовсе не требуется бесконечное щелканье: достаточно протянуть мышь с нажатой правой кнопкой через выделяемую группу (как в Windows) – обычно так удобней чем выделять по шаблону.

Помимо всего этого, Norton Commander выполняет функции предохранения экрана от преждевременного выгорания (входящая в его состав программа Saver), включая через определенный пользователем интервал (Меню\команды\конфигурация\гашение экрана), экранные заставки (расширение .nss), для самостоятельного запуска которых достаточно подвести указатель мыши к правому верхнему углу программы. Правда, блистать разнообразием заставок он может только в среде MS-DOS – в среде Windows, заставки с расширением .nss не работают (точнее, они работают только при самостоятельном запуске программы Saver) и, не зависимо от выбора пользователя, запускается растиражированная всеми клонами “Звездная ночь” унаследованная от NC4 (Norton Commander4.0).

Кроме того, Norton Commander версии 5.0 поддерживает копирование файлов путем перетаскивания мышью и предоставляет возможность пользователю создать собственное меню утилит, построчно записав набор желаемых команд в текстовой файл и сохранив его как TOOLS.MNU, внутри папки с Norton Commander. Располагается пользовательское меню утилит на панели меню, между пунктами “команды” и “правая панель” и исполняется одиночным щелчком мыши, что, зачастую, удобней обычного пользовательского меню F2. Благодаря меню утилит, можно автоматизировать, например, вызов Scandisk (указав в Tools.mnu к нему полный путь и букву проверяемого диска), перезапуск компьютера (команда Restart, исполняющий модуль которой можно найти на изготавливаемой Windows загрузочной дискете) и многое другое.

Указанный в ярлыке Norton Commander рабочий каталог, становится текущим, при его запуске (так же и у других ярлыков MS-DOS-программ), каталог, являвшийся текущим перед его запуском, открывается на второй панели.

Текстовой редактор Edit для операционной системы MS-DOS.

Как правило, MS-DOS используется для реанимационных операций, если работа удобных и многофункциональных приложений Windows становится невозможной. Полагаться в таких условиях приходится только на внутренние возможности MS-DOS, которыми в повседневной жизни люди старательно пренебрегают, а потому, зачастую, не умеют пользоваться. Одной из наиболее пренебрегаемых, программ MS-DOS, является текстовой редактор Edit, но именно им в случае необходимости, придется воспользоваться для редактирования “автоэкзеков” и “конфигсигов”. В силу своей простоты он имеет очень скромный объём и не занимает много места, так что, не смотря на существование таких монстров MS-DOS как текстовой редактор “Лексикон”, на служебных дискетах находится именно он. Edit в своём роде совершенен, совершенен настолько, насколько может быть совершенен минимализм (и MS-DOS). Им можно не пользоваться годами, но однажды, шпаргалка по нему придется весьма кстати. К тому же, им удобно составлять небольшие “хелпники” для MS-DOS - в этом случае никаких неожиданностей с не читаемостью шрифтов не произойдёт. Каким шрифтом Windows их писать неизвестно, но написанные в Edit справки читаются где угодно; в Windows как шрифт “Terminal”, в Norton Commander как “XyWrite”, “WordStar 2000” и просто “Текст”. Кроме того, этот редактор одновременно открывает до девяти файлов, общим объемом до 5,5 мегабайт (но не более 65 280 строк), и легко справляется с файлами, неподьемными для многих его собратьев, так что его применение зачастую уместно даже в среде Windows. Единственный его недостаток – это отсутствие возможности смены шрифта, из-за чего русскоязычные тексты написанные в среде Windows, для Edit, как правило, нечитаемы.

При работе без мыши (а она в MS-DOS не является стандартным устройством и требует собственных драйверов, которых у пользователя может и не быть…), вход в главное меню открывается клавишей ALT.

Enter или клавиша перемещения курсора вниз, открывает подменю

Esc служит для выхода из подменю

F1 вызывает справку

Переход между объектами (в том числе между открываемыми подменю) осуществляется с помощью курсорных клавиш или клавиш Tab и Shift+Tab.

Insert переключает режим редактирования с замены текста вставкой во внутрь существующего, на замену замещением, и обратно.

Выделение текста происходит перемещением курсора с нажатым Shift

Клавиша Del (удаление), дублируется в подменю правки (edit) командой “очистить” (clear)

Сочетание Shift+Del – вырезать (Cut)

Ctrl+Insert – копировать (copy)

Shift+Insert – вставить (paste)

Edit является одним из самых маленьких редакторов для DOS и, судя по всему… самым удобным.

ZipMagic.

Программа ZipMagic не имеет принципиальных отличий от других архиваторов рассчитанных для работы в Windows. Возможность исполнять и редактировать файлы, присуща им всем. Единственное ее отличие – отличие интерфейса, поскольку программа предоставляет возможность работать с архивами без посредника, непосредственно, средствами самой операционной системы (хотя оболочечный вариант остается в силе), в результате чего поиск в архивах можно проводить стандартными средствами Windows, со всеми вытекающими отсюда последствиями (создание ярлыков указывающих во внутрь архива, установка PATH на находящуюся в архиве папку и тому подобное).

Вообще, наличие специального посредника (оболочки) для работы с архивами – анахронизм MS-DOS, где его отсутствие крайне усложняло работу с ними:

1. Сначала требовалось запустить архиватор (распаковывающий модуль) для просмотра оглавления архива.

2. Если повезло и, выбранный для просмотра архив действительно содержит желаемый файл, требовалось запустить архиватор еще раз, для извлечения этого файла.

3. Затем можно было производить над файлом требуемые действия.

4. Если в результате этих действий файл изменился и, дальнейшему хранению подлежала его измененная версия, требовалось (по крайней мере, в третий раз) запустить архиватор (теперь упаковывающий модуль), чтобы вновь его упаковать.

Учитывая массу параметров запуска, которые каждый раз приходилось вводить в командную строку, процедуру нельзя назвать приятной. А если ее требовалось совершить не с одним, а несколькими файлами, из разных архивов, она могла уморить кого угодно. Так что, появление архивного посредника избавило пользователя от каторжных работ, на которые он был обречен разработчиками безинтерфейсных MS-DOS-архиваторов.

Однако, в системе Windows именно персональные оболочки препятствуют свободной работе с архивами, делая доступ к ним неуниверсальным. Windows имеет неплохую встроенную оболочку, кроме того, имеется возможность установки любой другой оболочки по желанию пользователя. При этом доступ к архивам обычно возможен только в некоторых из них, да и то, с множеством ограничений. Для полноценной работы с архивами приходилось пользоваться услугами архиватора, во всех остальных отношениях, неудовлетворительными. Теперь же, благодаря ZipMagic, заархивированные файлы доступны любому приложению вне зависимости от того, работает оно с архивами или нет, даже приложению запущенному в сеансе MS-DOS (как и самому сеансу).

В связи с появлением ZipMagic, нежелательное, по разным причинам, уплотнение дисков (см. “Порядок загрузки компьютера”, “Config.sys” и др.), вообще потеряло смысл. По скорости доступа и степени сжатия программа не уступает DrvSpase, и при этом, во первых, обладает несравнимо большей гибкостью, сжимая любые объекты, а не только целые диски и логические разделы; во вторых, не занимает в MS-DOS-памяти ни единого байта.

Имеются, правда, и несущественные недостатки:

1. ZipMagic работает только в среде Windows и для доступа к сжатым файлам из режима командной строки (режима MS-DOS) все же потребуется программа-распаковщик.

2. Иногда (например, если инсталляция какого-либо продукта предусматривает распаковку некоего архива), программа приводит к ошибкам, так как после ее установки все архивы превращаются в папки, отличающиеся от обычных папок только несколько иным значком и наличием свойственного архивам расширения. В таком случае, их трансформацию следует временно запретить (Disable ZipMagic), воспользовавшись для этого появляющейся после ее установки четвертой кнопкой управления окнами или, посетив появившуюся в панели управления Windows программу настройки, запретить трансформацию архивов находящихся на определенных дисках.

3. Программа показывает размер файлов так, будто они не сжаты. Ознакомится с их реальным размером можно либо, временно запретив трансформацию и, открыв архив обычным архиватором, либо, что проще, найдя в его контекстном меню пункт “Open with ZipTools”, без всякого запрещения (в появляющемся при этом окне запроса, следует ли установить ассоциацию ZipTools с данным типом файлов, следует установить флажок "Больше не задавать этот вопрос" и ответить “нет”, если в обычном состоянии, файлы с расширением Zip должны открываться не в ZipTools, или "Да" и тогда в настройках ZipTools можно отметить чтобы ZipTools так же открывался в Explorer).

4. Поскольку ZipMagic “висит” резидентно, на старинных компьютерах, его запуск может вызвать чуть заметное замедление. Однако, на таких реликтах, вряд ли найдет применение и Windows 98.

5. При глобальных процессах, затрагивающих, в том числе и многомегабайтные архивы, преобразование их ZipMagic может привести к зависанию. Если это происходит, на период этого процесса от преобразования следует отказаться.

Перечисленные недостатки ни в коей степени не умоляют достоинств ZipMagic, а только несколько ограничивают области ее применения. Возможно, новые версии программы будут от них избавлены.

NDOS.

Программа NDOS входящая в состав нортоновских утилит для MS-DOS является интерпретатором команд, предназначенным для замены стандартного MS-DOS-интерпритатора Command.com (командой CHELL= в Config.sys), хотя может применяться и совместно с ним. Ее расширенный командный язык, содержащий 86 команд, 45 переменных и 44 функцыи (которые, по сути, то же являются командами) и основанный, для удобства, на стандартных MS-DOS-командах, вплотную приближает язык бат-файлов к обычным языкам программирования. Кроме того, многие внешние команды MS-DOS, для NDOS являются внутренними, что так же является несомненным плюсом.

При использовании обычных MS-DOS-команд, работа с NDOS отличается от работы с Command.com только форматом выдачи сообщений. Например, сообщение, выданное после команды копирования Config.sys на рабочий стол, выглядит так:

c:\config.sys => c:\windows\desktop\config.sys

1 file(s) copied

NDOS очень популярно разъясняет, что именно он сделал, чем полностью компенсирует неспособность говорить по-русски.

При использовании расширенных возможностей команд MS-DOS и использовании нестандартных для Command.com команд, во всем поможет разобраться его интерактивная справочная система, состоящая из файлов:

Nlib200.rtl

Ndoshelp.exe

Ndoshelp.hlp

В придачу к которой прилагаются текстовые файлы в коде ASCII:

Aliases

Appnotes.doc

Ncache.doc

Ndos.doc

Read.me

Samples.btm

Tour2.btm

Whats.new

Разъясняющие всевозможные аспекты применения NDOS. При чем, в локализованной версии утилит, все это, в том числе справочная система, полностью русифицировано.

Все программы локализованной версии утилит (кроме Ndos.com), так же русифицированы, поэтому, в некоторых случаях, удобней применять не сам NDOS, а какую-то программу утилит, способную выполнить ту же функцию. Однако, локализованные программы конфигурирования, упрощающие настройку утилит и NDOS, не вполне корректно создают файлы настройки (NDOS.INI, NORTON.INI) и записывают команды задания цветов на русском языке, совершенно не воспринимаемом языком операционной системы. Поэтому, после настройки, следует открыть эти файлы и изменить русские названия цветов на соответствующие английские (их название можно глянуть в справке NDOS).

Кроме того, Ndos может некоректно определить, установлен ли драйвер Ansi.sys, в связи с чем, вместо обычного очищения экрана по команде CLS, выдаст, заменяющую ее, эскейп-последовательность. Чтобы этого не происходило, следует либо ввести команду

SETDOS /A2

(например, через Autoexec.bat), либо в ndos.ini ввести параметр ANSI=NO.

MSInfo32

Программа “Сведенья о системе” входящая в состав Windows является сервисной программой, основное назначение которой – интеграция программ настройки. Среди собранных в ее меню “Сервис” утилит наибольшее значение имеют “Программа настройки системы” (MSConfig.exe) предназначенная для редактирования файлов настройки (Config.sys, Autoexec.bat, System.ini, Win.ini и меню автозапуска системного реестра) и “Проверка системных файлов” (Sfc.exe) предназначенная для отслеживания изменений в файлах ядра Windows. Последняя – самая важная. Программы Windows похожи на свору голодных собак, жадно дерущихся за ресурсы компьютера и, в этой драке системным файлам достается в первую очередь. С помощью программы Sfc.exe легко не только определить измененные или удаленные файлы (при проверке следует обращать внимание на их версию и размер: наиболее вероятно, что новые версии работают лучше и, наиболее вероятно что, русифицированные версии имеют больший размер), но и восстановить их в том виде, в котором они находились во время установки Windows или предыдущей проверки (требуется указать только место захоронения дистрибутива). Программа предложит на всякий случай сохранить заменяемые версии и, это никому не повредит.

Помимо файлов ядра, Sfc готова контролировать любые файлы, указанные пользователем, так что, при желании, она защитит весь компьютер (хотя время проверки заметно увеличится), и этим напоминает действия антивирусных ревизоров. Однако она имеет и существенные отличия. Она не замечает изменений, если версия, размер или дата остались прежними и, хотя сообщает о повреждении файлов, если обнаружит таковое, не имеет ни малейшего представления о вирусах и не может применяться для защиты от них. Но, зато, при наличии резервной копии файла, она гарантировано его восстановит, избавив от кропотливого ручного труда и, учитывая, что основные проблемы Windows связанны не с вирусами, а с некорректными программами и банальными ошибками диска, чаще всего, лечение компьютера приходится выполнять именно ей.

Если после установки программ, проверенных на предмет вирусов, происходят какие-то сбои и программы типа WinDoctor ничего не замечают, значит пришло время заняться системными файлами.

Fdisk.exe

С программной точки зрения Fdisk – низкоуровневый редактор, записывающий в строго определенные кластеры, начиная с первого физического сектора, информацию о том, где должны находится первые и последние кластеры логических разделов, чтобы соответствовать размерам разделов, заданных пользователем и, какой из разделов будет считаться загрузочным. Записанная Fdisk информация называется главной загрузочной записью (Master boot record) и не видна средствами операционной системы, поскольку не входит в состав какого-то логического диска. При запуске компьютера, она считывается программой первоначальной загрузки, находящейся в BIOS и позволяет определить параметры необходимые для доступа к жесткому диску.

Кроме создания главной загрузочной записи, Fdisk выполняет и функции ее проверки, для чего его вызов сопровождается параметром /Status.

Fdisk из последних версий MS-DOS имел недокументированный параметр /MBR позволяющий восстановить Master Boot Record в случае его повреждения. Вероятно, его действие остается в силе и сейчас.

Format.com

В простейшем случае работа Format.com заключается в проверке диска на наличие сбойных кластеров, пометке их, для избежания записи на них информации, и обнулении данных FAT (в результате чего вся информация о содержащихся на диске файлах полностью уничтожается), а так же, создании системного загрузчика. В случае создания системного диска, программа берет на себя дополнительный труд по переносу на него таких системных файлов как Msdos.sys и Io.sys, которые должны размещаться в первых логических секторах системного диска, считываемых системным загрузчиком.

Sys.com

Программа Sys.com похожа на недоделанную программу Format, запущенную с параметром /S, поскольку, хотя и переносит системные файлы MS-DOS, не проверяет сбойные кластеры, и не создает загрузочной записи (структуру корневого каталога, системный загрузчик, новую FAT), но именно благодаря этому, может использоваться для восстановления системных файлов (должных занимать строго определенное место на диске), без уничтожения имеющейся на нем информации.

Для переноса системный файлов, следует перейти на системный диск (сделать его активным) и ввести команду SYS A: где А: – обрабатываемый диск, либо, перед указанием обрабатываемого диска, указать расположение переносимых файлов:

Sys C: A:

Помимо переноса системных файлов, программа корректирует, находящийся в загрузочной записи, блок параметров диска, помечая диск как загрузочный – в этом заключается причина невозможности создания загрузочного диска ручным переносом системных файлов даже на пустой диск – и может применятся для его восстановления.

Rescue

Программа Rescue из нортоновских утилит создает файл со сложным цифровым именем, служащим для идентификации конфигурации компьютера и три файла, содержащих копии важнейших системных данных. Файл CmosInfo.dat содержит данные CMOS – составной части BIOS; файл BootInfo.dat содержит системный загрузчик; файл PartInfo.dat содержит таблицу разделов (главную загрузочную запись). Сохранить эту информацию вручную фактически невозможно и, во многих случаях (например, в случае севшей батареи питания CMOS-памяти или в случае, когда CMOS-память полностью или частично испорчена вирусом), только наличие на загрузочной дискете программы Rescue и подготовленных ей копий позволяет безболезненно восстановить работоспособность системы.

Например, при нарушении таблицы разделов, для доступа к жесткому диску без применения программы Rescue потребуется новый передел разделов, а это означает собственноручное, безвозвратное уничтожение всего его содержимого.

При запуске программы (восстанавливающего модуля), на экран выводится сообщение о ее возможностях. После ознакомления с ним и нажатия кнопки OK, открывается доступ к основному рабочему окну предоставляющему выбор объектов, которые следует восстановить. На возможность указания пути к расположению файлов данных, лучше не надеется: во многих случаях требующих вмешательства программы, доступ к жесткому диску невозможен, поэтому, если программа находится на съемном диске, созданные ею файлы должны сохранятся вместе с ней (либо на другом съемном диске, что несколько неудобно).

Обновлятся файлы Rescue должны при каждом изменении сохраняемых в них данных.

Norton Protected и UnErase.

При удалении, файлы и каталоги, на самом деле, никуда не удаляются. Удаляются только соответствующие им ссылки в таблице размещения файлов (FAT). На этой особенности основано действие таких утилит как Корзина Windows, UnErase, Norton Protected. Файлы, помещенные в корзину, считаются удаленными, поскольку информация о них отсутствует в общем разделе таблицы FAT, однако, она сохраняется в специальной таблице корзины, благодаря чему:

1. Их легко восстановить.

2. При дефрагментации диска они обрабатываются наравне с остальными, но перемещаются не к началу диска, а на границу между неудаленными файлами и свободными кластерами.

3. Запись новых файлов происходит в свободные кластеры, сохраняя целостность файлов помещенных в корзину.

Аналогично происходит при применении утилиты Norton Protected. Только хранит она информацию о файлах удаленных мимо корзины либо из нее (дублируя корзину).

Основная разница между этими двумя программами только в том что, корзина имеет фиксированный размер, а Norton Protected защищает весь диск. Но если в свойствах корзины не указывать “уничтожать файлы сразу после удаления, не помещая в корзину”, а, кроме того, увеличить размер корзины до размера всего диска, то разница между корзиной Windows и Norton Protected будет полностью устранена.

Отсюда логически следует, что Norton Protected – утилита совершенно не нужная, напрасно отнимающая часть ресурсов процессора.

Программа UnErase, в отличи от нее, очень полезна. Она не хранит никаких ссылок на удаленные файлы, но может восстановить их, считывая данные непосредственно с диска и сравнивая их с данными FAT: Файлы, не содержащиеся в таблице размещения, являются удаленными и предлагаются для восстановления.

Начинается работа UnErase с проверки корзины – обнаруженные там файлы можно восстановить и обычным образом. Затем определяются файлы, информации о которых нет даже в корзине, но которые реально существуют на диске. Первая буква таких файлов всегда затерта (так удаляется ссылка из FAT) и заменяется программой знаком вопроса – для восстановления файла требуется заменить вопрос любым допустимым символом.

Используется UnErase в случае ошибочного удаления мимо корзины (например, при работе в MS-DOS, где корзины и в помине не было). Для восстановления важно опомнится, как можно раньше, чтобы на место удаленного файла не успела записаться никакая другая информация. Но даже если на старом месте уже существует новый файл, восстановление зачастую возможно, хотя и частичное, что вполне применимо для восстановления текстов.

Так же, она используется в дополнение к UnFormat при восстановлении отформатированного диска.

UnFormat

Эта программа (из нортоновских утилит) – полная противоположность программы Format и, перезаписывая FAT, она вносит в нее точные данные о фактическом размещении файлов на диске, так что, после ее применения, диск выглядит так, будто его и не форматировали. Наиболее часто она применяется при случайном форматировании не той дискеты. Если форматирование не было полным (низкоуровневым), содержащиеся на ней данные восстановятся в первозданном виде. Однако ради спасения приблудившихся дискет вряд ли стоит разрабатывать программу и, UnFormat действительно предназначен не для этого. Иногда, ей приходится восстанавливать жесткие диски, отформатированные стараниями вирусов. Поскольку низкоуровневое форматирование вызовет всеобщий протест антивирусов, да и не может пройти незамеченным если пользователь находится рядом с компьютером (фактически, если вирус и сумеет отформатировать диск, то только тот, в отношении которого на момент форматирования не происходят операции чтения и записи, то есть – только обособленную, логическую часть жесткого диска, а такое форматирование не может происходить на физическом уровне), то наличие на дискете или CDROM программы UnFormat позволяет полностью исключить вероятность ущерба от действия форматирующих вирусов.

В своей работе программа использует данные, подготовленные программой Image, а она, в свою очередь, записывает все важнейшие данные о диске и сохраняет их в файле Image.dat. При следующем запуске, файл переименовывается в Image.bak и, вместо него, создается новый – дублирование критических данных предусмотрено на случай неумышленного снятия данных с уже поврежденного диска, что иногда происходит при автоматическом запуске программы из меню автозагрузки.

Для восстановления файловой структуры, программа UnFormat использует любой из файлов, по выбору пользователя, а для того чтобы найти их в общей неразберихе, она обращается к содержащему их физический адрес и так же, заготовленному программой Image, файлу Image.idx о котором заранее известно, что он будет помещен в последний кластер логического диска (поэтому его ручное перемещение недопустимо). Сохранять файлы Image.dat и Image.bak на дискете не имеет смысла (хотя эта возможность предусмотрена), поскольку в связи с быстрым изменением состояния диска, эти файлы требуют постоянного обновления (к сожалению, автоматическое снятие данных предусмотрено только в момент запуска Windows, хотя делать это следовало бы перед отключением компьютера) и, в частности, при таких серьезных передвижках, какие производит программа дефрагментации, данные Image совершенно устаревают, так что, программе дефрагментации приходится запускать Image в фоновом режиме, для обновления данных.

При запуске, после непродолжительного диалога, программа UnFormat определяет наличие файлов Image и предлагает на выбор два варианта восстановления:

Первый – полное восстановление, которое целесообразно применять при наличии свежих Image-файлов.

Второй – частичное восстановление, предпочтительное при их устарении. В таком случае будут восстановлены только неизменяемые элементы (BOOT-сектор), а остальное отдано на попечение других программ – столь сложная процедура связана с тем что, иначе произойдет неизбежная потеря всей информации измененной или хотя бы перемещенной после заготовления последнего Image-файла.

Но даже если на диске нет никаких файлов с данными от Image, упрямый UnFormat все равно его восстановит. При этом качество восстановления окажется тем выше, чем меньше степень фрагментации диска. Правда, с содержимым корневого каталога в любом случае придется расстаться, а вложенные в корневой каталог папки приобретут имена DIR0, DIR1, DIR2 и т. д. – вот тут-то и пожалеешь, что в корневом каталоге вообще что-то было. Но и это восстановимо – с помощью программы UnErase.

Не зависимо от варианта восстановления, после применения программы UnFormat требуется запуск программы проверяющей логическую структуру диска (например, Scandisk), для обрезания хвостов оставшихся после удаленных файлов (для уменьшения ущерба наносимого перекрестными ссылками с этими хвостами, при дефрагментации диска следует очищать свободное пространство, заполняя его нулями – это производится автоматически, после соответствующего указания в настройках программ-дефрагментаторов).

Утилиты Nuts & Bolts

Утилиты «Nuts & Bolts» от Network Associates во многом аналогичны утилитам Нортона. Они менее удобны, но зато имеют мощьные средства по улучшению интерфейса Windows, а их программы проверки диска и реестра работают быстрее и качественней. К тому же, они включают в себя программу McAfee VirusScan, считающююся лучшим антивирусом (этот же антивирус входит в пакет «MS Plus! 98») и занимают на диске гораздо меньше места. Главным их недостатком является отсутствие русскоязычной версии.

Архиваторы ACE для Windows и MS-DOS

1. Имеют вторую в мире степень сжатия, незначительно уступая архиватору WinRar и существенно превосходя Rar для MS-DOS и все другие программы (при этом, Ace для DOS не теряет длинные имена, когда запускается в среде Windows).

2. Создают самые маленькие самораспаковывающиеся архивы (при том что, обычные архивы у WinRar получаются меньше).

3. Создают интерактивные самораспаковывающиеся архивы даже под MS-DOS (в прочем, подобную возможность имеют и некоторые другие архиваторы, например, ZipMagic).

4. Имея графический интерфейс за основу которого взят интерфейс Rar и WinRar, являются одними из самых удобных архиваторов.

5. Работают с архивами нескольких типов, при чем, Ace для Windows (WinAce), без подключения внешних программ может не только открывать, но и создавать CAB, LHA и ZIP архивы.

6. Имеют хорощую справочную систему.

7. Работают как в интерактивном, так и в командном режимах.

Кроме того:

1. Поддерживая контекстное меню Windows, исполнение программ и вторую панель, а так же, имея множество дополнительных функций, WinAce является проводником более удобным чем стандартный проводник Windows (Explorer).

2. Поддерживая концепцию второго каталога, гибкую настройку и возможность запуска внешних программ Ace для DOS вполне применим в качестве файлового менеджера (хотя такие файловые менеджеры как Norton Commander и Volcov Commander все же более удобны для работы с обычными файлами).

Ace для DOS имеет единственный недостаток: некоторые его функции слишком неожиданны и не изучившему интерфейс программы могут причинить массу неприятностей. Команды типа «освежить» очень созвучные командам типа «перечитать», но имеющие совершенно другое действие (действие обычное для архивов), следовало бы вынести в отдельное диалоговое окно архивных операций.

К началу двухтысячного года русскоязычных версий программ не имелось, но работа по их переводу на другие языки ведутся.

Утилиты сжатия исполняемых файлов.

Утилиты сжатия исполняемых файлов, позволяют сжимать драйвера и программы так, что их запуск не требует предварительной распаковки. Принцип их действия аналогичен действию обычных архиваторов: сжимаемая программа снабжается SFX-заголовком, который при запуске, распаковывает ее в память и передает ей управление – поэтому разработчики архиваторов, зачастую являются и разработчиками утилит сжатия программ. Примером тому случат архиватор PkZip и утилита PkLite, архиватор Ain и утилита AinExe, Архиватор Uc и утилита UcExe. Однако механизм действия утилит сжатия программ несколько иной – одно дело распаковать на диск, другое дело распаковать в память, да так, чтобы программа себя нашла. Тут требуется и большая квалификация и большая изобретательность. Поэтому они не так многочислены как обычные архиваторы.

Различные типы программ имеют различную структуру. Устройство Com-файла существенно отличается от устройства Exe-файла. При этом, Exe-файлы и сами не однородны. Они делятся на 32-битные программы для Windows, 16-битные программы для Windows и программы для DOS. Для каждой из этих структур используется собственный алгоритм сжатия и утилиты обрабатывающие одни типы, могут не признавать другие. В частности, утилиты предназначенные для упаковки программ DOS, не сжимают программы Windows, и наоборот.

Кроме того, exe-файлы могут содержать, так называемые, оверлейные данные – данные не считываемые в память при загрузке программы, а загружаемые только по мере необходимости. В зависимости от метода присоединения оверлеев и их назначения, содержащая их программа, после сжатия, частично или полностью может потерять рабоспособность. В основном используется наиболее простой механизм прямого считывания данных по их физическому размещению в файле программы. После сжатия этот механизм не работает, поскольку данные меняют адресацию и, загрузчик оверлеев не находит их на прежнем месте. Иногда используется более интелектуальный метод поиска оверлеев по специальным меткам, позволяющий корректно загружать оверлеи даже если они были перемещены. Использующие его программы не теряют работоспособность и после сжатия, но разработчики программ редко об этом заботятся. В любом случае, основная масса утилит сжатия распознает оверлеи и выдает запрос на выполнение операции.

Существует три варианта обработки программ с оверлеями: отказатся от сжатия подобных программ, присоединить оверлеи к телу программы в несжатом виде или удалить оверлейные данные.

Первый метод применяется к программам, упрямо пытающимся загружать оверлеи по физическим адресам их былого расположения. Второй применим к программам с «интелектуальным» оверлейным механизмом. Третий применим в том случае, если оверлеи содержат несущественные данные типа экранов справки или отладочной информации, почему-то не удаленной разработчиками – такие программы будут работать как раньше, хотя перестанут выдавть справку и не смогут корректироватся с помощью программ типа Debug.

Сжатые программы, обычно, можно восстановить в исходном виде, теми же утилитами, которыми они были сжаты. Однако оверлейные программы восстанавлению не подлежат. Если оверлейная информация при сжатии была удалена, при восстановлении она не появится из «ни откуда», хотя программа не потеряет работоспособность. Если же информация была присоединена в виде несжатого блока, утилиты сжатия не в силах ее отделить и добавить к распакованному основному модулю, поэтому, они либо вообще отказываются ее восстанавливать, либо «восстановленная» программа оказывается безнадежно испорченной.

Однако, сжатие программ производится не для того чтобы их потом разжимать.

Среди утилит сжатия наиболее примечательны следующие:

Diet.exe 1.45f – утилита обеспечивающая один из лучших коэффициентов сжатия для Com-файлов, сжимающая Exe-файлы для DOS, драйвера и файлы данных (при этом, доступ к сжатым данным обеспечивается если Diet установлен в память резидентно и обрабатывает их подобно DblSpace или ZipMagic – в этом режиме могут использоватся даже неподдатливые программы с оверлеями).

AvPack.exe – утилита иногда превосходящая Diet в области сжатия Com-файлов и часто превосходящая его в области сжатия Exe-файлов под DOS. Распаковывает файлы не только собственной упаковки, но и файлы обрабртанные LzExe (при чем качественней чем специально для этого разработанные программы UpackExe и UnLzExe), а так же некоторыми версиями PkLite и ExePack. Позволяет добавлять оверлеи к сжатым модулям.

PkLite.exe (версии 2.0 и выше) – утилита имеющая много возможностей, сжимающая не только программы для DOS, но и 16-битные программы для Windows (при этом, программы Windows восстановлению не подлежат). Владеет распаковкой файлов обработанных LzExe и ExePack. Позволяет добавлять оверлеи к сжатым модулям.

UcExe.exe – утилита, которая, не смотря на создание заголовка-распаковщика, не уступает в сжатии Zip-архиватору. Однако, Com-файлы превращаются в Exe, что не всегда корректно работает и не восстановимо. Позволяет добавлять оверлеи к сжатым модулям, для перепаковки файлов обработанных ExePack или LzExe вызывает утилиту UpackExe.

Apack.exe – сжимает даже сильнее чем UcExe, позволяя сэкономить порядка пятидесяти килобайт на каждом мегабайте (в сравнении с UcExe), однако обработанные ей программы для своего выполнения требуют больше памяти (это легко обнаружить для резидентных программ, запустив программу Mem.exe и для некоторых нерезидентных программ, имеющих датчики памяти, например, архиватора Rar).

AsPack.exe – утилита сжатия 32-битных программ Windows, встраивающаяся в контекстное меню и, кроме массы возможностей и удобного инткрфейса, имеющая юмористический перевод на русский язык. Однако, сжатые ей программы (как, очевидно и любые сжатые ресурсы Windows), восстановлению не подлежат.

Com2exe.exe (или ComToExe) – не вполне утилита сжатия, поскольку ничего не сжимает, но иногда она применяется для преобразования Com-файла в Exe-файл для последующей его обработки программами сжимающими только Exe-файлы (например LzExe.exe – самой первой программы этого класса). Такое преобразование не всегда корректно, поскольку изменение заголовка программы не меняет ее структуры и, например, Volcov Commander, преобразованный ей в Exe-файл и сжатый утилитой AinExe.exe, при потытке загрузить его в верхнюю память, приводит к зависанию компьютера, но обычно, вполне приемлемо.

Cup386.com – не является утилитой сжатия, зато, аналогично программе DrWeb (но с большими возможностями), восстанавливает запакованные файлы, загружая их в память и прослеживая их поведение при выполнении. Такое восстановление не вполне корректно, поскольку использует не строгий механизм распаковки, заложенный в программах-упаковщиках, а эвристический анализ и, зачастую, вытаскивает из памяти немного мусора. По этому, оправданно только при отсутствии оригинального упаковщика или, если тот, по каким-то причинам (например, помимо упаковки файл зашифровывался), с этой работой не справляется. То же касается программы DrWed.exe и других универсальных распаковщиков.

Примеры применения упаковщиков

(за стопроцентное сжатие принято сжатие до нуля)

Программа | Исходный Размер | Примененная Утилита | Полученный Размер | Степень сжатия
Драйвер языка и клавиатуры KeyRus.com | 22,714 Кб | AvPack.exe | 12,224 Кб | 46%
Программа взаимодействия с CDROM Mscdex.exe (с оверлеями) | 25,473 Кб | AvPack.exe | 18,166 Кб | 28%
Драйвер памяти HiMem.sys | 33,191 Кб | Diet.exe | 11,227 Кб | 66%
Программа проверки и исправления ошибок диска DmDos.exe | 213,488 Кб | UcExe.exe | 83,189 Кб | 61%
Редактор WinWord.exe | 8,441 907 Мб | AsPack.exe | 4,366 336 Мб | 48%

Почти все перечисленные программы имеют русскоязычные версии, а упомянутая утилита ZipMagic может считаться языконезависимой.

Обычно их называют оболочками. Посредник – определение более точное, а без точных определений, иногда вообще не понять суть вопроса.

Например, команда

Echo %_ROWS %_COLUMNS

где переменная %_Rows определяет число строк на экране, а переменная %_Columns определяет число столбцов, выведет сообщение о текущем экранном разрешении.

Команда

Echo %@EVAL[135462 / 4563]

где %@EVAL - внутренняя математическая функцыя, выведит на экран результат деления числа 135462 на число 4563, с точностью до восьмого знака.

При переносе системных файлов в ручную, с диска можно загрузится, однако система выдаст сообщение об ошибке в конфигурации и предложит, загрузившись в режиме Command prompt only, запустить программу ScanReg – совет, который следует игнорировать. Если же диск уже является загрузочным и блок параметров диска не поврежден, восстановление системмых файлов в ручную вполне допустимо.


Некоторые расширения

ANI – «живой» указатель курсора

ARC – архивный (сжатый) файл

ARJ – архивный файл

ASM – программа на языке ассемблера

AVI – сжатый видеофайл

BAK – резервная версия файла (обычно сохраняемая перед внесением изменений)

BAS – программа на языке BASIC

BAT – командный файл MS-DOS (программа на языке MS-DOS)

BIN – файл в машинном коде, в том числе, программа или драйвер

BMP – рисунок

C – программа на языке С

CAB – архив открываемый стандартными средствами Windows (но существуют нестандартные “кабы”)

CDR – векторный рисунок

CFG – файл параматров программы, обычно в ASCII-коде читаемом как шрифт Terminal

CHI – текстовой документ

CNT – файл интеграции справочной системы

COB – программа на языке Cobol

COM – исполняемый файл (программа MS-DOS)

CPL – компонент панели управления

CPI – файл кодовой страници

CUR – указатель курсора

DAT – файл данных для какой-либопрограммы

DB – база данных

DBF – высокоорганизованный файл данных, в том числе, база данных

DIZ – текстовой файл сопровождающий программы полученные из интернета и, часто, описывающий способ их взлома

DLL – динамически подключаемые данные для использования многими программами

DOC – документ содержащий отформатированный текст

DRV – драйвер

EPS – рисунок

EXE – программа

EXT – файл регистрирации типов файлов, применительно конкретных программ (в некоторых программах MS-DOS)

GIF – рисунок

FNT – файл шрифта для принтера

FOR – программа на языке Fortran

HA – архивный файл

HLP – файл интерактивной справки

HTM – интерактивный документ в формате интернета

HTML – интерактивный документ в формате интернета

ICE – архивный файл

ICO – значек

INF – сведенья считываемые Windows перед установкой драйверов

INI – файл настройки программы или операционной системы, обычно, в коде ASCII

JPG – сжатый графический формат

KBD – файл раскладки клавиатуры для Windows

LET – письмо

LIB – библиотека подпрограмм

LID – конфигурация программы инсталяции

LNK – ярлык Windows-программ

LOG – протокол выполнения работ. Иногда служит только для отчета (например, отчеты антивирусных програм), но многие служат для возможности возврата системы в исходное состояние (деинсталляцыя програм, восстановление удаленных ссылок из реестра и т. д.).

LSP – программа на языке LISP

LZH – архив

MAC – макрокоманда на языке Ассемблера

MID – набор команд MIDI (синтезированая музака)

MNU – файл меню программ MS-DOS

MOD – если не Xcopy32. Mod – синтезированная музыка

MSG – файл содержащий сообщения выводимые программами MS-DOS в различных ситуациях

NSS – файл экранной заставки MS-DOS-оболочек

OBG – обьектная программа

OVG – оверлейный файл (дополнительные настройки для программ)

OVR – оверлейный файл

OVL – оверлейный файл

PAK – архивный файл

PAS – программа на языке паскаль

PLS – плейлист, двойной щелчек на котором интерпритируется как команда исполнения

PCX – рисунок

PIC – рисунок

PIF – оверлельный файл (Windows-ярлык MS-DOS-программ)

PRN – файл подготовленный для ввода на принтер

PRO – программа на языке Пролог

PSD – рисунок

RA – музыкальный файл интернет

RAM – музыкальный файл интернет

RAR – архивный файл

REG – фрагмент реестра Windows, добавляемый к реестру двойным щелчком, с заменой параметров при совпадении.

REF – таблица перекрестных ссылок

SCR – экранная заставка

SEQ – программа на языке Forth

SYS – если не Io.Sys, MsDos.Sys и не Config.Sys, то драйвер

TIFF – рисунок

TMP – временный файл

TPL – библиотека для Турбо Паскаля

TPU – объектный модуль для Турбо Паскаля

TXT – простой текстовой файл, понимаемый любым текстовым редактором

URL – ярлык интернета

VXD –драйвер виртуального режима, при необходимости динамически подгружаемый Windows

WAV – оцифрованный звук

WBK – резервная копия DOC-файла

WMF – метафайл (рисунок орткрываемый, как растровыми, так и векторными редакторами)

WRI – документ созданный программой WordPad

XLS – таблица Exell

ZIP – архивный файл

ZOO – архивный файл

$$$ – временный файл


Нечитаемость и неудаляемость содержимого папки.

Нечитаемость.

Порча (например, по причине образования общих кластеров) или случайное удаление каких-либо файлов малоприятна, но особыми неприятностями грозит порча или удаление драйверов национальной поддержки в версиях Windows рассчитанных на применение в неанглоязычных странах (наибольшее значение из них имеет Country.sys). Сам Windows реагирует на подобные происшествия вполне лояльно. И исправно продолжает отображать имеющие, например, русские названия, папки и файлы, их настоящими именами. Но у программ требующим монопольного доступа к диску, неизбежно возникают проблемы и либо, по неизвестной пользователю причине, некоторые их функции становятся недоступны, либо они не запускаются вообще; иногда, вместо запускаемой программы может появиться диалоговое окно с примерно таким сообщением: “Невозможно выполнить н5&-r?Ё~{]w”. Программы проверки логической структуры диска вопиют в таких ситуациях об ошибках в структуре каталогов и неверных длинных именах для MS-DOS, уговаривая позволить им исправить ошибку и обещая взамен золотые горы. Особенно щедра на обещания программа Norton Disk Doktor (зато с Scandisk из Windows, таких недоразумений вообще не возникает).

В ПОДОБНЫХ СИТУАЦИЯХ ПОЛАГАТЬСЯ НА ПРОГРАММЫ ПРОВЕРКИ ДИСКА НИ В КОЕМ СЛУЧАЕ НЕЛЬЗЯ. Обрабатывая диск без русификаторов, они превратят содержимое каталогов в такое месиво, что единственным способом его исправления станет форматирование диска: рабочий стол и главное меню окажется недоступным, запустить какую-либо программу или добраться до каталога её содержащим окажется невозможным, в ряде случаев не помогут и клавиши быстрого вызова, назначаемые в ярлыках программ. Даже отключение и перезапуск компьютера можно будет произвести только после применения Ctrl+Alt+Del (и то, только в том случае, если по несчастью, человека не угораздило дать папке Windows русифицированное имя).

Загрузка в режиме командной строки после исправления структуры каталогов и длинных имен без русификаторов, позволяет обнаружить, что многие файлы и каталоги получили странные “исправленные” имена состоящие из смеси французских, арабских и китайских символов. Загрузка Windows окажется невозможной.

Все это можно исправить с помощью MS-DOS-версии программы UnErase и ей подобных (только сначала разобраться с русификаторами: есть ли они, правильно ли указана ли на них ссылка в файлах Autoexec.bat и Config.sys, да и вообще, не исчезли ли сами файлы конфигурации), но исправить все имена она вряд ли будет в состоянии, даже если снимок данных о названии и адресации файлов, типа снимков выполняемых программой Image, выполнялся каждый день, а программы-востановители UnErase и UnFormat находятся на загрузочной дискете.

Лучшим способом защиты, как известно, является нападение. Поэтому, во избежание подобных проблем, следует регулярно производить проверку логической структуры диска и не допускать перерастания небольших ошибок в стихийное бедствие. Иногда стоит проверять наличие и правильность состава файлов конфигурации, рискующих пострадать от некорректной установки какой-либо программы (что можно поручить программе Registry Trascker из нортоновских утилит, если резидентное нахождение столь жадной до ресурсов программы допустимо с точки зрения мощности процессора).

Не менее эффективным способом предохранения (хотя и не таким универсальным, как проверка диска и файлов конфигурации), служит помещение в Autoexec.bat строчек:

If exist C:\моидок~1\авп.prf goto NORM

Echo Нет русификации (No Rusification)!

Pause

:NORM

Где авп.prf – любой файл в русскоязычной папке “Мои документы”, если он доступен – все в порядке.

Пока эти команды находятся в Autoexec.bat, потеря русификации не пройдет незамеченной.

Но главное средство профилактики заключается не в этом. Главное (хотя, как разобрать, что здесь главнее?) – исправить ошибку сотрудников корпорации Microsoft, локализовывавших своё детище и, присвоить папкам “Главное меню” и “Рабочий стол” какие-нибудь… англоязычные имена (хоть “Rabochi Stol” и “Menu”), тогда, даже после случайной порчи Autoexec.bat, даже лишившись Country.sys, даже исправив неправильные с точки зрения Диск-докторов, названия на действительно неправильные, вы не лишитесь Windows, а это уже многое: ориентация не только по размерам, расширениям дате создания и остаткам англоязычных названий, но и по значкам, предоставляет не меньше сведений, чем любое название. Восстановив благодаря этим сведеньям русские имена папок и программ можно обойтись и без таких рискованных процедур как применение UnErase и UnFormat (восстановить их из MS-DOS , а значит, и получить доступ к Windows не удастся не столько по причине трудности поиска среди одинаково неправильных имен единственно нужного, сколько в силу неподдерживаемости MS-DOS столь длинных имен как “Рабочий стол” и “Главное меню”).

Переименование системных папок “Рабочий стол” и “Главное меню” (как и переименование любых других системных папок), имеет свои особенности, но это не должно помешать столь нужному делу, поскольку пара минут на него потраченных – ничто в сравнении с тем от скольких головных болей оно, в случае чего, избавит.

После переименования папки “Главное меню”, главное меню окажется недоступным, поскольку изменения внесенные в системный реестр ее переименованием еще не вступят в силу. Для того чтобы они вступили в силу, требуется перезагрузка компьютера, но выполнить ее удастся только через Ctrl+Alt+Del. Если по каким-то причинам доступ к главному меню не будет получен даже после перезагрузки, следует добраться до него через систему окон “Мой компьютер” на рабочем столе и вернуть папке прежнее имя (для этого требуется доступ к рабочему столу и на всякий случай – береженого и Бог бережет – переименование Рабочего стола и Главного меню не следует выполнять за один прием). После обеспечения доступа к Главному меню, как бы оно не называлось, даже если ему пришлось вернуть прежнее название, следует взяться за папку “Рабочий стол”. Проблемы с переименованием этой папки не возникают, но на тот случай, если у кого-то найдется персональная проблематичная папка рабочего стола, перед ее переименованием следует иметь гарантированный доступ к главному меню, чтобы в случае чего, войти в главное меню и посредством “Проводника” или какого другого файлового посредника добраться до нее с целью возвращения прежнего имени.

Неудаляемость.

Неудаляемость папок и файлов возникает из-за неправильности их имен. Некоторые символы закреплены за управляющими кодами и не могут применяться в названиях имен и папок (знать эти символы необязательно, так как в системе Windows включение таких символов в название просто невозможно), но некоторые программы умудряются все же создавать файлы и папки именно с такими названиями. Преуспевают на этом поприще программы – архиваторы. Если русифицированным архиватором упаковать нечто русско-именное, а затем, распаковать полученный файл архиватором нерусифицированным, получится именно то, о чем идет речь. Аналогичное получится и наоборот. В любом случае, последовательная обработка русскоязычного файла разноязычными архиваторами приводит к нежелаемому результату, а это – логическая ошибка – предпосылка к тому что, с течением времени вся, старательно отлаженная, система прикажет долго жить . Исправление таких ошибок с помощью сервисных программ мало эффективно, поскольку нужные имена файлы так и не приобретают, и заниматься ими приходится в ручную, что требует много времени и вообще, неудобно. Проще удалить эти файлы и создать заново, распаковав их более подходящей программой. Но многие из них, по причине ошибочных имен, Windows не может даже удалить. Более результативно их удаление в среде MS-DOS с применением файловых посредников типа Norton Commander или команды DelTree, однако, и в этой ситуации не все складывается благоприятно, так что, оставшуюся часть файлов, все-таки приходится переименовывать вручную (а затем, как правило, все же удалять, поскольку новые имена врядли совпадут с исходными).

Чтобы подобных проблем не возникало, следует иметь в наличии как русифицированный, так и, нерусифицированный архиватор – неизвестно ведь каким архиватором упаковывался тот или иной архив – а перед распаковкой, просматривать содержимое архива, чтобы определить, есть ли в нем русские имена и нормально ли они читаются данной программой. Неправильность отображения неанглоязычных имен проявляется уже на стадии просмотра, в то время как, англоязычные имена всеми архиваторами понимаются одинаково. А чтобы избежать неудобства работы с архиваторами, вступающими в диалог на плохо знакомом языке (недостаточное понимание вопросов задаваемых программами – один из основных источников компьютерных проблем), англоязычные архиваторы можно подключить к русскоязычному файловому посреднику, например, локализованной версией Windows Commander, который возьмет на себя общение с архиватором и избавит пользователя от этой необходимости. Так же, можно воспользоваться программой ZipMagic стирающей все грани между архивами и обычными папками вследствие чего, диалог ведется на языке используемого файлового менеджера, однако проблема разноязыкости при этом не исчезает.

Подобных проблем не имеет русскоязычный WinRar, и воспроизводит русские имена так же, как англоязычный, но при этом, по скорости работы и степени сжатия в формате Zip, заметно уступает настоящим Zipам (сжатие в родном Rar у него гораздо лучше, но в силу отечественного происхождения этот формат недостаточно распространен, чтоб считаться универсальным).

Рецепт №1

Любимым занятием компьютерщиков (судя по частоте его производства) является переустановка операционной системы (Windows). Иногда, после установки большего числа новых программ, ошибки диска (типа неуникальных имен), вследствие подмены общих ресурсов, следуют одна за другой. Пытаться исправить их с помощью сервисных программ – все равно что, сушить белье под проливным дождем. Переустановка операционной системы способна решить эту проблему, оснастив спорщиков наиболее универсальными библиотеками. Если она не помогает, стоит проверить, не награжден ли компьютер вирусом (по сути, с этого лучше и начать). Если таковой не обнаружен, с программой внесшей разлад в работу компьютера следует расстаться (или мучатся, оставшись с ней), а программы, ранее работавшие нормально, но теперь потерявшие эту способность, переустановить. Если и это не помогает, существует рецепт №1 – переустановка Windows. Если он не помогает даже после этого, существует рецепт №2 – форматирование диска и, к программе – разрушителю больше не возвращаться.

Рецепта №3 не существует, однако, есть способ защитить себя от подобных неприятностей: убедившись, что система пребывает в полном здравии и отличной работоспособности, следует открыть программу “Сведенья о системе” (MSInfo32.exe) и через меню “Сервис”, запустить программу “Проверка системных файлов” (эту же программу можно запустить непосредственно, она находится в папке SISTEM и называется SFC), где запустить проверку и обновить сведенья о системных файлах. В случае сбоя, можно вернутся к этой программе, и восстановить систему в том состоянии, в котором она прибывала на момент обновления сведений (в идеальном). Обновлять сведенья о системных файлах следует после каждого обновления программ, предварительно убедившись, что работоспособность системы действительно не пострадала. Процесс проверки, обновления и восстановления полностью автоматизирован (хотя может выполняться в ручную) и не требует много времени. Помимо того, восстановить работоспособность компьютера можно, используя папку C:\Windows\Sysbckup содержащую файлы, зарезервированные при переустановке Windows (всего до десяти мегабайт, которые при желании можно смело выкинуть) и копии файлов конфигурации Windows за последние несколько дней, помещенные в Каб-файлы.

См. пример загрузочного меню жесткого диска (глава "Диалоговые командные файлы... ").

Источник проблемы заключается, очевидно, в изменении, затронувшем в недавнее время, стандарт кодировки русских символов и, судя по всему, это проблема только старых архиваторов, расчитанных на другую кодировку.

с поиском последних проблем не существует, а первый можно найти, например, в составе русифицированного Norton Commander для Windows 95


Обеспечение доступа к коппакт-диску в MS-DOS.

Для обеспечения доступа к компакт-диску в MS-DOS требуется установка MS-DOS-драйвера CDROM из файла Config.sys и программы поддержки чтения компакт-дисков MsCDex.exe из Autoexec.bat или командной строки.

Для большинства CDROM подходит имеющийся на загрузочной дискете или в папке C:\Windows\Command\EBD драйвер OakCDROM.sys. Если нет ни того, ни другого, но есть дистрибутив Windows, то драйвер можно извлечь из находящегося там файла Base5.cab, для чего нужно либо открыть Base5.cab двойным щелчком мыши (кстати, автоматический поиск внутри сжатых файлов, даже внутри “кабов”, удобно производить, используя для этого функции файлового менеджера Windows Commander, после подключения к нему внешних архиваторов), либо извлечь его от туда с помощью программы “Сведенья о системе”, где в списке меню “Сервис”, требуется выбрать “Проверка системных файлов”, и, переключив появившуюся программу на извлечение системных файлов с установочного диска, указать данный драйвер и папку дистрибутива.

Для устройств, не поддерживаемых этим драйвером, требуется драйвер с установочной дискеты, поставляемой с CDROM.

Загрузка драйвера CDROM производится с дополнительным параметром /D:mscd001, где 001 - порядковый номер устанавливаемого драйвера (обычно хватает одного).

В процессе установки, драйвер выводит сообщение, в строке “Device Name”, которого, указывается параметр, необходимый для загрузки программы MsCdex.exe.

При загрузке операционной системы с дискеты, это обычно тот же /D: mscd001.

При загрузке операционной системы с жесткого диска, как правило /D:12345678.

Таким образом, доступ к компакт-диску обеспечивается включением в Config.sys строки:

Devicehigh=…Oakcdrom.sys /D:mcsd001

И включением в Autoexec.bat строки:

LH …Mcsdex.exe /D:12345678

Где вместо троеточия указывается путь к драйверу.

При этом, команда загрузки Mscdex.exe может иметь дополнительные параметры, среди которых /K - указывающий на необходимость распознания дисков Kanji и, должна выполнятся раньше команды Smartdrv. Кроме того, при применении нескольких драйверов Cdrom, она должна иметь несколько параметков типа /D:mcsd001, обеспечивающих связь с каждым из них.


Оптимизация на простейшем уровне.

Обобщенно.

Наращивание мощности компьютера не имеет смысла, если уже имеющиеся мощности, не используются в полной мере. Однако, стремление получить от компьютера стопроцентную отдачу среди владельцев компьютеров почти не наблюдается. Большинству больше по душе гордость от обладания ультрасовременной техникой, даже если реальное быстродействие этой техники, в результате их собственного неумения с ней обращаться, находится на допотопном уровне. Между тем, увеличить реальное быстродействие компьютера очень просто.

В первую очередь, быстродействие зависит от архитектуры процессора, его тактовой частоты, скорости и размере оперативной памяти, скорости винчестера. По этому на первом этапе, эффективная работа компьютера зависит от правильности выбора конфигурации. И здесь все довольно просто:

Процессоры нового поколения, за счет иной архитектуры, при одной и той же рабочей тактовой частоте, работают быстрее, чем процессоры поколения предыдущего.

Не менее важна для Windows оперативная память. В отличие от DOS, где 4 мегабайта оперативной памяти является роскошью (1 мегабайт для программ и 3 мегабайта для виртуального диска), в Windows ее объем так же влияет на быстродействие, как и тактовая частота процессора. При недостаточном объеме памяти, Windows хранит избыток оперативной информации в файле дисковой подкачки, именуемом Win386.swp (свап-файл). Увеличение объема оперативной памяти уменьшает использование свап-файла и, поскольку обмен с ней в тысячи (а то и миллионы) раз быстрее, чем с диском, многократно увеличивает общее быстродействие, особенно при переходе от одного приложения к другому и обмене данных между ними.

Скорость жестких дисков определяется стандартом: IDE, E-IDE, и SCSI. Первые из них наиболее допотопны и медлительны, последние – наиболее быстры. Стандарт E-IDE появился позднее SCSI, но при этом не является более быстрым. Он появился как модернизация IDE стандарта и по скорости занимает промежуточное положение между медлительными IDE и быстрыми SCSI. Промежуточная у него и цена.

Дополнительное ускорение работы с диском обеспечивается наличием встроенного кеш-буфера, более дешевая, но не менее эффективная замена которого обеспечивается кэшированием диска в оперативной памяти.

Наибольшая неразбериха возникает с такими немаловажными комплектующими как видео и саунд карта: считается, что чем дороже вещь, тем она лучше, хотя, реальная разница в цене зависит не от качества продукции, а от технологии ее изготовления.

Саундкарта.

Саундкарты на основе чипсета ISA, для нормальной обработки MIDI файлов требуют большого количества собственной (дорогостоящей) оперативной памяти и без нее, при воспроизведении MIDI звучат как веревка натянутая на фанере. Пришедшие им на смену саундкарты на основе PSI чипсета, ни в какой памяти не нуждаются, а посему, при том же качестве MIDI звука, имеют в несколько раз меньшую цену. При озвучивании VAW-файлов, оба типа карт ведут себя одинаково.

Разные саундкарты поддерживают разные варианты обьемного звука. Обычное стерео имеет любая современная карта. Многие недорогие карты поддерживают так же расширение стереобазы – так называемое, псевдостерео. Вчера были популярны всевозможные типы “звуковых театров” где, для получения, действительно обьемного звука, слушатель обкладывался со всех сторон колонками, каждая из которых подключалась к собственному выходу. Мода грядущего сезона – A3D. В этом стандарте объемный звук, вплоть до вращения вокруг слушателя, достигается путем специальной обработки и выдачи на… два канала, что гораздо удобней, чем завалить всю квартиру динамиками. Кроме того, ощущение объема остается даже после перезаписи звука на обычный магнитофон (что очень полезно для музыкантов), о чем всяким квадро-стерео и не снилось. Правда поддержка A3D, пока что мало какими программами (и играми) обеспечивается, в таком случае, A3D будет звучать как обычное стерео.

Режим A3D реализован в картах Diamond Monster Sound и Turtle Beach Montego A3Dxtream (у Turtle Beach много карт, в названии которых фигурирует слово “Montego”, не все из них работают в A3D), естественно, обе эти карты собраны на чипсете PSI.

Соотношение полезного сигнала к шуму в основном зависит от битности саундкарты. 20-ти битные карты изготавливаются для профессионалов. Поговаривают о существовании какой-то 24-х битной карты, но в продаже ее не видно. А максимальная частота воспроизводимого звука определяется половиной частоты дискретизации.

Видеокарта.

Плоская графика.

Качество экранного изображения, в первую очередь, зависит от цветового режима. Для Windows, он имеет три варианта (не считая 16-ти цветного безопасного режима, включаемого в экстренных ситуациях):

Luw color (8-битный цвет) – 256 цветов.

High color (16-битный цвет) – высококачественный режим в 65 тысяч (65 Кило) цветов.

True color (24-битный цвет) – предел различимого глазом цветового диапазона, составляющий 16,7 миллионов (16,7 Мега) цветов. При этом режиме, картинка выглядит наиболее естественно (однако, большой разници между High color и True color не наблюдается).

Вторая составляющая качества изображения – его относительная зернистость, прямо пропорциональная размеру монитора и обратно пропорциональная экранному разрешению (генерируемому количеству точек). С увеличением размеров монитора, для удержания четкости изображения на приемлемом уровне, приходится увеличивать и экранное разрешение (в частности, для достижения качества изображения, выдаваемого 14-ти дюймовым монитором с разрешением 640х480 точек, 17-ти дюймовый монитор должен иметь разрешение 800х600).

В сумме, понятия экранного разрешения и цветового режима, складываются в понятие видеорежима (именно он предлагается к выбору, когда пользователь щелкает правой кнопкой мыши по значку настройки экрана на панели задач). А возможности видеорежима находятся в прямой зависимости от количества оперативной памяти видеокарты.

Цветовой режим True color, при разрешении 640 на 480 точек (видеорежим 640х480х16,7М), обеспечивается даже видеокартой с одним мегабайтом оперативной памяти.

Разрешение 800х600, для того же количества цветов требует видеокарту с двумя мегабайтами памяти.

Разрешение 1024 на 768 требует четырех мегабайт.

Для 1280 на 1024 все те же, четыре, хотя, при перемещении, отчетливее проявяться рывки.

Для 1600 на 1200, порядка восьми.

Видеокарты на AGP чипсете более проворны, чем PSI-карты, данные для которых приведены, и при том же количестве памяти, обеспечивают лучший видеорежим за счет сброса излишков информации в оперативную память компьютера. Хотя, в основном, их преимущество становиться заметным, только тогда, когда эта, плоская графика приходит в движение.

Точная величина необходимой памяти для PSI карт высчитывается по формуле:

Где:

V – требуемая память в байтах;

R – разрешение, равное произведению количества точек по горизонтали и вертикали;

B – цветовой режим, в битах.

Для переведения полученного числа в мегабайты, следует разделить его на 1 048 576.

Поскольку приемлемая величина экранного разрешения зависит от размера монитора, то именно он, в конечном итоге, и определяет необходимое количество видеопамяти.

Некоторые пользователи, надеются увеличить, и без того, высокую четкость изображения, простым увеличением экранного разрешения, совершенно не учитывая что, количество точек в отдельных элементах, а значит и качество их изображения при этом остается неизменным. В результате, они только портят себе зрение, поскольку увеличение разрешения уплотняет точки, уменьшая размер значков и текстовых сообщений, вплоть до полной неразличимости.

Для изменения качества элементов, следует отредактировать сами элементы, изменив их размер в пикселях, для чего существует специальная вкладка свойств рабочего стола, называемая “Оформление”. Кроме того, часть полезной может оказаться установка или снятие флажка “Использовать крупные значки”, во вкладке “Эффекты”, тех же свойств. Без подобной коррекции, увеличение экранного разрешения пригодно только для большей его вместительности, однако, ее увеличения можно добиться указанием отображения мелких значков. При чем, без каких-либо дополнительных нагрузок на видеокарту.

Немаловажным параметром для видеокарты является частота RAMDAC. Чем выше эта частота, тем большую частоту обновления экрана (частоту развертки) при большей разрешении способна она выдать. Но, поскольку все современные видеокарты имеют RAMDAC не менее 170 Гц и, соответственно, выдают 100 герцевую развертку вплоть до разрешения в 1280х1024 точек, реально устанавливаемая частота обновления определяется только качеством монитора.

Высокая частота обновления обеспечивает столь быструю смену изображения, что глаз не успевает ее замечать. Он воспринимает изображение как нечто цельное, и не устает смотреть на экран.

Телевизионное изображение обновляется с частотой 50 Гц. Для монитора сие недопустимо. Нынешние стандарты требуют от мониторов исправной работы, по крайней мере, с частотой 85Гц. 100Гц считается атмосферой комфорта, но выдерживают этот комфорт, лишь самые высококлассные мониторы.

Лидером в производстве мониторов является Viewsonic. Его мониторы рассчитаны на потребителей разного уровня и для каждого уровня обеспечивают максимально высокое качество .

Сжатое видео.

При просмотре сжатого видео, за счет большей пропускной способности чипсета, при прочих равных параметрах, качество изображения (уменьшение зернистости и рывков) для AGP-карт, на 45% выше чем у видеокарт PSI. Добится "живого" качества на PSI картах невозможно в силу того что, необходимый поток информации просто не успевает на них поступать.

Объемная графика 3D игр.

3D графику все “плоские” видеокарты обрабатывают одинаково сносно, но для действительно качественной ее обработки, без рывков при движении и убогости текстуры (рисунка поверхности изображаемых объектов), применяются специальные 3D карты или дополняющие обычную карту 3D ускорители. Снабжающая их память предназначена не столько для увеличения возможности статического (плоского) видеорежима, сколько для обработки движущихся текстур. Здесь разумного придела количества памяти не существует. Достаточное количество сегодня, может оказаться недостаточным завтра, при выходе в свет новой, более тонко прорисованной и более скоростной игры.

Среди ускорителей, особую популярность снискали Woodoo2 и Banshee (торговая марка 3Dfx). Но по нынешним временам, оснащать компьютер такими монстрами – все равно, что пользоваться орудиями каменного века. Гораздо мощнее и современней (читай – дешевле), использовать не сплав дорогой видеокарты с дорогим ускорителем, а полноценную видеокарту с поддержкой 3D.

Мощность 3D-видеокарты зависит от количества установленной на ней памяти, типа шины (PSI или AGP) и 3D чипсета. Последние, в порядке возрастания возможностей перечислены далее (Фирма производитель – в скобках):

i740 (Intel) – применяется на таких картах как ASUS 3Dexplorer, STB Light Speed 740 и других, устанавливается также, на материнские платы нового образца собственного, Intel производства.

ARK Tyger 3D (ARK Logic)

Savage 3D (S3) – хорошая карта, но отличается слабой поддержкой со стороны производителей игр (слишком нова), вследствие чего, некоторые игры за 3D карту ее не воспримут. Аналогичные мощности имеют RivaZX и PowerVRSG

ATI Rage 128 (ATImach)

RivaTNT (Nvidia)

MGA-G200 (Matrox) – ни один 3Dfx ускоритель не дотягивает до собранных на этом чипсете видеокарт.

Программная оптимизация.

Программная оптимизация является второй составляющей реального быстродействия. Она не способна увеличить мощность компьютера и, предназначена лишь для разумного распределения его ресурсов. Однако пренебрежение ей приводит к ощутимой потере производительности.

Оптимизация режима энергосбережения.

Одним из параметров, зачастую нуждающимся в оптимизации, является режим энергосбережения. Беспокоясь о предоставляемой гарантии, некоторые сборщики компьютеров, выставляют параметры работы аппаратуры в режим максимального энергосохранения, вследствие чего, жесткий диск и прочие устройства отключаются, если операции чтения и записи не производятся втечение минуты – что, на первый взгляд, кроме всего прочего, должно уберечь их от преждевременного износа. Однако, максимально снижая расход электроэнергии, такая установка не только замедляет работу компьютера вынужденными паузами (симптомом подобной установки является периодическая подгрузка компьютера, во время которой его работа приостанавливается), но и разрушает жесткий диск бесконечным дерганьем. Чтобы исправить эту оплошность не в меру усердных сборщиков, следует

1. нажатием клавиши DEL, на начальном этапе загрузки компьютера войти в BIOS,

2. клавишами вертикального перемещения курсора с последующим нажатием ENTER войти в подменю “POWER MANAGEMENT SETUP” и, в его пункте “POWER MANAGEMENT”, клавишами Page Up и Page Down указать желаемый режим.

3. Одним из возможных режимов является “User Define” – определяемый пользователем, при выборе которого, в пункте “HDD Power Down” у пользователя появляется возможность самому выставить время ожидания перед приостановкой жесткого диска. Запрет остановки (DISABLE), лучше не применять, так как в этом режиме диск периодически будет вращаться в холостую (например, при прослушивании компакт-диска), а значит, напрасно тратить электроэнергию и, что гораздо важнее – напрасно изнашиваться.

4. После задания приемлемых параметров (которые в разных случаях могут быть различны – главное, чтобы компьютер работал без рывков), клавишей ESC производится выход в главное меню, а кнопкой F10, с последующим нажатием “Y” и ENTER, производится регистрация изменений в SETUP и переход к загрузке компьютера.

Физическая оптимизация файловой структуры.

Нуждается в оптимизации, также, файловая структура. И если оптимизацию режимов энергосбережения достаточно провести один раз, то файловая структура в оптимизации нуждается постоянно.

Как известно, файлы записываются на диск дискретными областями – кластерами. При этом кластер имеет строго определенную величину, и при наличии файла превосходящего размеры кластера, его содержимое распределяется между несколькими кластерами. Кроме того, файлы записываются на диск последовательно, на первое попавшееся свободное место. При пустом диске, они ложатся единой цепочкой, но если тот не был пустым, а из имевшихся на нем файлов некоторые были удалены (например, временные файлы, создаваемые многими программами во время работы и автоматически удаляемые по ее окончании), то, записываясь последовательно, новые файлы заполняют все образовавшиеся пустоты, независимо от того, вмещаются они в эти пустоты целиком, или нет, а в результате, цепочка кластеров принадлежащих одному файлу разрывается на несколько фрагментов.

Образование фрагментов замедляет работу диска, поскольку его содержимое уже читается не подряд, а в определенной последовательности, для соблюдения которой считывающей головке приходится постоянно перескакивать с дорожки на дорожку, да еще и ожидать, пока диск повернется нужной стороной. Устранение фрагментов позволяет увеличить скорость чтения и записи на диск, внося свою лепту в общую оптимизацию компьютера, для чего применяются специальные программы дефрагментации (латинская приставка “де” означает отрицание), одна из которых входит в состав Windows. Они перезаписывают весь диск заново, собирая фрагменты цепочек со всего диска в новой, неразрывной последовательности. Естественно, занятие это довольно долгое и, его самого неплохо было бы оптимизировать.

Одна из самых быстрых программ дефрагментации – Norton Speed Disk, входящая в состав Нортоновских утилит . В состав Windows входит ее усеченная версия, право на которую приобрела, в свое время, корпорация Microsoft .

Логическая оптимизация файловой структуры.

Кроме оптимизации на физическом уровне, достигаемой с помощью дефрагментации, файловую структуру полезно оптимизировать логически. Чем больше каталог содержит файлов и папок, тем дольше в нем производится поиск. Считается, что для нормальной работы компьютера, общее количество адресов в каждом каталоге не должно превышать сотни. Однако, чем меньше, тем лучше. С этой точки зрения полезно:

1. Выбросить вон все лишние файлы Readme (в состав Norton Commander входит даже специальная утилита по их поиску и удалению).

2. Выбросить из каталога Windows, все заведомо никому не нужные файлы фоновых узоров, как то “Колечки”, “Уголки” и тому подобное.

3. Выбросить из папки Windows\System лишние программы-заставки.

4. Освободить диск от захламляющих его пустых каталогов.

5. Не устанавливать программы, которыми никогда не придется пользоваться.

6. Удалить все лишние компоненты Windows.

7. Удалить из каталога Windows или переместить в отдельный каталог все файлы с расширением .Txt и файлы начинающиеся на “Readm”.

8. Установку программ по возможности проводить выборочно, не соглашаясь ни со стандартной установкой (накидающей кучу хлама), ни с минимальной (в которой, при изрядном количестве хлама, будет отсутствовать самое нужное) – никто и никогда не предугадает потребности конкретного пользователя, и пусть программисты даже не пытаются его стандартизировать.

9. При установке программных продуктов группировать их в специальные тематические каталоги, чтобы уменьшить общее число подкаталогов в каталоге Program File (при этом, названия полезно сокращать и, например, вместо “Norton Utilitie”, вместе с другими программами имеющими товарный знак Norton, помещаемую в папку Norton, оставить просто “Utilitie” – тогда искать нужную папку удобно будет даже из MS-DOS).

10. Не устанавливать программы в слишком глубоко эшелонированные папки.

11. До предела сократить количество файлов и папок, находящихся в корневом каталоге каждого диска.

Выполнение перечисленного позволит не только ускорить работу компьютера, но и получить на диске дополнительное количество свободного места (если подобная процедура на компьютере еще не проводилась, то в результате ее проведения, можно высвободить мегабайт 50). А сокращение содержимого корневого каталога, к тому же, облегчит спасательные работы в аварийных ситуациях: в аварийных ситуациях повреждается, прежде всего, корневой каталог, его оглавление становится нечитаемым, либо затирается вообще. Программы типа UnErase способны его восстановить и открыть доступ к содержимому вложенных папок, однако, автоматически восстановленное оглавление будет иметь короткие имена и, чем этих имен окажется меньше, тем меньше, в случае чего, с ними будет возни. Ну а если потребуется вмешательство программы DiskEdit, то и двух имен покажется слишком много.

Оптимизация программного интерфейса.

Немаловажна так же и оптимизация задействованных на компьютере программ.

Некоторые программы, при своей установке, запускают кучу свернутых в значок датчиков, многие из которых являются дублирующими и совершенно не нужными (о чем не редко предупреждают и сами производители, например, в сопровождающем Нортоновские утилиты файле Readme, значится: “Датчики CrashGuard+, Rescue Disk и WinDoctor - общесистемные и не для одного диска. Только один из них должен быть активным в любое время… Датчик описаний вирусов Norton System Doctor использует антивирусные данные Norton Antivirus 2.0. Если у вас Norton Antivirus 4.0, эта программа обеспечивает антивирусную защиту более высокого уровня, чем Norton System Doctor, поэтому рекомендуется удалить датчики “Поиск вирусов” и “Описания вирусов” из Norton System Doctor”). Их свернутость в значок, не означает, что они не занимают место в оперативной памяти и не отнимают часть прерываний процессора . Чем больше на панели задач таких “полезных” датчиков, тем медленнее работает компьютер, а некоторые программы, могут вообще не запустится, потому что, не смотря на достаточное количество установленной в материнскую плату оперативной памяти, свободной памяти для их запуска окажется недостаточно.

Выйти из положения можно, приобретя более мощный компьютер, но с таким отношением к делу, никаких мощностей не хватит: в мире существует сотни тысяч программ и, наверное, миллионы датчиков.

Гораздо эффективней и дешевле, убрать все лишние датчики, оставив только действительно необходимые. Например, датчик планировщика заданий, если планировщик не используется, можно убрать (для этого требуется открыть планировщик и в раскрывающемся списке пункта меню “Дополнительно”, щелкнуть “Остановить планировщик”), из Norton System Doctor можно удалить все датчики, оставив лишь проверку логической структуры системного диска (Disk Doktor C) и целостности системы (WinDoctor), при отсутствии других антивирусных программ имеющих функцию непрерывного наблюдения, полезно оставить Norton Antivirus SE – поиск; датчик обновления антивирусных баз, в любом случае лучше убрать – хозяин компьютера и без всяких датчиков понимает, что раз в месяц, антивирусные базы полезно пополнять. Подобную чистку, желательно провести и в рядах других датчиков. Пусть, избавившись от лишнего груза, компьютер вздохнет полной грудью и покажет, на что он, на самом деле, способен.

Оставшиеся датчики следует настроить на запуск в разное время, чтобы не возникало ударной нагрузки при одновременном включении сразу нескольких.

Оптимизация рабочего стола.

Для нормальной работы компьютера при представлении рабочего стола как Web страницы, рекомендуется наличие не менее 64 мегабайт оперативной памяти. На самом деле, это изрядное преувеличение и, при хорошей отладке, работа компьютера с вдвое меньшей памятью, ни чуть не замедляется. Однако, на случай слишком прожорливых программ, могущих не поделить память со страницей Web, рабочий стол лучше не превращать в полигон для интернета. Выход на серверы и прочие приятности обеспечиваются любым рабочим столом, а то, что обычный рабочий стол не поддерживает использование в качестве фонового рисунка (не надо их путать с захламляющими папку Windows фоновыми узорами), сжатые графические форматы – сущая безделица. Photoshop, Paint Shop Pro и многие другие графические редакторы (а на худой конец – ACDSee Brauser) сохранят копию требуемого рисунка в родном для Windows BMP-формате и при желании, поместят ее прямо в папку Windows, чтобы ее не приходилось где-то искать.

Оптимизация пользовательского интерфейса.

С каким бы быстродействием не работал компьютер, все его старания не редко разбиваются об человеческий фактор: невозможно быстрое выполнение задачи, если управлять процессом неудобно. Между тем, некоторые пользователи создают себе такие трудности в работе с компьютером, что непрерывно находятся в состоянии нервного перенапряжения.

Во первых, стоит разобраться с рабочим столом: зачастую он завален так, что среди собранных на нем значков можно заблудится, при чем, почти каждый из них, еще и продублирован в главном меню. “Где этот проклятый ярлык?” – вопрошает несчастный владелец компьютера, в то время как, ярлык находится у него перед носом. Рабочий стол – это не место сборища подгулявших значков, а такое же рабочее место, как и тот рабочий стол, на котором воодружен компьютер. Необходимость уборки в конце дня реального стола, всем понятна, от чего же непонятна необходимость уборки стола виртуального? Все программы доступны из главного меню, зачем же доступ к ним дублировать на рабочем столе?

Во вторых, не мешало бы разобраться с размерами окна папки: некоторые пользователи любят расстилать по экрану такие простыни в виде развернутых до предела папок, что доступ к другим папкам просто невозможен. Неудивительно, что при таких окнах, они предпочитают пользоваться файловыми посредниками типа Norton Commander со товарищи, предоставляющими возможность раскрывать сразу два окна (с которыми поступают аналогично). Но что им мешает открывать сразу два (или 52) окна Windows? Достаточно сократить их размер до разумных пределов и, пожалуйста – готов Norton Commander собственного производства. Часть файловых операций можно выполнять через буфер обмена или контекстное меню – в этом и заключается главное преимущество Windows; не стоит, имея столь мощную операционную систему, ограничиваться в работе только методами MS-DOS. Но использование буфера обмена удобно только при заранее известном составе обрабатываемых файлов, если же их состав определяется по ходу дела, копирование и перемещение файлов удобно совершать через рабочий стол, используя его как перевалочный пункт для подлежащих дальнейшей обработке файлов. Правда, для этого рабочий стол должен быть свободным от всевозможного мусора, но что мешает отправить этот мусор куда подальше (хотя бы, в корзину)? Беспрепятственный доступ к рабочему столу и возможность передвигать расположенные на нем предметы – вот условие комфорта в работе.

В третьих, порядок жизненно необходим в главном меню. Каждая программа, при инсталляции стремится там, как можно больше нагадить и если не сгребать весь этот помет в кучу, блуждание по лабиринтам меню растянется на всю жизнь. Уже после полугода попустительства, в главном меню накапливаются десятки и сотни самых неожиданных ярлыков, от программ, файлов справки, файлов приветствия производителей, файлов деинсталляции (кто пользуется программным “унинсталом” при наличии утилиты “Установка и удаление программ”, которая удалит не только поднадоевшую программу, но и прилагающийся к ней “унинсталер”, в противном случае, требующий розыска и удаления в ручную?) и тому подобной шушерой. В такой мешанине желание продублировать используемые ярлыки на рабочий стол вполне закономерно, но не полезней ли, выскрести из главного меню все лишнее, а оставшиеся значки распределить по темам: редакторы к редакторам, утилиты к утилитам, при чем, утилиты от Нортона, поместить отдельно, а внутри созданной для них папки, создать еще одну, для тех из них, что не предназначены для систематического использования, чтобы не пестрили. Каждый пользователь сам прекрасно знает, что ему надо, а что нет и, как это расположить – требуется лишь, чтобы он однажды взялся за неведение порядка, и никакое дублирование ярлыков на рабочем столе ему больше не потребуется.

В четвертых, стоит поразмыслить над наглядным представлением файлов: без упорядочивания значков по именам, найти что-либо внутри папки бывает невозможно; отображение крупных значков требует слишком много экранного места; мелкие значки представленные в виде списка слишком неинформативны. Очень удобно представление файлов в виде таблицы – размер, время создания, тип… – все под рукой, да и поиск только в одном направлении – с верху в низ – куда удобней суматошного перескакивания взгляда, неизбежного при обычном расположении файлов. Полоса, находящаяся в верхней части таблицы (заголовок табулятора), позволяет задать оптимальное пространство для каждого отображаемого параметра, а за счет высвободившегося по горизонтали места, удастся сузить папку и открыть вид на рабочий стол. Кроме того, удаление подписей под кнопками и панели ссылок в окне папки, позволяет высвободить немало места (да и вообще, что может действовать более угнетающе, чем огромные кнопки с надписями для умственно-отсталых?), а чтобы полученный интерфейс папки стал стандартом, требуется войти в меню вид\свойства папки\вид и установить “как у текущей папки”.

В пятых, нуждается в оптимизации пункт “Отправить” контекстного меню открываемого правой клавишей мыши. Ярлыки обозначенных там пунктов приема хранятся в папке SendTo вложенной в папку Windows. При помещении туда новых ярлыков, функция “Отправить” обзаведется новыми пунктами приема, и если поместить в SendTo ярлыки логических дисков, при копировании чего-либо с дистрибутивного носителя в корневой каталог, не придется больше открывать этот каталог и перетаскивать туда требуемый объект – достаточно будет щелкнуть правой кнопкой и отправить (в таком случае, для удобства чтения, полезно сменить название ярлыков с “Ярлык для диска С” на “На диск С”).

В шестых, панель задач доступна всегда, даже если какая-то программа блокировала рабочий стол; панель задач доступна прежде всего, даже прежде чем главное меню. Использование ее – эффективнейший способ оптимизации пользовательского интерфейса. Щелчок правой кнопкой мыши по панели задач открывает доступ к пункту “панели инструментов”, где можно отключить лишние панели и создать свою, на основе специально созданной для этой цели папки (например, вложенной в папку “ Мои документы” ). На полученную таким образом панель можно поместить ярлыки логических дисков, чтобы открывать их одним щелчком, даже при блокированном рабочем столе. Туда же, можно поместить копию ярлыка программы-заставки (хранятся в папке Windows\System), чтобы при желании, запускать ее одним щелчком. И кучу всего другого. При этом, в зависимости от количества назначенных кнопок, размер панели, возможно потребуется изменить, ухватив ее за край, а чтобы она не загромождала экран, в свойствах панели указать “автоматически убирать с экрана”. Возможно так же, и перемещение панели в бок, схватив ее за середину. С непривычки такое положение панели наверняка покажется неудобным, но уже на следующий день почувствуются очевидные преимущества проделанных изменений.

Качество монитора определяется не только отношением поддерживаемой частоты обновления к видеорежиму или долговечностью, но и величиной экранного зерна: чем мельче зерно, тем, при прочих равных условиях, четче изображение. Покупка монитора с меньшим зерном – реальный способ увеличить качество изображения элемента.

Для того чтобы Speed Disk из русифицированной версии Norton Utilities 3.0 корректно работал с файловой структурой FAT32, требуется обновление файлов Ndrvex.dll, Numisc.dll, S32fatl.dll, S32guil.dll, S32krnll.dll, S32util.dll, Sd32eng.dll, устанавливаемых в одну папку с самими утилитами. Так же, полезно обновить Ctl3d32.dll из папки C:\Windows\system. Все указанные файлы имеются в англоязычных утилитах 4.0. С русскоязычными утилитами 4.0 лучше не связыватся из-за большого содержания ошибок. Однако, при подобном обновлении Norton Disk Doktor некорректно работает с дискетами и физической поверхностью диска. Чтобы восстановить его работоспособность, следует обновить S32maill.dll, S32nptl.dll, Nddeng.dll и C:\windows\system\S32stat.dll. Данные файлы можно взять из русифицированной версии (в противном случае отчеты будут выдаватся на английском).

Для уменьшения фрагментации, ускорения процесса дефрагментации и общего повышения быстродействия, свап-файл можно перенести в начало диска, задав ему фиксированный размер. Однако, тем, кто настолько плохо знаком с операционной системой, что не знает, как это делается, этим лучше не заниматься (тем не менее, делается это через “Свойства системы\быстродействие\виртуальная память” и соответствующую настройку программы-дефрагментатора). Кроме того, не стоит этим заниматься при большом количестве оперативной памяти (точный размер, зависит от выполняемых задач). Windows может свапить на диск информацию общим обьемом равным двум с половинам объемам оперативной памяти. При задании свап-файла большего размера, часть дискового пространства будет тратится в пустую.

Желающие убедится воочию, могут открыть программу “Сведенья о системе” и найти левом окне “программная среда\Выполняемые задачи”. Например, Датчик Нортон антивируса занимает в памяти пять мегабайт.

Существующая панель быстрого запуска не менее удобна: находящиеся там кнопки поддаются перетаскиванию мышью.

Вместо этого ярлыка можно использовать ярлык программы Saver входящей в комплект Norton Commander 5.0


Оптимизацыя и спасение IBM PC

Красносельский К.К.О том как работать с Windows, С. Симоновичем, Г.Евсеевым и А.Алексеевым написанаочень толковая книга "Общая информатика" и ее незачем копировать. Поэтому здесь собранны только уникальные сведенья об обтимизации и востановлении работоспособности компьютера, многие из которых, как оказалось, неизвестны даже людям професионально занимающимся их сборкой и обслуживанием. И пусть вас не смущает размер брощюры - информация записана в ней так же плотно, как при записи на сжатый диск.

Востановление системы в случае краха и его предотвращение - это очень просто.

Начинаясь с разъяснения абстрактных понятий, книга постепенно переходит к конкретным примерам их практического применения и пошаговым инструкциям, позволяя почувствовать и общую картину и каждую деталь в отдельности. Этому же способствует специально подобранный язык изложения, по лаконичности сопоставимый с языком програмирования. Благодаря такому стилю, огромное количество новой информации, может быть полностью усвоено за считанные дни.


Отказ компьютера от загрузки

Сплошная рябь

Наиболее вероятной причиной того, что после загрузки Windows на экране ничего не возможно разобрать, является установка видеорежима и частоты обновления монитора, не соответствующих возможностям аппаратуры. Если перед данной загрузкой компьютера действительно проводились подобные перенастройки, следует перегрузить компьютер с нажатой клавишей Ctrl и, войдя в меню загрузки, выбрать режим “Safe mode” (третий пункт меню), после чего, открыть свойства экрана и вернуть прежние установки.

Если перенастройка не производилась, то, вероятно, всему виной действие вирусов: они любят совершать подобные трюки с экраном. В таком случае следует загрузиться с защищенной от записи чистой системной дискеты и провести дезинфекцию.

Если применение антивирусных программ не помогло (например, вирусы не обнаружились или, их удаление не восстановило нормальную работу, поскольку видеодрайверы уже были выведены из строя), следует все же перегрузится в режиме “Safe mode”.

Такая перегрузка полезна не только в случае повреждения видеодрайверов, но и в том случае, если, в связи с износом оборудования, используемые ранее режимы, теперь оказались неприемлемыми.

Находясь в режиме “Safe mode”, следует открыть свойства системы в панели управления, чтобы выяснить там сведенья о драйверах видеокарты и монитора (если у последнего они вообще были). Вслед за этим, следует запустить программу “Сведенья о системе” для проверки состава оборудования и программного обеспечения, а затем, используя ее сервис, проверить ошибки Windows и системные файлы.

Дальнейшие действия зависят от полученной информации. Если же из этого ничего толкового не выходит, то:

1. Следует запустить ScanDisk, чтобы убедится в отсутствии ошибок диска.

2. Следует уменьшить частоту обновления и смягчить видеорежим.

3. Сохранив щадящие настройки, следует перегрузиться в нормальный режим и, удалив из списка устройств видеокарту, переустановить заново ее драйвера (кроме того, можно переустановить драйвера монитора).

Если это не помогает – дело плохо. Придется потратить кучу времени на переустановку Windows, для чего, лучше всего подойдет режим “Safe mode command prompt only”. Если не помогает и это – эта проблема на аппаратном уровне и ее решение зависит только от того, насколько она серьезна, насколько она ударит по семейному бюджету и, насколько человек “дружит” с электричеством.

Внутренний конфликт Windows

Если отказ произошел на стадии загрузки графической оболочки Windows (имеющиеся на экране русскоязычные сообщения превращаются в иероглифы, после чего экран полностью очищается ), следует перегрузиться с нажатой клавишей Ctrl и, войдя в меню загрузки, предпринять попытку загрузится с записью протокола в файл BootLog.txt (второй пункт меню). Сама по себе запись протокола не заставит компьютер работать лучше, однако, его просмотр средствами MS-DOS поможет выяснить на каком именно драйвере или программе произошел сбой и, возможно, устранить проблему. Кроме того, существует вероятность, что, со второй попытки, загрузка произойдет нормально – обычно так и происходит, если причиной неполадки были проблемы реестра .

Определяя, вскоре после загрузки, параметры работы как “нормальные”, Windows записывает в системный реестр команды собственной реанимации, которые, в случае чего, проверяют диск на наличие ошибок и восстанавливают зарезервированные в папке C:\Windows\Susbckup данные, при которых работа проходила вполне нормально (на всякий случай, там содержатся копии за последние несколько дней). При выборе в Главном меню пункта “Завершение работы”, Windows первым делом, удостоверяется что, все программы закрыты и не происходит записи на диск (во избежание потерь не сохраненных данных и возникновения дисковых ошибок, грозящих тяжелыми последствиями), удаляет из реестра команды реанимации и, только после этого, выдает сообщение “Теперь питание компьютера можно отключить”.

Если завершение работы Windows произошло в соответствии с этой схемой, при включении компьютера никакая реанимация не происходит. Если же, оборвать работу Windows, не дав ему повозиться с реестром (например, он был перегружен кнопкой “Reset”, после того как завис вследствие изменений внесенных в реестр и системные файлы инсталляцией какой-либо программы), команды реанимации так и остаются неудаленными и, при новом запуске приводятся в исполнение. Так Windows занимается самолечением, восстанавливая логическую структуру диска и реестр в таком состоянии, при котором он нормально работал. При чем, запись команд реанимации происходит на самой ранней стадии загрузки и при зависании компьютера из-за ошибки в реестре, уже одного факта “неправильного” выхода из Windows будет достаточно для его выздоровления.

Но если и со второй попытки Windows не захотел загружаться, значит, виноват не реестр или не только он. В таком случае, следует загрузиться в режиме “Command prompt only” (пятый пункт меню) и посмотреть, что говорится в протоколе. Файл, запротоколированный последним, является наиболее вероятной причиной зависания и, загрузившись в режиме “Step-by-step conformation” (четвертый пункт меню) можно попробовать его обойти, чтобы, добравшись до средств Windows разобраться с ним всерьез (обновить, запретить загрузку или удалить) .

Первая попытка загрузки в “Step-by-step conformation” поможет прояснить ситуацию, но если колдовство с этим режимом даже с нескольких попыток не приводит к положительному результату (в частности, запросы на загрузку DLL-файлов не выдаются и эксперименты с их обходом в пошаговом режиме невозможны), следует загрузиться в режиме защиты от сбоев “Safe mode” и проверить наличие конфликтов в свойствах системы, панели управления.

Если там все в порядке, следует, на всякий случай запустить антивирусный сканер, поскольку завешивание компьютера может происходить и по вине вирусов. Затем следует проверить ошибки Windows с помощью программы WinDoctor из нортоновских утилит (или другой аналогичной), проверить ошибки диска, поковыряться в программе “Информация о системе” и, на худой конец, запретить автозапуск всех программ указанных в программе “Настройка системы” (экспериментируя с автозапуском, вероятно, удастся выяснить, какая именно программа привела компьютер в состояние ступора). Так же, полезной может оказаться информация антивирусных ревизоров – если периодически просматривать их сообщения, начинаешь понимать, изменение каких файлов нормально, а изменение каких, обычно не происходит и может оказаться причиной неверной работы.

Если ничего не помогает или режим защиты от сбоев тоже недоступен, лучше всего загрузится в режиме “Safe mode command prompt only” и переустановить Windows. Те, кто не хочет сдаваться, могут продолжить борьбу, восстанавливая реестр из Cab-файлов, хранящихся в папке C:\Windows\Iosubsys или занимаясь его редактированием с помощью программы RegEdit, но вряд ли этот метод окажется быстрее переустановки.

Недоступность защищенного режима

Если недоступен даже режим “Safe mode”, лучшим способом решения проблемы является переустановка Windows, которую лучше всего производить из защищенного режима для командной строки (Safe mode command prompt only).

Бесполезность переустановки Windows

Если переустановка Windows не привела к желаемому результату, а проверка на вирусы, загружаясь с чистой системной дискеты, еще не производилась, следует ее произвести и дальше действовать по обстоятельствам.

Если с вирусами полный порядок, а все проблемы с Windows начались после установки какой-либо программы, следует удалить эту программу и попробовать загрузиться без нее. А если и это не помогает, переустановить Windows еще раз (удаляясь, программа может напрочь вычистить все необходимые Windows библиотеки).

Если вирусы не обнаружены и, никакие новые программы не устанавливались, переустанавливать Windows еще раз – бессмысленно. Переустанавливаясь, он старается ничего не нарушить (иначе бы, всегда после его переустановки, требовалось бы переустанавливать все работавшие под него программы) и может унаследовать ту самую болезнь, от которой должен был избавить. И, если он унаследовал ее один раз, то унаследует и в другой. Поэтому, в ситуации, когда Windows, избавившись от всех вирусов и страшных программ и переустановившись, все равно не работает, следует…

Надавать ему по заднице.

…следует, загрузившись в Command prompt only (пятый пункт меню) или как-то еще в этом духе, собрать все ценные файлы в единую папку (а лучше их в единой папке и хранить), а остальное удалить. При наличии диска, на который можно было бы эту папку переместить, проще переместить ее на этот диск (одна из причин, по которой полезно деление дисков), а вышедший из строя системный диск отформатировать (форматирование займет в десятки раз меньше времени чем тотальное удаление).

После получения чистого диска придется заново установить операционную систему и программное обеспечение, вплоть до драйверов видеоадаптера и т. п.

Проблемы возникающие где-то внутри Windows, несмотря на кажущуюся пустячность – самые тяжелорешаемые. Поскольку переустановка Windows и прочих программ занимает уйму времени, ее можно пытаться избежать, разыскивая точные причины неполадки, но это все равно что, искать иголку в стоге сена. Поэтому, если на диске нет ничего, что нельзя ни спасти, ни восстановить (а для спасения требуется лишь наличие второго диска), при невозможности восстановить его работоспособность переустановкой Windows, не стоит терять понапрасну время: Format.com – лучший доктор для операционных систем, наследующих болезнь своих предшественников.

Проблемы с Command prompt only

Если компьютер не загружается в режиме Command prompt only, следует загрузиться в Safe mode command prompt only или с дискеты и разобраться с файлами конфигурации MS-DOS, а так же, вызываемыми ими программами и драйверами. Возможно, над файлами конфигурации недобросовестно потрудилась какая-то программа, а возможно, испорчен какой-то загружаемый ими модуль.

Разобраться с модулями можно, загружаясь в пошаговом режиме. Испорченным окажется тот, после выдачи разрешения на загрузку которого, система зависла и, если его нельзя заменить, то его загрузку следует запретить (например, вставив в начало команды по его загрузке, команду REM).

Абсолютный сбой

Если компьютер не загружается с жесткого диска даже в режиме Safe mode command prompt only, то, наверняка повреждено ядро MS-DOS: главная загрузочная запись (Master Boot Sector ), загрузочная запись системного диска (Boot Sector), FAT, корневой каталог, системные файлы Io.sys и MsDos.sys или интерпретатор команд Command.com, находящийся в папке Windows.

В любом из этих случаев, восстановить нормальную работу компьютера можно, загрузившись с дискеты (или CDROM) и отформатировав жесткий диск, возможно, предварительно обработав его программой Fdisk. Но это означает потерю всех имеющихся данных, восстановление которых займет, в последствии, не один день (а ведь на компьютере могут содержаться и какие-то уникальные вещи, точное восстановление которых вообще невозможно), поэтому, столь суровые действия в столь, безобидной, на самом деле, ситуации, вряд ли разумны.

Существует множество способов решить проблему в считанные минуты и без каких-либо потерь.

Автоматическое исправление

Способ первый – проверка на вирусы.

Если компьютер не загружается с жесткого диска даже в режиме Safe mode command prompt only, а проверка на вирусы еще не произведена, следует загрузиться с дискеты или CDROM, но вместо беспощадного уничтожения содержимого диска программами Fdisk и Format, проверить его на наличие вирусов. Возможно, всему виной именно они (а по какой бы еще причине, могли повредиться данные, основная масса которых даже не отображается средствами операционной системы?), и прежде чем восстанавливать работоспособность системы, следует от них избавится.

Попытка восстановления, с игнорированием присутствия вирусов, недопустима. Подобные действия могут привести к новым разрушениям и только усложнят задачу реального выздоровления. Победа, если и будет, то временной, и будет означать она только то, что вирусам дали еще одну возможность нанести удар по содержимому диска и распространится по, еще не зараженным, файлам.

Если на компьютере есть вирусы, антивирусные программы его вылечат . В крайнем случае, они удалят зараженные файлы. Чем больше антивирусных программ поработает над диском, тем больше шанс того что, ни одному вирусу не удастся остаться незамеченным; чем больше антивирусных программ имеется в запасе, тем больше шанс того что, зараженные файлы удастся вылечить, а не просто удалить (для этого, перед лечением, антивирусные программы, по желанию пользователя, создадут резервную копию подлежащих лечению файлов). Поэтому, при диагностике вирусов, в ситуации, когда компьютер напрочь отказывается грузиться с жесткого диска, не стоит ограничиваться какой-то одной, пусть даже, хорошо зарекомендовавшей себя, программой – это было приемлемо только до тех пор, пока и без антивирусов все шло как по маслу.

Излечение компьютера от вирусов приводит к полному восстановлению его работоспособности, поэтому, если на компьютере были обнаружены вирусы, и он был удачно излечен, можно вынимать загрузочную дискету и загружаться обычным порядком.

Если на компьютере были обнаружены вирусы, но вылечить его не удалось, следует удалить зараженные файлы или сохранить с расширением, не обрабатываемым системой как программное и, потому, безопасным (например, Vir, Txt, любое русскоязычное расширение – последнее полезно, чтобы не забыть расширение оригинала, допустим, “КОМ”). Затем, в зависимости от ситуации, следует, либо попытаться загрузиться с жесткого диска, либо, если ядро осталось поврежденным, восстановить его иным способом.

Если, в процессе сканирования, вирусы не обнаружены, значит, повреждение ядра MS-DOS вызвано не ими. Оно могло быть следствием запуска троянской программы (многие из которых, так же отслеживаются антивирусами), некорректным выполнением какой-либо операции или дисковой ошибки (во многом, избежание подобных ошибок обеспечивается включением в Autoexec.bat команды VERIFY ON) и, для восстановления работоспособности требуется запуск ScanDisk или другой программы проверки диска.

Запуск ScanDisk является следующим этапом в борьбе за выживание и полезен даже тогда, когда работоспособность уже восстановлена (но, в таком случае, предпочтительней его Windows-версия).

Способ второй – исправление дисковых ошибок.

Вторая, по степени вероятности, причина поражения ядра MS-DOS – логические ошибки и физические дефекты диска. При физическом дефекте, без его обнаружения, восстанавливать ядро бесполезно: записанное на сбойные кластеры, оно все равно не будет считываться. Поэтому, проверка диска на ошибки, не менее важна, чем проверка на вирусы (только не следует забывать о недопустимости запуска ScanDisk или ему подобных программ, до запуска антивирусов). Дисковые доктора исправят ошибки, пометят сбойные кластеры для предотвращения их записи (если таковые найдутся) и, в случае необходимости, восстановят FAT, используя для этого, ее резервную копию, всегда имеющуюся на диске, зарезервировав, на всякий случай, первую, в файле Undo.

Благодаря восстановлению FAT, запуск диск-докторов может оказаться достаточным для восстановления системы. Если же, компьютер не загружается с жесткого диска и после них, то, либо причина не в повреждении FAT (или в повреждении не только ее), либо повреждены обе их копии (в таком случае, программы проверки диска обычно зависают на стадии проверки структуры каталогов) и, для восстановления работоспособности, придется сначала выяснить, какой именно компонент поврежден.

Поиск неисправности

Восстановление всего сразу, без разбора, недопустимо, поскольку в случае ошибки записи, к тому, что уже было испорчено, можно испортить еще и что-то другое, тем самым, окончательно убить свой компьютер. Поэтому, при дальнейших реанимационных действиях, необходимо точное определение неисправности.

Для поиска неисправности, может оказаться полезной информация антивирусных ревизоров, однако, они не единственный источник информации, да к тому же, могут оказаться недоступны, даже при загрузке с дискеты. Первейшим источником сведений о системе является сама система и, при возникновении каких-либо проблем, исправно о них сообщает (хотя отсутствие сообщений, вовсе не исключено).

Сообщения MS-DOS.

Сообщение:

Type the name of hte Command interpreter (e.g., C:\Windows\Command.com)

соответствует случаю когда система не находит командный интерпретатор ни в корневом каталоге, ни в папке Windows. Возможно он поврежден, переименован или вообще отсутствует. Это же сообщение может быть выдано при отсутствии в корневом каталоге фала MsDos.sys, без которого система не может настроится на нормальную работу с жестким диском.

Сообщение:

Invalid system disk

Соответствует случаю потери или повреждения системных файлов Io.sys и MsDos.sys (при повреждении последнего, на экран может быть выдано и гораздо более объемное сообщение).

Прекращение загрузки сразу после выдачи сообщения:

Verifyng DMI Pool DATA……..

Соответствует повреждению системного загрузчика.

Определение статуса

При отсутствии каких-либо сообщений системы или, недостаточной их ясности, следует прибегнуть к другим источникам и, для начала, загрузившись с дискеты, запустить Fdisk с параметром /Status. По этой команде, Fdisk сообщит о количестве физических дисков, буквах, назначенных разделам и степени их использования (для получения более подробной информации, следует вызвать Fdisk без параметров и выбрать четвертый пункт меню).

Если статус не соответствует ожидаемому, значит, повреждена главная загрузочная запись.

Дополнительные симптомы

Если статус нормальный, но переход на системный логический диск (допустим, командой C:), невозможен, значит, поврежден системный загрузчик активного раздела (этом случае, если следующим, по порядку загрузки, после жесткого диска идет гибкий и, он вставлен в дисковод, система, игнорируя жесткий диск, сразу начинает грузиться с дискеты).

Если, загрузившись с дискеты, на активный раздел жесткого диска можно перейти, но он оказывается совершенно пуст, значит, он либо отформатирован, либо, все его содержимое удалено.

Если на диск можно перейти, но при этом, в корневом каталоге обнаруживается какой-то мусор, значит, поврежден корневой каталог и, если поврежден только он, при попытке загрузится с жесткого диска, загрузчик должен сообщать о несистемном диске или дисковой ошибке (так как ему вряд ли удастся найти системные файлы).

Если на диск можно перейти и войти в любую папку, но при дальнейшей проверке, обнаруживается что, часть текстовых файлов усечено или с чем-то перемешано, часть программ, обязанных нормально работать в MS-DOS, не работают, а часть данных вообще куда-то исчезла, значит, повреждена FAT. Исходя из того что, к моменту ручного поиска, по диску уже должны были пройтись программами типа ScanDisk, и, учитывая, что они ничего не исправили (скорей всего, они вообще зависали), следует вывод что, повреждены обе их копии. В этом случае загрузка продолжается до замечания об отсутствии Command.com, либо прекращается сразу после его считывания.

Если в корневом каталоге и внутри папок полный порядок, а загрузка застыла на “Invalid sistem disk”, значит, повреждены только файлы Io.sys и MsDos.sys (точнее, первый из них).

Если в аналогичной ситуации, система загружается до сообщения “Type the name of hte Command interpreter (e.g., C:\Windows\Command.com)”, значит, поврежден только Command.com, либо в корневом каталоге отсутствует MsDos.sys.

Окончательный диагноз.

При повреждении Command.com, загрузка продолжается до тех пор, пока не подойдет его черед. На этом она останавливается со словами “Type the name of hte Command interpreter (e.g., C:\Windows\Command.com)” и ждет, пока, в появившуюся на экране командную строку, не будет введена команда указывающая на правильный интерпретатор. Остальные команды, хотя и вводятся, исполнению не подлежат.

При отсутствии MsDos.sys система не находит Comand.com даже когда тот, в полной сохранности, находится на самом видном месте; MsDos.sys, при этом, не отображается даже по команде DIR /A /P.

При повреждении Io.sys и MsDos.sys, система выдает какую-нибудь жалобу и застывает. Никакой командной строки не выдается и, нажатие клавиш на состоянии монитора не отражается.

При повреждении FAT, которое может быть причиной неправильного считывания Command.com, поврежденными оказываются многие файлы во вложенных каталогах, а некоторые из них, вообще исчезают. В таких ситуациях, компьютер обычно загружается с жесткого диска до уровня командной строки, хотя может не сделать и этого.

При повреждении корневого каталога его содержимое абсолютно не читаемо.

При повреждении системного загрузчика системного диска, либо система вообще не признает этот диск (при повреждении байта описания носителя), либо загрузка с него прекращается на сообщении “Verifyng DMI Pool DATA……..”, а при попытке обратится к нему, загрузившись с дискеты, компьютер безнадежно зависает.

При повреждении главной загрузочной записи, симптомы сходны с предыдущими, но, в придачу ко всему, Fdisk выдает о диске неправильный статус.

При отформатировании диска, его просмотр показывает, что он абсолютно пуст (но не для UnErase). В этом случае, опять же, при попытке загрузится с жесткого диска, выдается сообщение о том, что он не сделан системным.

Выбор способа исправления.

Восстановление Command.com производится элементарным копированием любой его здоровой версии.

Восстановление системных файлов Io.sys и MsDos.sys производится программой Sys.com, хотя, во многих случаях, может производится и в ручную.

В отличае от создания системной дискеты, при переносе системных файлов с дискеты на диск, програма SYS не создает исклюзивный MsDos.sys, а слепо копирует имеющийся на дискете, и не пригодный для жесткого диска. При загрузке с жесткого диска, такой MsDos.sys игнорируется, загрузка прекращается зразу после исполнения Config.sys и, компьютер просит показать ему командный интерпритатор. Однако, даже после соответствующего указания, он способен работать только в DOS.

Исправить это положение можно либо переустановкой Windows, либо восстановив MsDos.sys из резервной копии, которую следует иметь (например, из хранящегося в корневом каталоге файла MsDos.dos), либо правкой файла в текстовом редакторе. Не следует пытатся устранить это неудобство, заменой файла MSDOS.sys на дискете его версией для жесткого диска, поскольку, загружаясь с такой дискеты и определив параметру загрузки по несвойственному ей MSDOS.sys, система, как ни в чем ни бывало (если не вступит в конфликт с драйверами Config.sys и Autoexec.bat), загрузит Windows.

Восстановление корневого каталога производится в режиме частичного восстановления программы UnFormat при наличии Image-файлов или с помощью программы UnErase.

При применении UnErase, в название файлов придется ввести первую букву. Для того чтобы восстановление было абсолютно корректным, эта буква должна соответствовать той, что была изначально. Учитывая, что содержимое корневого каталога практически неизменно, облегчить эту задачу можно, заранее подготовив список его содержимого (например, командой DIR C:\*.* /A > CATALOG.TXT) и сохранив его в удобном месте (допустим, на дискете). В случае необходимости, перед запуском UnErase, этот файл переписывается на листок и служит эталоном.

Восстановление FAT, в случае, когда дисковые доктора бессильны, осуществляется в два этапа: сначала диск форматируется, а затем восстанавливается, как и после любого другого форматирования. Процедура упрощается при наличаи свежих снимков диска – при их использовании FAT восстанавливается программой UnFormat в режиме частичного восстановления без предварительного форматирования.

Восстановление после форматирования производится программой UnFormat.

Первым делом, программа выдает запрос о наличии снимков программы Image. Эти снимки – палка о двух концах. Они – ничто иное, как копия загрузочной записи (системный загрузчик, корневой каталог, FAT). Восстанавливая диск по снимкам, UnFormat воссоздает его в том состоянии, в каком тот находился в момент их снятия. Файлы измененные, удаленные и, даже просто перемещенные с тех пор, при этом могут перемешаться с новыми и оказаться абсолютно непригодными.

Поэтому, не стоит спешить с полным восстановлением по снимкам.

Если после создания последних снимков производились работы с какими-то ценными данными, не имеющими резервной копии, на вопрос о наличии снимков, в некоторых случаях, лучше ответить “нет”. Программа просканирует диск и создаст новую загрузочную запись в точном соответствии с реальной ситуацией. В таком случае, новые и свежеизмененные файлы могут быть спасены – вероятность этого тем выше, чем меньше был фрагментирован диск в момент разрушения FAT (форматирования) и, чем меньше на нем было удаленных, но не стертых, по настоящему, файлов (поэтому, в настройках, программам-дефрагментаторам, следует указать, чтобы они очищали свободное место, заполняя его нулями ).

В отличие от восстановления по снимкам, после восстановления без них, папки, непосредственно вложенные в корневой каталог, приобретут имена типа Dir0, Dir1, Dir2 … и т. д. Вернуть им прежние имена можно обычным переименованием, ориентируясь по содержимому.

Можно облегчить задачу, заблаговременно вложив в каждую папку, непосредственно вложенную в корневой каталог, файл “DirInfo”, содержащий любую полезную информацию (например, название каталога, записанное в коде ASCII). Одна из панелей оболочек типа Norton Commander может быть информационной (панель состояния). На этой панели отображается всяческая полезная информация (метка тома, количество свободной памяти и т. д.), в том числе, содержимое файла DirInfo. При открытии любой папки, оболочка разыскивает этот файл и, не найдя, сообщает “В этом каталоге нет DirInfo”. Если же DirInfo найден, его содержимое отображается на панели, благодаря чему, об открытом каталоге не приходится гадать на кофейной гуще.

Восстановив диск от форматирования, следует скопировать все ценные файлы на другой, после чего запустить дисковый доктор для исправления перекрестных ссылок на восстановленном диске (файлы имеющие перекрестные ссылки усекаются и, таким образом, могут оказаться полностью разрушены, сохранение копий ценных файлов на втором диске, служит страховкой на случай, если усечены будут именно они). Затем можно запустить UnErase и восстановить то, что оказалось не восстановленным.

Закончив эти процедуры, необходимо запустить Windows и проверить, какая из версий менее повреждена (но ничего больше!). Часть поврежденных копий удастся восстановить программой UnErase под Windows, работать с которой удобней, чем ее MS-DOS-версией, но которой достанется меньше данных, поскольку, передвижками, совершаемыми Windows при запуске, какая-то их часть будет убита (поэтому, что можно, следует восстанавливать еще в MS-DOS). После этого можно определить, какие версии данных выкинуть, а какие оставить.

Если результат восстановления без снимков оказался неудовлетворительным, следует еще раз его отформатировать (главное – не делать на диск записи и ничего в его пределах не перемещать, по всем вопросам обращаясь ко второму диску, на котором, для надежности, можно обновить снимок Image ), а затем провести полное восстановление по снимку, с последующим запуском ScanDisk. В этом случае, UnFormat восстановит загрузочную запись по данным Image, восстановив тем самым, диск, в состоянии, имевшемся на момент ее запуска и… соответственно переведет системный таймер.

Поскольку, с момента снятия снимка, на диске произошли изменения, в восстановленных файлах неизбежны ошибки. После исправления их программой ScanDisk, можно запустить UnErase, для ручной коррекции результата и, сравнить версии данных, спасенных разными методами .

Полное восстановление по снимкам занимает гораздо меньше времени и, если компьютер применяется только для игр и, у его владельца не проснулся дух экспериментаторства, ему следует приступить к нему сразу, а не заниматься самодеятельностью. В крайнем случае, он потеряет последние “сейвы”.

Восстановление системного загрузчика, поскольку он создается однажды, при форматировании диска, и с тех пор остается неизменным, возможно программой UnFormat, в режиме частичного восстановления по снимкам Image.

Если снимков нет, его восстановление возможно последовательным применением Format и UnFormat (последняя, восстановит данные, которые будут уничтожены в процессе форматирования).

Следующий способ, заключается в применении программы Rescue, которая восстановит системный загрузчик по заранее заготовленному ее Windows-версией файлу BootInfo.dat. Важно, чтобы этот файл был подготовлен после последнего форматирования, иначе доступ к данным не восстановится.

Если в системном загрузчике поврежден только блок параметров диска, восстановить его можно программой Sys. Однако следует учитывать возможность подмены файла MSDOS.sys его дискетной версией.

Восстановление главной загрузочной записи (таблицы разделов), производится программой Rescue, по файлу PartInfo.dat.

При отсутствии Patrinfo.dat, можно попытатся восстановить главную загрузочную запись программой Fdisk, вызванной с параметром /MBR. При этом в Master Boot Sector будет записана текущая информация о диске, поэтому, делать это следует только в том случае, если эта информация (выдаваемая Fdisk по четвертому пункту меню) обсолютно корректна.

Данный параметр никогда не документировался, хотя работает Windows 95, Windows 98 в последних версиях MS-DOS.

Помимо того, любое восстановление возможно с помощью низкоуровневых редакторов диска, типа DiskEdit из нортоновских утилит:

Пункт “сектор”, меню “объект”, открывает окно выбора секторов, в котором описано, что и где находится.

Изменения записываются с помощью меню “правка\запись изменений”.

Разрешается запись через меню “средства\настройка” (по умолчанию, только чтение).

В случае недоступности диска, в этом же меню выбирается “расширенный доступ…”.

Параметр /m задаваемый при вызове программы, позволяет на физическом уровне добратся до дисков, к которым DOS не имеет доступа.

Этой программой можно воспользоваться, если другие средства бессильны, но… лучше, если этим займутся системные программисты.

ПИШЕТ ПРОГРАММА ДАЖЕ НА ЗАЩИЩЕННЫЕ ОТ ЗАПИСИ ДИСКЕТЫ – ОПАСНО!

Повреждение CMOS.

Потеря или повреждение данных CMOS является особым случаем отказа компьютера от загрузки, уже хотя бы потому что, его не лечит не один диск-доктор. Эта ситуация вообще непредсказуема и симптомы ее могут быть совершенно различны.

Однако, восстановить данные CMOS не трудно.

1. Перезаписав микросхему ПЗУ в мастерской.

2. Использовав для этого информацию, сохраненную программой Rescue.

В первом случае, помимо необходимости куда-то идти и платить деньги, возникнет так же, необходимость ручной корректировки установок CMOS. Во втором – за минуту, не выходя из квартиры и совершенно бесплатно, данные CMOS будут восстановлены абсолютно в том виде, в каком были сохранены (однака, своя Смоса ближе к телу).

Но прежде чем восстанавливать данные CMOS, требуется устранить причину их разрушения. Наиболее вероятной из них является действие вирусов или выход из строя батарейки питания. Поэтому, перед восстановлением CMOS требуется, загрузившись с дискеты или CDROM (возможно для этого придется перевести BIOS в режим по умолчанию, выбрав “Load BIOS default”, в первом экране процедуры Setup), проверить компьютер на наличие вирусов, а в случае их обнаружения, устранить. Если вирусы не найдены, следует проверить пригодность батарейки, установленной на материнской плате (например, вольтметром) и надежность ее контакта. Батарейка стоит не дорого, а ее замена так же проста как если бы это была батарейка в фонарике, так что, с устранением этой причины, проблем не возникнет.

Другой вероятной причиной нарушения данных CMOS может служить вмешательство ребенка. Ребенка устранять не следует. Его повторную диверсию можно предотвратить, установив пароль на вход в процедуру SETUP (пункт Password Setting или нечто подобное в первой панели).

Устранив причину, можно устранить и следствие. Если программа Rescue имеется на дискете и, там же сохранены подготовленные ее Windows-версией данные (файл CmosInfo.dat), достаточно запустить программу, отметить мышью или пробелом желаемый пункт и щелкнуть на кнопке “OK”, после чего, в появившемся диалоговом окне, подтвердить свои намеренья. После щелчка на кнопке “OK” в окне отчета о результатах (если результат отрицательный, значит, проблема все-таки на аппаратном уровне), можно запустить Setup и полюбоваться картиной Репина “Возвращение блудного Смоса”.

Физически и невосстановимо поврежденная системная область.

Такого рода поломки, как и любые другие стихийные бедствия, будь то землетрясение или всемирный потоп, здесь не обсуждаются, но все же, если DiskEdit сумеет добраться до файловой структуры, спасти можно любую информацию, если нет – в результате длительных поисков, вручную можно спасти текстовые файлы в коде ASCII (ради такой малости, наверное, не стоит и суетиться). А затем, следует провести низкоуровневое форматирование, в надежде, что диск будет приведен в пригодное состояние и, если это случится, обработать его средствами MS-DOS, начиная с Fdisk.

Сообщения о проблемах

Кроме уже перечисленных сообщений, система выдает и некоторые другие, в числе которых:

Battery discharged – разряжена батарея, для запуска компьютера необходимо заменить батарейку на материнской плате и восстановить данные CMOS.

Hardware information lostrun setup – Информация об аппаратуре потеряна в результате сбоя питания или плохого контакта с батареей, следует проверить контакты и восстановить данные CMOS.

Invalid CMOS Checksumrun setup – Информация об аппаратуре повреждена в результате сбоя питания или плохого контакта с батареей, следует проверить контакты и исправить данные CMOS.

Please insert boot-disk and press any key – на данном диске оттутствует загрузочная запись.

Please insert valid boot-disk and press any key – на данном диске повреждены или не найдены файлы ядра

Non-System Disk, please insert boot-disk and press any key – на данном диске не найдены файлы ядра

Non-System Disk or disk error. Replace and press any key when ready – данное сообщение обычно появляется после некорректного удаления раздела с другой операционной системой, в результате которого MBR указывает на несуществующий Boot Sector. Следует убедится в правильности разметки разделов, а при необходимости, указать новый активный раздел и перегрузится. Если же сообщение появляется даже при правильном активном разделе (и информация Fdisk о разделах верна), следует исправить Master Boot Record, запустив Fdisk с параметров /mbr. Если и это не помогает, значит ошибочна не команда перехода, а сам Boot Sector и в востановлении нуждается его системный загрузчик.

Hard disk boot sector invalid – Неисправный загрузочный сектор жесткого диска

Сообщение типа «Не удается найти файл Program, необходимый для нормальной загрузки Windows. Если вы удалили его сознательно, удалите команду по его загрузки из файла System.ini. Нажмите любую клавишу для продолжения загрузки…» – некоторые программы для Windows, используют модули загружаемые через файлы Win.ini и System.ini. Команды по их загрузке не должны содержать пробелов, поскольку слово после пробела считается новым параметром, но иногда программы неправильно записывают пути указавая, например:

C:\Program Files\NewPro\File.exe

В результате чего, Windows будет считать это командой C:\Program. Данную ошибку можно полностью игнорировать, поскольку после нажатия любой клавиши загрузка продолжается обычным порядком. Однако есть три причины для ее устранения:

1. Необходимость нажимать клавишу в конце концов надоедает

2. Функция обеспечиваемая модулем, команда по загрузке которого указана неправильно, не выполняется

3. При попытке обращения к функции, которую должен был обеспечить незагруженный модуль, компьютер может зависнуть

Поэтому, следует открыть указанный файл, найти в нем неверную строку и заменить ее аналогичной строкой в формате DOS, например:

C:\Progra~1\NewPro\File.exe

Аналогичное сообщение (несмотря на то что, оно будет указывать на файл System.ini), может появится при ошибке в разделе Run или RunOnce системного реестра, если там находится ссылка на загрузку несуществующего файла. Если ссылка пемещена в раздел RunOnce (однократный запуск) – обычно при инсталляции программ – после загрузки Windows она удалится автоматически.

Кроме описанного, при всех неполадках Windows, интерактивную помощь можно получить, открыв Главное меню\Справка\Устранение неполадок\Средства устранения неполадок. Хотя описанные там методы могла бы предложить и любая старушка (очевидно, на западе считают, что действенные меры слишком сложны для понимания пользователя).

Кроме того, ошибки Windows полезно проверить программой WinDoctor из нортоновских утилит.

Windows может вступить в конфликт с драйверами и программами MS-DOS загружаемыми через Autoexec.bat и Config.sys, при чем, изменения в них могут произойти без ведома пользователя, так что, их проверка будет не лишней.

Если есть основания полагать, что здесь не обошлось без вирусов, вместо загрузки с BootLog.txt следует, убедится, что в разделе “Standard CMOS Setup”, процедуры SETUP, в строке “Drive A:” отмечено наличие дисковода гибких дисков (если не отмечено – отметить), и загрузится с чистой, защищенной от записи системной дискеты для их поиска. Если подобных оснований нет, поиск вирусов можно пропустить, поскольку причин для зависания Windows хватает и без них.

Без подобных функций, столь сложная система как Windows была бы обречена. Но иногда в нее приходится вмешатся в ручную и, если автоматическое восстановление реестра не помогает, а его коррекцыя програмой RegEdit слишком громоздка, собственоручно запускать программу Scanreg из папки C:\Windows\Command.

Однако может оказаться и так, что причина вовсе не в этом, а как раз таки в том, что какой-то файл, требующийся в дальнейшем для каких-нибудь операций, загрузить не удалось. Поэтому, с содержанием BootLog.txt следует ознакомиться целиком.

Очень кстати, здесь могут прийтись MS-DOS-архиваторы, например, архиватор, встроенный в Norton Commander 5.0

Иногда, вместо “Sector”, можно встретить термин “Record”

SpeedDisk к тому же, автоматически запускает Image, освежая снимки – это необходимо, поскольку дефрагментация полностью меняет расположение файлов.

Шрифт “терминал”

Судя по всему, фокусы с DirInfo придуманы для облегчения ориентации в структуре каталогов, названия которых ограничивались восьмью символами и недостаточно вразумительны.

В зависимости от качества восстановления, система может работать нестабильно и, в случае возникновения ошибок записи, повредить нормальный файл архивного диска, который легко будет восстановить по снимку.

Если Image запускается автоматически, при загрузке компьютера, следует проявить бдительность и не восстановить, случайно, диск по снимку, сделанному после первого форматирования.

Последовательность применения методов, при желании можно изменить.

, А такие программы, как AdInf (если основной модуль доступен при загрузке с дискеты), предоставят, к тому же, кучу полезной информации, главное внимание в которой, следует уделить сообщениям об изменении или удалении компонентов ядра MS-DOS

В утилитах Nuts & Bolts, восстановление по снимкам и без снимков разделено между двумя программами. UnFormat восстанавливает систему без снимков. Восстановлением по снимкам, занимается программа McAfee Image, однако пологатся на нее не стоит: при серьезных повреждениях диска, в отличаи от UnFormat из Нортоновских утилит, она не находит заготовленный для нее снимок (в связи с чем его рекомендуется хранить на дискете что, из-за его размера в несколько мегабайт, не вполне удобно).


Порядок загрузки компьютера.

При включении компьютера, зашитая в ПЗУ программа проверяет конфигурацию технических средств, их готовность и доступность оперативной памяти, после чего предлагает войти в процедуру Setup посредством копки “DEL” – другого случая для входа в Setup не представится до следующей загрузки, поэтому, если кто-то что-то забыл в “сетапе”, ему стоит поторопится.

Если предложение войти в Setup пользователем игнорируется, программа ПЗУ определяет какой дисковод в CMOS указан первоочередным загрузочным и, согласно этому указанию, разыскивает системный загрузчик, обязанный быть на любом отформатированном диске.

При указании первоочередным, жесткого диска, она считывает из его первого физического сектора главную загрузочную запись, по которой определяет конфигурацию логических дисков и обращается к первому сектору логического системного диска, где системный загрузчик обязан находится.

Если системный загрузчик на первоочередном диске не найден, программа ПЗУ не находит и сам диск, и ищет загрузчик на следующих дисках, указанных в CMOS.

Найдя системный загрузчик, программа считывает его в память и, оставляя его там резидентно, передает ему дальнейшее управление процессом загрузки.

Получив управление, системный загрузчик считывает информацию с первого логического сектора, в котором, если это системный (загрузочный диск) должен находится файл Io.sys, а при отсутствии такового, выводит сообщение:

Non system disk or disk error.

Replase and strike ani key when ready.

Означающее что, этот системный диск неверен и предлагающее его смену.

Если файл найден, управление переходит к нему и на экран выводится бодрящее сообщение: “Starting Windows 95” или “Starting MS-DOS ” (или вообще никакого сообщения не появляется, а сразу появляется логотип Windows, в случае загрузки Windows 98 с включенной в Msdos.sys командой вывода логотипа). Затем дается двухсекундная выдержка, втечение которой можно нажать F8 для ручного управления настройки операционной системы через меню загрузки.

Далее, файл Io.sys, настроив параметры системы по данным MSDOS.sys, вызывает из корневого каталога системного диска файл конфигурации Config.sys для выполнения указанных в нем команд, а в случае, если какая-либо команда записана неправильно, либо ее выполнение по каким-то причинам оказалось невозможным, выводит на экран соответствующее англоязычное сообщение, указывая номер ошибочной строки. Но загрузку не прекращает.

Следом за Config.sys из того же каталога считывается файл Command.com являющийся интерпретатором команд MS-DOS (в случае загрузки с жесткого диска, Command.com может считываться не только из корневого каиалога, но и из папки Windows), переводящим человеческие команды, выданные на языке программирования MS-DOS , в понятные компьютеру инструкции машинного кода. Загрузившись в оперативную память, Command.com берет на себя управление и, обнаружив в корневом каталоге файл Autoexec.bat, выполняет записанные в нем команды. Если в какую-то из них вкралась ошибка, на экране появляется сообщение: “Имя команды или файла указано неправильно”, при чем, в русскоязычной версии, это сообщение попытается показать себя русскоязычным и, если драйверы русского языка к этому моменту уже загружены, ему это удастся.

После выполнения команд Autoexec.bat в зависимости от настройки системы возможны варианты: либо загрузка прекратится и на экране появится приглашение MS-DOS , либо произойдет загрузка Win.com (русские буквы временно трансформируются в иероглифы) и появится рабочий стол Windows, либо, не дай Бог, что-нибудь еще…

НЕПРЕДВИДЕННОЕ.

Драйвер Drvspase.bin или Dblspase.bin загружается по указаниям MSDOS.sys в оперативную память автоматически, еще до обработки Config.sys. Их назначение – обеспечить читаемость сжатых дисков. Но поскольку, при сегодняшних размерах дисков, вряд ли имеется смысл их сжимать, а так же, поскольку FAT 32 не поддерживают существующие методы сжатия, а переходить ради возможности сжатия на FAT 16 не имеет смысла (сжатые диски более вместительны, но вместе с тем, более медлительны, так как перед обработкой информации претерпевшей сжатие, она должна еще пройти процедуру распаковки, в то же время FAT 32, за счет, только лишь более экономичного расхода дискового пространства, без всякого сжатия и связанного с ним замедления, экономит на гигабайтном диске, около 80 мегабайт), указанные драйвера только замедляют загрузку и напрасно занимают в оперативной памяти лишнее место (110 килобайт) – что очень существенно при необходимости работы в MS-DOS (иногда, даже отформатировать диск не удается из-за перегруженности оперативной памяти). Чтобы подобного не происходило их лучше удалить, или хотя бы, откорректировав Msdos.sys, отключить их загрузку, если нет уверенности в том, что сжатие диска никогда не будет применено.

Это указание корректируется в процедуре Setup, обычно называемой BIOS при выборе BIOS Features Setup главного меню и System Boot Sequence его подменю.

Этот параметр принят по умолчанию и может вообще не отображаться в MSDOS.sys, но, указав в разделе [options] строку Dblspace=0, можно отключить его загрузку (аналогично и для Drvspace.sys).

При их удалении из корневого каталога, они перестанут переноситься на системные дискеты, избавив, таким образом, от необходимости каждый раз удалять их оттуда.


Предварительные сведенья.

Операционная система – набор программ обеспечивающих взаимодействие оборудования, его драйверов, прикладных программ и человека.

Приложение – прикладная программа (предназначенная для создания и обработки документов).

Аплет – небольшая программа, входящая в состав приложения для расширения его возможностей.

Программный пакет – набор программ, использующий единую базу данных. Объединение программ в пакеты, за счет применения единых данных, сокращает занимаемый ими объем.

Утилита – программа, предназначенная для оптимизации операционной системы.

Драйвер – программа, обеспечивающая взаимодействие оборудования с операционной системой.

Основное различие между WINDOWS и MS-DOS – средства управления памятью. При этом, имеющая более мощный аппарат управления памятью, Windows может сужать свои возможности, имитируя управление памятью системой MS-DOS.

Режим MS-DOS. Некоторые приложения используют прямое обращение к BIOS (иногда иначе и нельзя), оказывающийся недоступным из Windows, берущим все управление на себя, но никогда к нему не обращающимся (его драйвера гораздо совершенней драйверов BIOS). Таким приложениям для своей работы необходим режим MS-DOS.

Полноэкранный режим сеанса MS-DOS необходим приложениям MS-DOS, переводящим работу монитора в графический режим (игры, графические заставки и т. п.).

Ядро MS-DOS является базовым комплектом данных, наличие которых является обязательным условием работы компьютера и включает в себя BIOS, главную загрузочную запись, содержащую таблицу разделов (только для жестких дисков), BOOT-сектор, файлы Io.sys, MsDos.sys и Command.com.

Оболочка – интерпретатор команд, организовывающий диалог между компьютером и пользователем и, обычно, являющийся неотъемлемой частью операционной системы. Классические примеры оболочек – Command.com, Ndos.com и Windows.

Программа-оболочка – программа- посредник (файловый менеджер) устанавливаемый между интерпретатором команд (оболочкой операционной системы) и пользователем, ради более удобного интерфейса. Некоторые оболочки обладают развитым сервисом (Norton Commander), позволяя полностью отказаться от непосредственных услуг операционной системы. Другие, имеют предельно ограниченный набор функций, для расширения которых требуется подключение программ сторонних разработчиков (Volcov Commander). Иногда, оболочками называют программы обслуживания архивов, но до настоящих (универсальных) файловых менеджеров дотягивает, пожалуй, только WinRar и Ace.

Троянская программа – программа, выполняющая совершенно не те действия, какие от нее ожидались или, наряду с ожидаемыми действиями, тайно от пользователя производящая действия причиняющие ему вред. В отличия от вирусов, троянские программы не способны к саморазмножению. Так же, в отличие от вирусов, многие из которых пишутся ради баловства и, стараются не причинить ущерба (если не считать ущербом распространение по всему компьютеру и периодическое прерывание его работы сообщениями типа “Я не причиню вам вреда, я просто хочу сообщить, что Света очень красивая девушка”), троянские программы всегда пишутся для нанесения максимально-возможного ущерба. Некоторые программы, не являющиеся троянскими, могут причинить не меньший ущерб, в силу неправильно выстановленных параметров или неумелого применения, поэтому следует предельно ограничить применение программ, в настройках и назначении которых трудно разобраться.


Представление MS-DOS в цвете

Представление MS-DOS в цвете и другие возможности Ansi.sys.

Задание цвета.

Прежде всего, для представления MS-DOS в цвете требуется посредством соответствующего указания в файле Config.sys, загрузить в оперативную память драйвер Ansi.sys, после чего, с помощью так называемых “эскейп-последовательностей”, можно менять цвет символов и фона.

Главным компонентом эскейп-последовательности является символ ¬ эмитирующий нажатие клавиши ESCAPE. Драйвер Ansi.sys перехватывает все команды, начинающиеся с этого символа, и принимает соответствующие меры.

После символа эскейп, задаются параметры, общего вида [S; … Sm – где m – сообщает драйверу о необходимости изменить цвет, а S – является режимом отображения и может иметь следующие значения:

0 – отменить все ранее заданные режимы и установить режимы по умолчанию (серые буквы на черном фоне).

1 – увеличить яркость.

4 – подчеркнуть символы.

5 – сделать символы мигающими.

8 – отключить вывод (невидимые на черном фоне, черные буквы), что можно применять вместо набора команд:

@Echo off

… > nul

или команды “CTTY NUL”. Однако набор “Echo” – единственный кто предупредит в случае ошибки.

Для задания цвета символов и фона применяется две цифры (двухзначное число), первая из которых (десятки) определяет объект, а вторая (единицы) – его цвет.

Тройка в десятках соответствует символам.

Четверка в десятках соответствует фону.

Сами цвета, кодируются следующим образом:

0 – черный

1 – красный

2 – зеленый

3 – рыжий либо желтый (в зависимости от яркости)

4 – синий

5 – сиреневый

6 – бирюзовый

7 – серебристый (белый)

Например, число 31 означает буквы красного цвета, а команда

¬[1;5;31;40m (или ¬[5;31;1;40m – порядок кодировки значения не имеет) означает: “Выводить изображение в виде мигающих надписей светящихся красным неоновым светом на черном фоне”.

Установленный режим действует от места задания, до места смены новой эскейп-последовательностью. На ранее выведенное изображение действие не распространяется, что снимает все ограничения на комбинирование цвета. Если же, сочетание цветов нежелательно, после задания режима, применяется команда CLS, очищающая экран от прежних изображений.

При задании режима, немаловажным фактом является и то, что сама управляющая последовательность, при активном драйвере Ansi.sys на экран не выводится, а значит и не занимает места, вследствие чего, например, слово “Del”, в надписи “Pres Del to Enter Setup” можно выделить более ярким цветом (или вообще, другим цветом), не нарушая логический строй фразы. Строка:

¬[37;40mPres ¬[1mDel ¬[0;37;40mto Enter Setup – при выводе на экран, будет выглядеть именно так, как выглядит при загрузке компьютера, без всяких [S; …Sm (при чем, параметры 37;40 принимаются MS-DOS по умолчанию и в большинстве случаев их указание не обязательно).

Кроме того, последовательность ¬[J очищает экран, подобно команде CLS.

В задании команды содержащей эскейп-последовательность существует только одна сложность – отсутствие клавиши вводящей знак , однако, для ее ввода существует два простых способа:

1. Ввод управляющего кода посредством команды Prompt. Клавиша Escape, нажатие которой эмитирует символ генерирует код 27. Этот же код, при выводе, генерирует команда Prompt $E. Вследствие чего, управление цветом обеспечивается командой “PROMPT $E[ … $P$G” где $E введет нужный символ, а $P$G восстановит нормальный вид командной строки (теперь уже с новым цветом).

2. Создать и вывести на экран, содержащий требуемую команду, текстовой файл.

Ввести в текстовой файл символ можно, воспользовавшись либо встроенным редактором Volcov Commander, позволяющим вводить управляющие кода непосредственно после нажатия клавиши ALT, либо встроеным редактором Norton Commander, позволяюжим применять ALT для ввода управляющих кодов после нажатия CTRL+Q, либо MS-DOS-редактором Edit.com, входящим в состав Windows и позволяющим применять ALT для этой же цели, после нажатия CTRL+P. В любом из них, при нажатом ALT, на калькуляторной клавиатуре набирается цифра 27, которая после отпускания ALT, модифицируется в .

Выведение на экран текстовой команды осуществляется либо исполнением файла, если он сохранен как .Bat-файл (при этом, перед командой ¬[S … , в одной строке с ней, следует ввести команду ECHO, иначе компьютер сделает замечание, что команда указана не верно), либо командами типа:

Copy 1 con

Tyre 1

More 1

Где 1 является именем файла (для простоты, его можно так и назвать).

Вывод таблиц.

Драйвер Ansi.sys позволяет создавать не только разноцветные надписи, но и всевозможные таблицы. Для этого употребимо либо сочетание различных цветов фона, либо символы псевдографики кода ASCII (шрифта Terminal). Применение псевдографики позволяет создавать таблицы и быз драйверы ANSI, хотя и в монохромном режиме.

Для введения псевдографики имеются два способа:

1. Открыть в программе “Таблица символов” шрифт Terminal и скопировав нужный символ в буфер обмена, вставить его в документ.

2. Второй способ заключается в непосредственном введении кодов данного символа. Поскольку кода псевдографики не являются управляющими, больших трудностей с их вводом не возникает. Однако воспользоваться для этого, придется, опять MS-DOS-редактором и клавишей ALT (но уже без нажатия CTRL+P).

Кодировка псевдографики в коде ASCII поддерживаемом Windows 98:

┌

218

├

195

└

192

╔

201

╠

204

╚

200

│

179

─

196

┬

194

┼

197

┴

193

╦

203

╬

206

╩

202

║

186

═

205

┐

191

┤

180

┘

217

╗

187

╣

185

╝

188

░

176

▒

177

╓

214

╟

199

╙

211

╒

213

╞

198

╘

212

▓

178

█

219

╥

210

╫

215

╨

208

╤

209

╪

216

╧

207

▌

221

▐

222

╖

183

╢

182

╜

189

╕

184

╡

181

╛

190

▀

223

▄

220

Назначение объявлений.

Не менее полезна возможность создания с помощью ANSI.sys стационарных обьявлений (панелей), для чего используются следующие эскейп-последовательности, включаемые в переменную PROMPT:

$E[S - заносит в память текущую позицию курсора

$E[U - возращает курсор в сохраненную в памяти позицию

$E[строка;столбецF - перемещает курсор в указанное положение

$E[K - очищает строку от текущей позиции, заполняя фоновым цветом (прописная "k"очищает до текущей позицыи).

Используя эти команды, удобно выводить на экран короткую справку. Команда:

PROMPT $E[S $E[1;1F $E[0;46;30m $E[K $D $T $H$H$H $E[34mЖми $E[37mF12 $E[34mдля запуска Volcov Commander $E[U $E[40;33m $P$G

написанная в одну строчку, запоминает позицыю курсора ($E[S), переведит его в левый верхний угол ($E[1;1F), определяет будующий цвет ($E[0;46;30m), заполняет этим цветом всю строку ($E[K), сообщает дату и время ($D $T), удаляя секунды и отделяющее их от минут двоеточие ($H$H$H), сменив цвет текста, выводит справку о "горячей" клавише, выделив название клавиши белым цветом ($E[37m), возвращает курсор в запомненную позицыю ($E[U), и со следующей от нее строки, рыжим цветом на черном фоне ($E[40;33m), выводит стандартное системное приглашение ($P$G), перемещающееся по мере заполнения экрана, в то время как, строка объявления жестко закреплена в указаной ей позицыи.

Такую команду удобно помещать в Autoexec.bat.

Определение "горячих" клавиш.

Обрабатываемые драйвером Ansi.sys эскейп-последовательности предоставляют неплохую возможность переназначения клавиш и создания сложных команд, исполняемых по одному нажатию. Учитывая что, все прелести этого драйвера реализуются лишь в DOS, а также, учитывая что, все работающие в DOS, предпочитают общатся с DOS через файловых менеджеров, эта возможность не столь ценна, как возможность управления цветом, но иногда и она может оказатся полезной.

Определяется горячая клавиша (как правило, с помощью команды ECHO), последовательностью вида:

¬[0;код;"команда";13p

где код является кодом опроса назначаемой клавиши или сочетания клавиш, а команда - команда выполняемая по их нажатию (ноль, точки с запятой, кавычки и 13p обязательны).

Коды опроса и ASCII-коды для клавиш и сочетаний представлены в таблицах, для удобства ориентации, разделенных на группы. Двойные значения в одной ячейки указывают на изменение символа при нажатии Shift.

Коды опроса и коды ASCII для цыфр, знаков припинания и спецыальных клавиш.

Символ Key Cap | Код опроса | Shift+Код опроса | Shift+Код ASCII | Ctrl+Код опроса | Ctrl+Код ASCII | Alt+Код опроса | Код ASCII
Esc | 1 | 1 | 27 | 1 | 27 | 1 | 27
1 ! | 2 | 2 | 33 |  |  | 120 | 49
2 @ | 3 | 3 | 64 | 3 | 0 | 121 | 50
3 № | 4 | 4 | 35 |  |  | 122 | 51
4 $ | 5 | 5 | 36 |  |  | 123 | 52
5 % | 5 | 5 | 37 |  |  | 124 | 53
6 ^ | 7 | 7 | 94 | 7 | 30 | 125 | 54
7 & | 8 | 8 | 38 |  |  | 126 | 55
8 * | 9 | 9 | 42 |  |  | 127 | 56
9 ( | 10 | 10 | 40 |  |  | 128 | 57
0 ) | 11 | 11 | 41 |  |  | 129 | 58
- _ | 12 | 2 | 95 | 12 | 31 | 130 | 45
= + | 13 | 13 | 43 |  |  | 131 | 61
Backspace | 14 | 14 | 8 | 14 | 127 | 14 | 8
Tab | 15 | 15 | 0 | 148 | 0 | 165 | 9
Enter | 28 | 28 | 13 | 28 | 10 | 28 | 13
[ { | 26 | 26 | 123 | 26 | 27 | 26 | 91
] } | 27 | 27 | 125 | 27 | 29 | 27 | 93
; : | 39 | 39 | 58 |  |  | 39 | 59
‘ “ | 40 | 40 | 34 |  |  | 40 | 39
~ | 41 | 41 | 126 |  |  | 41 | 96
\ | | 43 | 43 | 124 | 43 | 28 | 43 | 92
, < | 51 | 51 | 60 |  |  | 51 | 44
. > | 52 | 52 | 62 |  |  | 52 | 46
/ ? | 53 | 53 | 63 |  |  | 53 | 47

Кодировка алфавита:

Символ Key Cap | Код опроса | Shift+Код опроса | Shift+Код ASCII | Ctrl+Код опроса | Ctrl+Код ASCII | Alt+Код опроса | Код ASCII
Q | 16 | 16 | 81 | 16 | 17 | 16 | 113
W | 17 | 17 | 87 | 17 | 23 | 17 | 119
E | 18 | 18 | 69 | 18 | 5 | 18 | 101
R | 19 | 19 | 82 | 19 | 18 | 19 | 114
T | 20 | 20 | 84 | 20 | 20 | 20 | 116
Y | 21 | 21 | 89 | 21 | 25 | 21 | 121
U | 22 | 22 | 85 | 22 | 21 | 22 | 117
I | 23 | 23 | 73 | 23 | 9 | 23 | 105
O | 24 | 24 | 79 | 24 | 15 | 24 | 111
P | 25 | 25 | 80 | 25 | 16 | 25 | 112
A | 30 | 30 | 65 | 30 | 1 | 30 | 97
S | 31 | 31 | 83 | 31 | 19 | 31 | 115
D | 32 | 32 | 68 | 32 | 4 | 32 | 100
F | 33 | 33 | 70 | 33 | 6 | 33 | 102
G | 34 | 34 | 71 | 34 | 7 | 34 | 103
H | 35 | 35 | 72 | 35 | 8 | 35 | 104
J | 36 | 36 | 74 | 36 | 10 | 36 | 106
K | 37 | 37 | 75 | 37 | 11 | 37 | 107
L | 38 | 38 | 76 | 38 | 12 | 38 | 108
Z | 44 | 44 | 90 | 44 | 26 | 44 | 122
X | 45 | 45 | 88 | 45 | 24 | 45 | 120
C | 46 | 46 | 67 | 46 | 3 | 46 | 99
V | 47 | 47 | 86 | 47 | 22 | 47 | 118
B | 48 | 48 | 66 | 48 | 2 | 48 | 98
N | 49 | 49 | 78 | 49 | 14 | 49 | 110
M | 50 | 50 | 77 | 50 | 13 | 50 | 109

Коды опроса и коды ASCII для функциональных клавиш

Символ Key Cap | Код опроса | Shift+Код опроса | Shift+Код ASCII | Ctrl+Код опроса | Ctrl+Код ASCII | Alt+Код опроса | Код ASCII
F1 | 59 | 84 | 0 | 94 | 0 | 104 | 0
F2 | 60 | 85 | 0 | 95 | 0 | 105 | 0
F3 | 61 | 86 | 0 | 96 | 0 | 106 | 0
F4 | 62 | 87 | 0 | 97 | 0 | 107 | 0
F5 | 63 | 88 | 0 | 98 | 0 | 108 | 0
F6 | 64 | 89 | 0 | 99 | 0 | 109 | 0
F7 | 65 | 90 | 0 | 100 | 0 | 110 | 0
F8 | 66 | 91 | 0 | 101 | 0 | 111 | 0
F9 | 67 | 92 | 0 | 102 | 0 | 112 | 0
10 | 68 | 93 | 0 | 103 | 0 | 113 | 0
F11 | 133 | 135 | 0 | 137 | 0 | 139 | 0
F12 | 134 | 136 | 0 | 138 | 0 | 140 | 0

Коды опроса и ASCII для клавиш цыфровой клавиатуры при отключеном Num Lock.

Символ Key Cap | Код опроса | Shift+Код опроса | Shift+Код ASCII | Ctrl+Код опроса | Ctrl+Код ASCII | Alt+Код опроса | Код ASCII
* | 55 | 55 | 42 | 150 | 0 | 50 | 42
Home | 71 | 71 | 55 | 119 | 0 |  | 0
Up | 72 | 72 | 56 | 141 | 0 |  | 0
PgUp | 73 | 73 | 57 | 132 | 0 |  | 0
Minus | 74 | 74 | 45 | 142 | 0 | 74 | 45
Left | 75 | 75 | 52 | 115 | 0 |  | 0
5 | 76 | 76 | 53 | 143 | 0 |  | 0
Right | 77 | 77 | 54 | 116 | 0 |  | 0
Plus | 78 | 78 | 43 | 144 | 0 | 78 | 43
End | 79 | 79 | 49 | 117 | 0 |  | 0
Down | 80 | 80 | 50 | 145 | 0 |  | 0
PgDwn | 81 | 81 | 51 | 118 | 0 |  | 0
Ins | 82 | 82 | 48 | 146 | 0 |  | 0
Del | 83 | 83 | 46 | 147 | 0 |  | 0
/ | 224 | 224 | 47 | 149 | 0 | 164 | 47
Enter | 224 | 224 | 13 | 224 | 10 | 166 | 13

Коды опроса и ASCII для клавиш находящихся между цыфровой и основной клавиатурой.

Символ Key Cap | Код опроса | Shift+Код опроса | Shift+Код ASCII | Ctrl+Код опроса | Ctrl+Код ASCII | Alt+Код опроса | Код ASCII
Home | 71 | 71 | 224 | 119 | 224 | 151 | 224
Up | 72 | 72 | 224 | 141 | 224 | 152 | 224
PgUp | 73 | 73 | 224 | 132 | 224 | 153 | 224
Left | 75 | 75 | 224 | 115 | 224 | 155 | 224
Right | 77 | 77 | 224 | 116 | 224 | 157 | 224
End | 79 | 79 | 224 | 117 | 224 | 159 | 224
Down | 80 | 80 | 224 | 145 | 224 | 160 | 224
PgDown | 81 | 81 | 224 | 118 | 224 | 161 | 224
Insert | 82 | 82 | 224 | 146 | 224 | 162 | 224
Del | 83 | 83 | 224 | 147 | 224 | 163 | 224

Макрокоманды редактора командной строки.

Возможность назначения команд, подобную "горячим" клавишам Ansi.sys предоставляет, так же входящий в комплект поставки Windows, редактор командной строки DosKey. И хотя он не может назначать макрос функцыанальным клавишам, а после набора макроса, всегда требуется нажимать Enter, DosKey имеет перед Ansi.sys некоторые преимущества.

1. Позволяет создавать команды длинной в две строки.

2. Позволят включать в команду шаблоны (* и ?), переменные и заменяемые параметры, аналогичные заменяемым параметрам bat-файлов.

3. Позволяет объединять команды в одну строку (потому они и называются макросами - макрокомандами).

4. Хоть и на простейшем уровне, но все же, проверяет условия выполнения команд, без чего создание макросов не имело бы смысла.

5. Как и с любой правильно написанной програмой, работать с ним удобней чем с драйвером.

Назначается макрокоманда вызовом DosKey с параметром МАКРОС=КОМАНДА где МАКРОС - имя создаваемого или заменяемого макроса, а команда - закрепляемая за ним команда.

$T используется в макросах DosKey в качестве резделителя команд

$1 - $9 в качестве заменяемых параметров

$* глобальный заменяемый параметр, при исполнении заменяющийся всей строкой идущей за именем макроса

Таким образом, простейший макрос

DosKey pkz=pkzip $* $T if exist $1* copy $1* A:

заменяет команду pkz на pkzip, вставляет все введенные после нее параметры (выполняет архивацию), при необходимости добавляет расширение (звездочка после $1) и, убедившись что, архив действительно создан (ведь могло быть и так, что указанных к архивации файлов не оказалось в заданном каталоге), делает его резервную копию на дискете. Применен этот макрос, может быть, например, командой

Pkz D:\Arhiv\Январь -Prex C:\Моидок~1\*.doc

Ее расшифровка даст следующие результаты:

Pkzip D:\Arhiv\Январь.zip -Prex C:\Моидок~1\*.doc

If exist D:\Arhiv\Январь.zip copy D:\Arhiv\Январь.zip A:

Если процедура, назначаемая в макросе вполне стандартна, то в него можно перенести большее количество аргументов командной строки, и тогда, для ее выполнения, достаточно будет ввести только одно слово. Но, если уж назначать макросы и "горячие" клавиши, то делать это следует в NDOS. Макрокоманды NDOS (называемые синонимами - ALIAS) работают даже внутри файловых менеджеров и по своим возможностям не уступают Bat-файлам. И это при том, что он сам управляет цветом, редактирует командную строку и выполняет еще десятки функцый, иными средствами невыполнимых.

Способности NDOS в отношении макрокоманд демонстрирует следующий пример: Если после загрузки через Autoexec.bat команды (в одну строку)

alias del `iff isdir %1 then^inkey Это каталог. Удалить (Y/N)? %%YES^iff %YES%==Y then^*del /y /X /S /Z %1^endiff^else Inkey Обработать вложеные каталоги (Y/N)? %%KAT^iff %KAT%==Y then^*del /y /x /s /z %&^else *del /y /z %&^endiff^endiff`

ввести команду "DEL имя", NDOS проверит чем является удаляемый обьект и, если это каталог, выдаст запрос на его удаление (и удалит, по нажатию "Y"), а если нет, спросит, обрабатявать ли вложенные кталоги. При положительном ответе, файлы соответствующие указаному имени (именам) или шаблону, будут удалены из текущего и всех вложеных каталогов, не взирая ни на какие атрибуты, а при обнаружении пустых каталогов, будут удалятся и они. Таким образом, командой

DEL С:\*.exe *.com *.bat

можно легко (но только после подтверждения этого решения), уничтожить все програмы на диске С. Обычное удаление, при этом, будет проводится командой *DEL (со звездочкой) либо командой DEL, но с ответом "N" на запрос об обработке вложенных каталогов (на самом деле, достаточно нажать любую клавишу, кроме "Y").

ноль включен на случай, возращения экрану желаемых атрибутов, если какая-то программа их изменит


РАБОТА В MS-DOS

Чистый DOS и режим MS-DOS

При работе в MS-DOS, прежде всего, необходимо знать что:

1. MS-DOS воспринимает только 8 символов имени и 3 символа расширения, а встречающийся в имени пробел игнорируется и, если в названии объекта имеется более восьми символов, воспроизводит только первые шесть, дополняя их тильдой и порядковым номером (заменяя тем самым, седьмой и восьмой символы). При этом порядковый номер определяется положением объекта на диске (обычно первые те, что созданы раньше). Таким образом, последовательно созданные папки “Мои документы”, “Мои программы” и “Мои проигрыватели” в Windows будут отражаться как “Мои документы”, “Мои проигрыватели” и “Мои программы”. А в MS-DOS как “ МОИДОК~1 ”, “МОИПРО~1” и “МОИПРО~2” где, несмотря на алфавитное первенство, “Мои проигрыватели” будут отображаться как “Моипро~2”.

2. имена файлов и папок в командной строке MS-DOS разделяются косой чертой (\).

3. Обработке подлежат только те файлы, адрес которых указан в командной строке.

4. для запуска приложений MS-DOS без перехода в содержащий их каталог, вслед за приглашением, оканчивающимся знаком >, требуется набрать полный путь к ним от начала диска, например, D:\NC\nc. Если же часть требуемого пути уже выведена в командной строке (то есть, если пользователь находится на пол пути к искомому файлу), повторный ввод указанной части необязателен.

5. Команды, выполняемые MS-DOS, делятся на два типа: внутренние и внешние. При этом внутренние входят в набор команд предусмотренных командным процессором Command.com и, являясь неотъемлемой частью MS-DOS, не требуют для своего исполнения каких-либо дополнительных программ, а внешние, являются названиями дополнительных программ, отчасти поставляемых вместе с операционной системой, отчасти приобретаемых со стороны, вызывая эти программы для выполнения тех или иных операций. Для выполнения внешних команд, необходимо наличие соответствующих программ и указание операционной системе пути к ним. В остальном, их выполнение аналогично выполнению внутренних.

6. Некоторые команды исполняются без указания пути к программам их обслуживающим. К таким командам относятся, команды перемещения, копирования и переименования файлов, а так же другие внутренние команды (исполняемые командным процессором). Их, и некоторые программы, в частности, путь и привязка которых указана в автозагружаемом файле Autoexec.bat, (строка указания начинается со слова PATH) вызываются указанием только имени.

7. Файлы, имеющие расширение .exe, .bat и .com являются автоматически исполняемыми файлами (программами); введение их имен в командную строку воспринимается как команда запуска и, указание расширения, в таком случае, необязательно (но не при копировании и ей подобных операциях, иначе обработке подвергались бы все папки и файлы, различающиеся только расширением).

8. при работе в MS-DOS, первым всегда указывается имя программы предназначенной для выполнения операции или команда её выполнения (что, с пользовательской точки зрения, одно и то же), а через пробел указывается адрес, имя и расширение обрабатываемого файла. Например, для редактирования файла Autoexec.bat вызывается программа Edit (редактор); чтобы преступить к редактированию сразу после её открытия, в командную строку вводят: “Edit C:\Autoexec.bat”.

9. При нахождении в папке расположения требуемого файла, указание адреса излишне (в таком случае, указанная выше операция выглядит так: Edit Autoexec.bat): если адрес требуемого файла не указан, система интерпретирует это как указание на текущую папку.

10. При переименовании (Rename), после исходного имени и расширения, через пробел ставятся новые. При чём, больше восьми букв имени и трёх букв расширения, задавать нельзя.

11. При копировании и перемещении, кроме команды выполнения операции (Copy – копировать, Move – переместить), адреса и имени файла, с его расширением, задаются конечные адрес и имя с расширением. Например: copy c:\autoexec.bat d:\autoexec.bat. Но, находясь в папке получателя, излишне задавать конечное имя и адрес, с расширением.

12. Для обработки скрытых и системных файлов, обычно требуется снятие данного атрибута.

13. Нажатие клавиши F3 вызывает предыдущую команду.

14. Редактирование командной строки осуществляется с помощью курсорных клавиш: сдвинув курсор влево и, исправив нужный символ, его возвращают в прежнее положение, восстанавливая все последующие символы. Если команда не вмещается в строку, ее перенос на следующую обеспечивает нажатие CTRL+ENTER.

15. Для того чтобы узнать назначение и параметры команд или программ MS-DOS, их вызывают с параметром /?. Например, “Copy /?”. Однако данный способ не применим к драйверам и командам, применяемым в файле Config.sys.

16. Русская раскладка клавиатуры в MS-DOS включается сочетанием Ctrl с правым Shift, а английская - Ctrl с левым Shift

17. Кнопка F1 вызывает контекстную справку в приложениях имеющих графический интерфейс.

18. Кнопка Insert, при применении многих программ, включает режим вставки

19. Сочетания клавиш CTRL+C или CTRL+BREAK прекращает выполнение многих команд

20. Кнопка Escape обеспечивает выход из большинства приложений.

Некоторые команды MS-DOS:

Attrib внешняя команда просмотра, снятия или установки атрибутов.

Dir просмотр каталога. Заданная без пути, покажет текущий каталог, а при указании пути к другому каталогу, позволяет просмотреть указанный каталог, оставаясь в прежнем.

Dir/p его постраничный просмотр

dir/a просмотр всех файлов, в том числе системных и скрытых

Dir диск:\файл /s /a поиск указаного файла на указаном диске (удобно добавлять параметр /b)

cd переход в иной каталог (например, cd C:\mydocs\book\pc)

cd.. переход уровнем выше

cd\ переход к корневому каталогу

a: переход на диск А

d: переход на диск D

copy копировать

del удалить (для удаления большого числа файлов удобно применять Del *.* /p где параметр /p включен для выдачи запроса перед удалением каждого файла).

move переместить

rename переименовать (ren)

md создать новую папку (с обязательным указанием её имени)

RD удаление пустого каталога

DelTree (внешняя) удаление всей указанной ветви (удаление не пустого каталога).

Type просмотр небольших текстов

more (внешняя) постраничный просмотр любых файлов, прекращающийся при нажатии Ctrl+C

Copy con … ввод текста в … файл, непосредственно с экрана, заканчивается клавишей F6 с последующим нажатием ENTER.

HELP – помощь (если таковая предусмотрена)

Win - (внешняя, требующая наличия операционной системы Windows) команда, применяемая для загрузки Windows без перезапуска компьютера при работе в режиме командной строки.

Exit - аналогичная ей команда возвращения к Windows без перезагрузки, применяемая для выхода из режима MS-DOS только при его эмуляции.

Подстановочные символы, применяемые в именах файлов:

? любой символ, или его отсутствие

* любое число любых символов

*.* все файлы данного каталога

В частности, команда DEL *.bak означает удаление всех файлов с расширением BAK из текущего каталога.

Дополнительные возможности сеанса MS-DOS:

Помимо команды Exit с последующим введением Enter (как и в режиме MS-DOS), позволяющей выйти из сеанса MS-DOS, сохранив внесённые изменения; в сеансе MS-DOS употребима комбинация клавиш ALT+ENTER для сворачивания полноэкранного режима в оконный, удобная для временного выхода.

В MS-DOS, для удобства ориентации, каталоги обычно отображаются заглавными буквами.


Разрешение проблем режима MS-DOS.

Качество эмуляции Dos зависит, прежде всего, от настройки его ярлыка, и если ярлык к программе Windows является только указателем пути к файлу, то ярлык к программе MS-DOS, на самом деле является файлом настройки этой программы, имеющим соответствующие расширение и свойства. Даже перезагрузка в DOS посредством ГЛАВНОГО МЕНЮ и команды “Завершение работы”, происходит через обращение системы к ярлыку “Выход в DOS”, находящемуся внутри папки Windows. По этому, если с DOS произошли какие-либо неприятности, то все претензии необходимо предъявлять именно к ярлыку. Теоретически можно предположить, что возникающие проблемы связаны с порчей системных файлов и файлов конфигурации, но испортить их можно только умышленно, в то время как, для порчи ярлыка DOS достаточно невнимательности или неумения в обращении с ним. Открыв ярлык, для ознакомления с текущей конфигурацией DOS, можно закрыть его и спокойно продолжать работу, не подозревая о том, что при следующем запуске, компьютер откажется загружать Windows, а вместо русифицированного DOS выдаст некие арабские символы, понять смысл которых совершенно невозможно.

Эмуляция MS-DOS основана на передаче управления от оболочки Windows интерпретатору команд MS-DOS. При этом вместе с ним задействуются определённые драйверы и резидентные программы. Если во вкладке “дополнительно” ярлыка программы MS-DOS указано использование текущих параметров MS-DOS, то задействованными оказываются драйвера и программы указанные в файлах Config.sys и Autoexec.bat, содержащиеся в корневом каталоге системного диска (содержащего основной раздел MS-DOS). Эти программы загружаются при первоначальной загрузке компьютера и находятся в оперативной памяти постоянно, вследствие чего для выхода в режим MS-DOS компьютер не перезагружается (отгружается только Windows) и практически сразу после сообщения об окончании работы Windows, выдаёт командную строку, примерно такого содержания:

C:\Windows>

Которая, в зависимости от имен и расположения каталогов, на каждом конкретном компьютере может отличаться. После набора “exit” в этой строке и нажатия кнопки Enter , с дисплея выдаётся сообщение о загрузке Windows, что (если при работе в MS-DOS не инсталлировались резидентные программы) вскоре и происходит, без перезапуска .

Если во вкладке “Дополнительно” указано “выбрать новую конфигурацию”, происходит полная перезагрузка, во время которой обычные Autoexec.bat и Config.sys, получая расширение WOS, временно заменяются новыми, указывающими на загрузку других программ и драйверов, со всеми вытекающими отсюда последствиями. При чем, локализованные (адаптированные под применение в той или иной стране) версии Windows не способны верно определить необходимый набор требуемых программ и, если свойства эмуляции MS-DOS небыли откорректированы вручную, в подавляющем большинстве случаев (например, в случае обычной эмуляции, выдающей черный экран и командную строку), работа на компьютере становится невозможной из-за отсутствия поддержки национальных языков, приводящей к тому что, попытка программ вести диалог на подобающем языке превращается в полную тарабарщину. Приглашение MS-DOS в этой ситуации выглядит как чёрный юмор “Оставь надежду всяк сюда входящий”, поскольку, не разобравшись в чём дело, покинуть этот лабиринт не удастся даже с помощью перезагрузки компьютера: использованье все тех же, неправильных файлов конфигурации каждый раз будет возвращать к одной и той же командной строке – Windows окажется недоступным.

Перезагрузка в режим MS-DOS с новыми параметрами выглядит как загрузка в режиме COMMAND PROMT ONLY, но естественное для COMMAND PROMT ONLY желание перейти к Windows через команду “Win” не приводит к должному результату и вместо комфортного рабочего стола на экране появляются две иероглифические строчки, последнее из которых заканчивается знаком вопроса. Различить в этих сообщениях можно только Windows и ESC, но означают они следующее:

“В настоящий момент запущен режим эмуляции MS-DOS

Возвратится в обычный режим работы Windows [ввод=да, Esc=нет]?”

Зная истинное содержание этих строк, легко сделать правильный выбор. Так же, его легко сделать, если не забывать, что, не смотря на сходство с перезагрузкой в режиме COMMAND PROMPT ONLY, это все-таки только эмуляция MS-DOS и выход из неё всегда возможен через команду Exit: перезагрузка Windows произойдёт без всяких дополнительных вопросов, загрузчик Windows (Win.com) вновь возьмет управление на себя, а заодно, вернет стандартным Autoexec и Config нормальное расширение, позволяя загрузится указанным в них драйверам и программам.

Работать в режиме MS-DOS не удобно без какого-нибудь файлового посредника (программы-оболочки), поэтому вызов файлового посредника стоит поместить в Autoexec.bat ярлыка этого режима. В таком случае, туда стоит поместить и вызов драйвера мыши. Тогда, с переходом в MS-DOS оболочка установится автоматически. А если нужно, чтобы выход из оболочки автоматически приводил к выходу из MS-DOS и загрузке Windows, последней строчкой Autoexec.bat (вслед за вызовом оболочки) следует сделать:

ECHO Y | C:\WINDOWS\WIN > NUL

Эту же задачу можно решить по другому – сохранив в папке Windows ярлык этого файлового посредника под названием “Выход в DOS” и откорректировав его свойства, в том числе, установив опцию “закрывать окно по завершении работы” или, указав уже существующему ярлыку “Выход в DOS”, в качестве командной строки, строку указывающую не на Command.com, а на выбранный файловый посредник.

Другая проблема MS-DOS состоит в том что, когда человека поджимает время, разница между полноэкранным режимом сеанса MS-DOS и просто режимом MS-DOS (его полной эмуляцией) останется без внимания. Некоторые ярлыки MS-DOS могут иметь установку “Автоматически предлагать переход в режим MS-DOS”, и если согласится с ними, не учитывая этой разницы и не сохраняя открытые документы, все свежие данные, на создание которых не хватало времени, теперь будут потеряны вообще.

В связи с высокой скоростью перезагрузки, этот режим удобен для замены системных файлов.


Резервное копирование.

Не смотря на множество способов восстановления данных, лучшим способом их защиты является резервное копирование. В нем тоже, способов не счесть.

Во первых, его можно выполнять либо вручную, либо с помощью специальных программ. Применение специальных программ облегчает процесс.

Во вторых, его можно выполнять со сжатием, либо без. Сжатие позволяет экономить место.

В третьих, копировать можно либо целиком, весь диск, либо выборочно. Выборочное копирование экономит не только место, но и время.

Для выборочного копирования могут применяться различные программы:

Программы поиска различных файловых менеджеров (в том числе, программа поиска входящая в состав Windows), позволяют найти все файлы желаемого типа, после чего, требуемые из них, можно выделить и скопировать. Однако использование подобного резерва окажется крайне неудобным, поскольку в нем не сохранится информация об исходном расположении файлов.

Сохранить информацию об исходном расположении, позволяет копирование непосредственно из программ-архиваторов: необходимо дать команду “добавить в архив” (или “создать архив”) и в появившемся окне выбора файлов для архивации, ввести требуемый шаблон. Если требуется, следует отметить опцию “включая вложенные папки” и (в зависимости от особенностей программы), отдельно указать, что выбор происходит по шаблону.

Однако, архивация по шаблону не всегда удобна. Иногда более удобен выбор конкретных объектов, и, если они находятся в одном каталоге, он может производиться как в архиваторе, так и в обычном файловом менеджере, например, Explorer (с последующим выбором пункта архивации из контекстного меню). Проблемы возникают только тогда, когда желаемые файлы находятся в разных папках. Из множества существующих программ для резервного копирования, архивацию файлов сразу из нескольких каталогов, не вложенных друг в друга, поддерживают только единицы, в остальных же, процедуру архивации приходиться выполнять в несколько (десятков) приемов, постоянно добавляя файлы к созданному архиву, от чего не трудно и запутаться.

Одной из немногих программ, позволяющих одним приемом заархивовать файлы из нескольких независимых источников (возможно, в графическом варианте, таких программ всего две), является программа Backup, входящая в состав Windows. У нее есть три существенных недостатка:

1. Она задает слишком много вопросов.

2. Она недостаточно сильно сжимает.

3. С созданными ею архивами не может работать не одна другая программа.

Этих недостатков лишена программа PkZip fo Windows, бесплатно распространяемая корпорацией PkWare. Имеются у нее и другие преимущества. Если программа ZipMagic творит волшебство с архивами, то программа PkZip творит волшебство с самим процессом их создания.

После запуска программы, процесс создания архива сводится к следующему:

Команда “New” (Create a new .zip file) из меню “File”, открывает окно выбора имени и размещения архива, затем открывается окно выбора, подлежащих копированию, объектов.

Для того чтобы выбрать папку, а не просто открыть, после ее выделения нажимается кнопка “Add Directory”, а чтобы вложенные папки так же попали в архив, в настройках (Preferences) данного окна, должно быть указано “включить вложенные папки” (Include subdirectories). Этот параметр стоит сохранить по умолчанию (Save as default) – такое включение требуется в большинстве случаев.

Добавление файла аналогично – только нажимается кнопка “Add files”. Для множества файлов можно использовать выделение протягиванием мыши (гораздо удобней, чем многократные щелчки для установки флажков в программе Backup) или шаблон, введя его в списке “Filter” и нажав кнопку “Add filter” – подобной команды Backup не поддерживает. Так же, по фильтру файлы можно исключить (кнопка “Exclude Filter”), но можно исключить и конкретные файлы (кнопка “Manual Add”).

Отметив требуемое в одном источнике, можно перейти к другому и всего несколькими командами создать задание всеобщей архивации на любой вкус. Затем нажимается кнопка “Ok” и по окончании сжатия, “Done” – архив готов. Для его обновления, в случае необходимости, в окне выбора, появляющегося по команде “Add files”, достаточно установить переключатель “Add options” в положение “Update files” – программа сама проверит, какие файлы из содержащихся в архиве, после архивации были изменены и обновит о них данные -- но столь простую операцию выполнит и любая другая программа, работающая с форматом Zip.

Единственным недостатком PkZip (версии 2.60) является его отсутствие в контекстном меню Explorer. Поэтому, для обычного сжатия, с целью более компактного умещения файлов подлежащих перемещению на другой компьютер (например, на дискете), целесообразней применять другую программу.

Наиболее подходит для этой цели WinRar, уже хотя бы потому что, в режиме непрерывного архива в формате Rar, обеспечивает более высокое сжатие, чем любой Zip. Кроме того, WinRar удобен благодаря своей простоте. По сути, это не архиватор, а одно-панельный файловый менеджер, типа окна “Мой компьютер”, с несколько ограниченным контекстным меню (многие менеджеры вообще без него обходятся). Он и архивы представляет в виде вложенных друг в друга папок. Иногда это кажется наглядным, но одним взглядом оценить содержимое архива невозможно. Зачастую, более целесообразным представляется классическое отображение архива в виде полного списка находящихся в нем файлов.

Выбирать файлы по шаблону он не может (для этого существует специальная консольная версия) и в этом уступает практически всем остальным архиваторам, из которых наиболее интересны следующие три:

ZipMagic – входящая в его состав утилита ZipTools является не только отличным тактическим архиватором (если считать программы резервного копирования архиваторами стратегическими), но и не менее отличным одно или двухпанельным файловым менеджером, перенастраиваемым по желанию пользователя и полностью поддерживающим контекстное меню. Если Zip-архивы ассоциируются с ZipMagic, ZipTools отображает их в любом виде: в противном случае, только в классическом (в виде списка). Но если уж пользоваться ZipMagic, то, скорее, в “магическом” режиме, кроме всего прочего, в нем увеличивается скорость доступа к архиву, поскольку программа висит в памяти резидентно.

Compressed Folders – компонент MS Plus 98 предназначенный для новичков, боящихся запутаться в параметрах сжатия. После его установки в команде “отправить”, контекстного меню, появляется пункт “Compressed Folders”, при выборе которого, в текущей директории, под именем первого из выделенных файлов, появляется готовый архив. Никаких дополнительных параметров – дешево и сердито.

WinZip – отличается непревзойденной красотой и наглядностью. Небывалое число (десять) вариантов сортировки, особое выделение файлов Read.me и Setup.exe (для удобства их поиска)... Учитывая возможность полной перенастройки интерфейса, открывать архивы хочется именно в нем. Особенно, учитывая, что он понимает русские имена в кодировке большинства архиваторов, в то время как другие (кроме WinRar – тот вообще вездеход) к этому слишком чувствительны.

PkZip fo DOS 32-битная версия 2.50 – полезен тем, что работает в любой операционной системе и, поддерживая длинные имена Windows, позволяет автоматизировать процесс обновления архивов (консольная версия WinRar тоже допускает автоматизацию, но при незначительном преимуществе по степени сжатия, значительно уступает в скорости).

Как и любая другая консольная программа, PkZip не распознает введенные в командную строку имена, состоящие из нескольких слов (содержащие пробелы), считая новое слово именем источника и, в командной строке, их приходится задавать в формате DOS, теряя исходное имя. Но для решения этой проблемы существует два способа:

1) Заключение длинных имен в кавычки.

2) Архивация по списку. Каждая строка такого списка представляет отдельный файл или шаблон и, путаницы с его считыванием не происходит.

Подключается список командой вида: PkZip параметры архив @список.

Команда:

PkZip параметры архив -@список источники

генерирует список файлов, которые были бы помещены в архив из указанных источников, при данных параметрах.

Автоматизация процесса резервного копирования существенно повышает уровень общей оптимизации работы компьютера и защиты информации от повреждения, но поднять ее на должный уровень невозможно без специальных средств. Одним из таких средств является Ndos.com из Нортоновских утилит для DOS, а его сочетание с 32-битным PkZip для DOS, дает наилучший результат. Приведенный ниже пакетный файл является тому наглядным примером.

@echo off

if exist C:\dos\arhiv.log goto NONEW

echo %_date > C:\dos\Arhiv.log

C:\dos\pkzip -Pr -! -Wsh C:\Моидок~1\Новый.zip @C:\dos\список.txt -x@C:\dos\лишнее.txt

if errorlevel 1 pause Проблемы с созданием Нового зипа

C:\progra~1\arhiv\winrar\rar a -mm -sfx -ep1 -zC:\моидок~1\энциклопедия\1.txt C:\Моидок~1\Энциклопедия.exe C:\моидок~1\Энциклопедия\*.*

if errorlevel 1 pause Проблемы с созданием Энциклопедии.

Quit

:NONEW

if %_date==%@line[C:\dos\arhiv.log,0] quit

echo %_date > C:\dos\arhiv.log

C:\dos\pkzip -ur -! -Wsh C:\Моидок~1\Новый.zip @C:\dos\список.txt -x@C:\dos\лишнее.txt

if errorlevel 1 pause Проблемы с обновлением Нового зипа

C:\progra~1\arhiv\winrar\rar u -ep1 -mm C:\Моидок~1\Энциклопедия.exe C:\моидок~1\Энциклопедия\*.*

if errorlevel 1 pause Проблемы с обновлением Энциклопедии.

IF NOT %_DOW==Tue QUIT

if not exist D:\Новый.zip goto NOEX1

if %@filedate[D:\Новый.zip]==%@filedate[C:\моидок~1\Новый.zip] goto NOOLD1

if exist D:\Старый.zip del D:\Старый.zip

ren D:\Новый.zip D:\Старый.zip

:NOEX1

copy C:\Моидок~1\Новый.zip D:\

:NOOLD1

if not exist D:\Энцикл~1.exe goto NOEX2

if %@filedate[D:\Энцикл~1.exe]==%@filedate[C:\моидок~1\Энцикл~1.exe] goto NOOLD2

if exist D:\Старая.exe del D:\Старая.exe

ren D:\Энцикл~1.exe D:\Старая.exe

:NOEX2

copy C:\Моидок~1\Энцикл~1.exe D:\

:NOOLD2

Первый блок данного файла проверяет наличие отчета, в котором фиксируется дата последнего выполнения работы, а если таковой отсутствует, создает этот отчет, фиксируя текущую дату. Второй блок создает архивы, если отчет не найден (а значит, архивация еще не проводилась), и проверяет качество их создания, приостанавливая работу и выводя сообщение, в случае проблем. Затем завершает работу. Третий блок проверяет записанную в отчет дату. Если работа в данный день уже выполнялась, или же, проводилась впервые, дальнейшее выполнение файла прекращается, чтобы не тратить время на лишнее резервирование, если нет, зафиксированная в отчете дата обновляется и приводится в исполнение следующий блок, в котором производится обновление архивов и проверка их качества.

Пятый блок проверяет день недели и если он не совпадает с назначенным для генеральной резервации, завершает работу файла. В противном случае выполняется шестой блок, первой строкой проверяющий наличие копии архива на другом диске, второй строкой, проверяющий, обновлялся ли оригинал после создания копии, и третей строкой, проверяющий, существует ли старая версия этой копии.

Наличие двух копий архива очень существенно. Если в архив каким-то образом попадает поврежденный файл, (это можно предотвратить удерживанием Shift при загрузке Windows), восстановить его можно из архива обновляемого раз в неделю. А если попадание в архив поврежденного файла произошло как раз в день обновления запасного архива и, таким образом, в редко обновляемом архиве оказалась та же самая, поврежденная версия, восстановить файл можно из старой версии запасного архива, которой в этот день исполняется ровно неделя (или сколько-то еще, поскольку при желании, генеральную резервацию можно проводить чаще или реже чем раз в неделю).

Седьмой блок проводит генеральную резервацию следующего архива.

Однажды определив подобное задание и поместив в меню автозапуска ярлык с командной строкой:

C:\dos\ndos.com /c C:\Dos\New.bat

где

C:\dos\ndos.com является полным путем и именем для Ndos.com

/C - параметр вызова

C:\Dos\New.bat - полный путь и имя описанного пакетного файла

можно никогда больше не вспоминать о резервных копиях (если, конечно, резервирование не производится на сменные носители, менять которые придется в ручную), до тех пор, пока они не потребуются для восстановления поврежденных файлов .

Учитывая что, при некоторых незначительных затруднениях Rar генерирует код возврата равный единице, при обновлении Rar-архива (но не при создании), исходные файлы которого могут не изменится за сутки, протекшие с момента предыдущей архивации, следует проверять Errorlevel не ниже двух, иначе бат-файл начнет трубить о проблемах, даже когда архив не нуждается в обновлении (код завершения Rar, в этом случае, равен единице). PkZip в таком случае генерирует 12, поэтому, если реально возможна ситуация, чтобы не один из архивируемых файлов не изменился в течение суток, убедившись в корректности работы бат-файла (любая грамматическая ошибка может развалить весь механизм), следует изменить строку проверки обновления Zip-архива и вместо

if errorlevel 1 pause Проблемы с обновлением Нового зипа

вставить

if errorlevel 1 .AND. errorlevel NE 12 pause Проблемы с обновлением Нового зипа

Команда понимается буквально: "Если код возврата не менее единицы (отношение "не менее" для Ndos принято по умолчанию) и, при этом, не 12, поднимай тревогу".

Данное отступление снижает уровень сигнализации, но, при безошибочной записи команд, вряд ли более чем на сотую долю процента.

Если ежедневное выполнение задания крайне необходимо, то для продолжения его выполнения даже после принудительного прерывания (например, вследствие отключения напряжения), команду записи протокола (строку "echo %_date > C:\dos\Arhiv.log") следует переместить так, чтобы она находилась только в конце файла и перед командами QUIT. Строка IF NOT %_DOW==Tue QUIT при этом примет вид:

IF NOT %_DOW==Tue (echo %_date > C:\dos\Arhiv.log^QUIT)

В этом случае, дата будет обновляться только после полного выполнения задания.

NDOS передает программам любые имена файлов, в виде параметров запуска, однако, сам умеет работать только с короткими, поэтому, когда он обрабатывает их сам, ему необходимо указывать имена в формате DOS. Если же нужно сохранить длинное имя (это возможно только из-под Windows), то для копирования и переименования следует вызвать Command.com с параметром /C, например:

Command /c copy C:\Моидок~1\Энцикл~1.exe D:\

Для большего удобства, в свойствах ярлыка можно указать, чтобы программа сворачивалась в значок при запуске и сама закрывалась при завершении работы, а для того чтобы вовремя отреагировать на возникающие проблемы, в первый блок файла можно добавить строку:

Alias pause beep 349 11 233 11 349 11 233 11 349 11 233 11 349 11 233 11^*pause %&

Для уменьшения вводимых в командную строку параметров сжатия, при работе с PkZip (как и для Rar), предусмотрено изменение параметров, принимаемых по умолчанию, с помощью файла конфигурации PkWare.ini, имеющего следующий вид:

[PKZIP]

PATHS=ALL

INCLUDE=HIDEN/SYSTEM

VIEW=BRIEF/NAME/MORE

COMPRESS=EXTREME

RECURSE=ON

[PKUNZIP]

DIRECTORIES=ENABLED

VIEW=BRIEF/NAME/MORE

Где первый блок определяет параметры сжатия (сохранять все пути, включать в архив скрытые и системные файлы, при просмотре выдавать содержимое кратко, сортируя по именам, приостанавливаясь при заполнении экрана), а второй, параметры распаковки. Подробности составления этого файла приводятся в файле Manual.txt, поставляемом вместе с программой.

Для корректной работы PkWare.ini, в файле Autoexec.bat следует определить переменную PkWare.ini, указывающую на каталог, его содержащий. Например, SET PKWARE.INI=C:\PKWARE.

При резервном копировании, с применением Zip-архиваторов, автоматическая активизация ZipMagic в "магический" режиме, не желательна. Ее следует запретить, открыв свойства (Properties) ZipMagic и, на вкладке "Settings", установить флажок на опции "Start disabled". После выполнения копирования, ее можно разрешить заново, при чем, прямо из пакетного файла, где вместо команды Quit применить переход на метку в конец файла, после которой, ввести команду Start /w ZmCmdln.exe /e+ (предварив ее путем к папке ZipMagic).

Пример из жизни.

Ниже предлагается реальное задание архивации tps-файлов (базы данных) с сервера на локальный диск с последующим снятием «имиджа» этого диска.

: Данный способ (использующий архивный атрибут) создает не три архива

: (как прежний), а шесть.

: Поэтому, если большинство архивируемых файлов ежедневно изменяется,

: он требует больше места для всей совокупности создаваемых архивов.

: Однако если ежедневно обновляется только их небольшая часть,

: дает заметную экономию дискового пространства.

: Требуется эксперимент, для выбора оптимального метода.

: Очевидным преимуществом данного способа является наличие не только

: вчерашней копии и копии недельной давности,

: но и копий за каждый рабочий день в течение всей недели.

@echo off

alias pause `beep 349 11 233 11 349 11 233 11 349 11 233 11 349 11 233 11^*pause %&`

if exist D:\archiv\archiv.log goto NONEW

pkzip -a+ -pr -Wsh D:\archiv\Главный.zip W:\*.tps

if errorlevel 1 pause Проблемы с созданием Главного зипа.

echo %_date > D:\archiv\archiv.log

C:\Progra~1\Norton\Utilit~1\IMAGE32 D: /OUT

Quit

:NONEW

if %_date==%@line[D:\archiv\archiv.log,0] quit

IFF NOT %_DOW==Пт. then

if exist D:\archiv\%_DOW%zip del D:\archiv\%_DOW%zip

pkzip -ipr -Wsh D:\archiv\%_dow%zip W:\*.tps

if errorlevel 1 .and. errorlevel ne 12 pause Проблемы с созданием %_dow%zip

else

copy /u D:\archiv\Главный.zip D:\archiv\Запасной.zip

pkzip -ur -Wsh D:\archiv\Главный.zip W:\*.tps

if errorlevel 1 .and. errorlevel ne 12 pause Проблемы с обновлением Главного зипа

If «%WinDir» != «» setdos /i-attrib

attrib -A W:\*.tps /s

endiff

echo %_date > D:\archiv\archiv.log

C:\Progra~1\Norton\Utilit~1\IMAGE32 D: /OUT

Далее приведен усовершенствованный вариант этой же программы, в который добавлены команды по защите самого процесса создания резервных копий, возможности автоматического возврата его в исходное состояние и автоматического доархивирования файлов блокированных другими программами. Так же добавлены переменные, позволяющие легко адаптировать ее под любые потребности: изменение пяти переменных собранных в начале программы избавляет от необходимости искать и исправлять команды по всему ее тексту.

@echo off

SetLocal

: Переменная DIRECTORY указывает каталог для архивов и

: должна заканчиваться слешем (\)

set DIRECTORY=

: Переменная DIRECTCD так же указывает каталог для архивов и должна

: заканчиваться слешем (\), но вместо указания пути каждого файла,

: служит для назначения рабочего каталога, экономя память

: (аналогично папке назначаемой в ярлыке программы).

: Эти переменные взаимозаменяемы.

Set DIRECTCD=D:\archiv\

: Переменная DISK указывает букву диска с файлами данных (требуется

: для возможности восстановления атрибутов), и должна содержать двоеточие

set DISK=W:

: Переменная DATA содержит указание на архивируемые данные

set DATA=W:\*.tps

: Переменная DEY содержит день создания главного архива в том виде, в котором

: он возвращается по команде ECHO %_DOW

set DEY=Пт.

: Переменная WARNING содержит сообщение о том, что файл не попал в архив

: (для данной версии PkZip это «PKZIP: (W02) Warning! can't open:»)

set WARNING=PKZIP: (W02) Warning! can't open:

: Перечисленные переменные можно заменить параметрами типа %1

: и вводить при вызове файла

alias pause `beep 349 11 233 11 349 11 233 11 349 11 233 11 349 11 233 11^*pause %&`

alias Inkey `beep 349 11 233 11 349 11 233 11 349 11 233 11 349 11 233 11^*inkey %&`

if "%DIRECTCD" != "" (cdd %DIRECTCD^unset DIRECTCD)

if exist %DIRECTORY%archiv.log goto NONEW

scrput 5 25 Green on %_BG А Н А Л И З Д А Н Н Ы Х

pkzip -a+ -pr -Wsh %DIRECTORY%Главный.zip %DATA | tee %DIRECTORY%arhiv.txt

If errorlevel==18 GoSub ReArc

iff errorlevel 1 then

pause Проблемы с созданием Главного зипа, жми пробел.

list %DIRECTORY%arhiv.txt

cls

*inkey /K"YN" Продолжить выполнение (Y/N) ? %%Var

If "%Var"=="N" Quit

else

del %DIRECTORY%arhiv.txt > nul

endiff

echo %_date > %DIRECTORY%archiv.log

Quit

:NONEW

if %_date==%@line[%DIRECTORY%archiv.log,0] quit

IFF NOT "%_DOW"=="%DEY" then

iff exist %DIRECTORY%%_DOW%zip then

ren %DIRECTORY%%_DOW%zip %_DOW%bak > nul

iff "%_?" != "0" then

inkey /K"YN" Проблемы с созданием %_DOW%bak, возможно нет места. продолжить (Y/N) ? %%Var

If "%Var"=="N" Quit

endiff

endiff

pkzip -ipr -Wsh %DIRECTORY%%_dow%zip %DATA | tee %DIRECTORY%arhiv.txt

If errorlevel==18 GoSub ReArc

iff errorlevel 1 .and. errorlevel ne 12 then

pause Проблемы с созданием %_dow%zip, жми пробел.

list %DIRECTORY%arhiv.txt

:UNDO

(echo Безоговорочный выход

echo Вернуть в исходное состояние

echo Цивилизованное завершение) | (set Var=%@select[con,3,20,20,55,ДАЛЬНЕЙШИЕ ДЕЙСТВИЯ])

If "%Var%"=="" (Beep^goto /i UNDO)

If "%Var%"=="Безоговорочный выход" Quit

Iff "%Var%"=="Цивилизованное завершение" Then

unset Var

find /i "%WARNING" %directory%arhiv.txt > %directory%NoArc.txt

unset cmdline

: Удаление подстроки "PKZIP: (W02) Warning! can't open:"

: Поиск начинается со строки 2 поскольку строки 0 и 1,

: выдаваемые программой Find никому не нужны

set NUM=2

set FILE=%%@Line[%DIRECTORY%NoArc.txt,%%num]

iff "%file"=="**EOF**" then

del %DIRECTORY%NoArc.txt > nul

else

cls

beep

*inkey /K"YN" Создать список файлов не попавших в архив (Y/N) ? %%Var

if "%Var"=="Y" GoSub NOARC

list %directory%NoArc.txt

beep

*inkey /K"YN" Сохранить его в файле %directory%NoArc.txt (Y/N) ? %%Var

if "%Var"=="N" del %directory%NoArc.txt > nul

endiff

Beep

*inkey /K"YN" Сохранить сообщения архиватора (Arhiv.txt) и BAK-файл (Y/N) ? %%Var

If "%Var%"=="N" Del %DIRECTORY%%_DOW%bak Arhiv.txt > nul

endiff

Iff "%Var%"=="Вернуть в исходное состояние" then

: Освободим память

unset WARNING

unset var

if not exist %DIRECTORY%%_DOW%zip GoTo /i END

PkUnzip -d %DIRECTORY%%_DOW%zip -@%DIRECTORY%Arhiv.txt

unset cmdline

set NUM=0

set FILE=%@Line[%DIRECTORY%Arhiv.txt,%num]

iff "%file"=="**EOF**" then

echo Не удалось прочесть файл списка - "Arhiv.txt" или он пуст.

del %DIRECTORY%Arhiv.txt > nul

beep

*pause

goto /i SKIP

endiff

If «%WinDir» != «» setdos /i-attrib

:ATTRIBUT

: ________________________________________________________________

:CIKL Этот фрагмент только для PkUnZip (замена знака / на знак \)

set POZ=%@index[%file,/]

IFF "%POZ%" != "-1" then

set File1=%FILE1%%@substr[%file,0,%poz]\

set File=%@substr[%file,%@Eval[%poz+1]]

if "%@index[%file,/]" != "-1" GoTo /i CIKL

set File=%File1%%file

unset file1

endiff

: ________________________________________________________________

attrib +A "%Disk%\%File"

: Освобождение памяти

unset cmdline

set NUM=%@Eval[%num+1]

set FILE=%@Line[%DIRECTORY%Arhiv.txt,%num]

if not "%File"=="**EOF**" goto /i ATTRIBUT

:SKIP

Del %DIRECTORY%%_DOW%zip > nul

:end

if exist %DIRECTORY%%_DOW%bak Ren %DIRECTORY%%_DOW%bak %_DOW%zip > nul

del %DIRECTORY%arhiv.txt > nul

Quit

endiff

else

if exist %DIRECTORY%%_DOW%bak del %DIRECTORY%%_DOW%bak > nul

del %DIRECTORY%arhiv.txt > nul

endiff

Else

iff "%@filedate[%DIRECTORY%Главный.zip]" != "%@filedate[%DIRECTORY%Запасной.zip]" then

copy %DIRECTORY%Главный.zip Запасной.zip > nul

Iff "%_?" != "0" then

inkey /K"YN" Проблемы с копированием Главного архива, возможно нет места. продолжить (Y/N) ? %%Var

If "%Var"=="N" Quit

endiff

endiff

pkzip -ur -Wsh %DIRECTORY%Главный.zip %DATA | tee %DIRECTORY%arhiv.txt

If errorlevel==18 GoSub ReArc

Iff errorlevel 1 .and. errorlevel ne 12 then

pause Проблемы с обновлением Главного зипа, жми пробел.

list %DIRECTORY%arhiv.txt

:UNDO2

(echo Безоговорочный выход

echo Вернуть в исходное состояние

echo Цивилизованное завершение) | (set Var=%@select[con,3,20,20,55,ДАЛЬНЕЙШИЕ ДЕЙСТВИЯ])

If "%Var%"=="" (Beep^goto /i UNDO2)

If "%Var%"=="Безоговорочный выход" Quit

Iff "%Var%"=="Цивилизованное завершение" Then

unset Var

find /i "%WARNING" %directory%arhiv.txt > %directory%NoArc.txt

unset cmdline

: Удаление подстроки "PKZIP: (W02) Warning! can't open:"

: Поиск начинается со строки 2 поскольку строки 0 и 1,

: выдаваемые программой Find никому не нужны

set NUM=2

set FILE=%%@Line[%DIRECTORY%NoArc.txt,%%num]

iff "%file"=="**EOF**" then

del %DIRECTORY%NoArc.txt > nul

else

cls

beep

*inkey /K"YN" Создать список файлов не попавших в архив (Y/N) ? %%Var

if "%Var"=="Y" GoSub NOARC

list %directory%NoArc.txt

beep

*inkey /K"YN" Сохранить его в файле %directory%NoArc.txt (Y/N) ? %%Var

if "%Var"=="N" del %directory%NoArc.txt > nul

endiff

Beep

*inkey /K"YN" Сохранить сообщения архиватора (Arhiv.txt)? (Y/N) %%Var

If "%Var%"=="N" Del %DIRECTORY%Arhiv.txt > nul

endiff

Iff "%Var%"=="Вернуть в исходное состояние" then

unset var

copy %directory%Запасной.zip Главный.zip > nul

Del %DIRECTORY%Arhiv.txt > nul

QUIT

endiff

else

del %DIRECTORY%arhiv.txt > nul

If «%WinDir» != «» setdos /i-attrib

attrib -A "%Disk%\%DATA" /s

endiff

endiff

echo %_date > %DIRECTORY%archiv.log

quit

:NOARC - Определение незаархивированных файлов.

: Начала процедуры (начиная со строк UNSET VAR и FIND), находится в основной

: программе, поскольку остальная часть вызывается только при

: положительном ответе на содержащийся в первой части запрос – программа

: удлиняется, становится более запутанной, но выполняется быстрее

: (Возможно это не верный подход).

echo %@substr[%file,%@len[%WARNING]] >> %DIRECTORY%NoArc.tmp

set NUM=%@Eval[%num+1]

if not "%File"=="**EOF**" goto NOARC

del %directory%NoArc.txt > nul

set NUM=0

set FILE=%@Line[%DIRECTORY%NoArc.tmp,%num]

iff "%file"=="**EOF**" then

beep

echo Не удалось прочесть временный файл списка - "NoArc.tmp" или он пуст.

*pause^del %DIRECTORY%NoArc.tmp > nul

RETURN

endiff

:ReWRITE

: ________________________________________________________________

:CIKL1 Этот фрагмент только для PkUnZip (замена знака / на знак \)

set POZ=%@index[%file,/]

IFF "%POZ%" != "-1" then

set File1=%FILE1%%@substr[%file,0,%poz]\

set File=%@substr[%file,%@Eval[%poz+1]]

if "%@index[%file,/]" != "-1" GoTo CIKL1

set File=%File1%%file

unset file1

endiff

: ________________________________________________________________

echo %File >> NoArc.txt

set NUM=%@Eval[%num+1]

set FILE=%@Line[%DIRECTORY%NoArc.tmp,%num]

if not "%File"=="**EOF**" goto ReWRITE

del %directory%NoArc.tmp > nul

RETURN

:ReArc

echo Некоторые файлы небыли заархивированы.

beep

set Var=N

echo Отобразить их список? (Y/N)

*inkey /W10 Жду десять секунд и продолжаю без списка. %%Var

iff "%var" != "N" then

unset Var

find /i "%WARNING" %directory%arhiv.txt > %directory%NoArc.txt

unset cmdline

: Удаление подстроки "PKZIP: (W02) Warning! can't open:"

: Поиск начинается со строки 2 поскольку строки 0 и 1,

: выдаваемые программой Find никому не нужны

set NUM=2

set FILE=%%@Line[%DIRECTORY%NoArc.txt,%%num]

iff "%file"=="**EOF**" then

del %DIRECTORY%NoArc.txt > nul

beep

echo Ошибка при создании списка файлов непопавших в архив

*pause

else

GoSub NOARC

list %directory%NoArc.txt

beep

*inkey /K"YN" Сохранить его в файле %directory%NoArc.txt (Y/N) ? %%Var

if "%Var"=="N" del %directory%NoArc.txt > nul

endiff

EndIff

set Var=Y

echo Попытатся добавить их к архиву? (Y/N)

*inkey /W300 Жду пять минут и пытаюсь сам. %%Var

iff "%var"=="Y" then

find /i "%WARNING" %directory%arhiv.txt > %directory%NoArc.txt

unset cmdline

: Удаление подстроки "PKZIP: (W02) Warning! can't open:"

: Поиск начинается со строки 2 поскольку строки 0 и 1,

: выдаваемые программой Find никому не нужны

set NUM=2

set FILE=%%@Line[%DIRECTORY%NoArc.txt,%%num]

iff "%file"=="**EOF**" then

del %DIRECTORY%NoArc.txt > nul

beep

echo Ошибка при создании списка файлов непопавших в архив

*pause

else

GoSub NoArc

pkzip -a+ -pr -Wsh %DIRECTORY%%_dow%zip @%DIRECTORY%NoArc.txt | tee %DIRECTORY%arhiv.txt

: Крутим динамо либо пока не добьемся положительного результата,

: либо пока не остановит пользователь

if errorlevel==18 GoTo ReArc

del %DIRECTORY%NoArc.txt > nul

EndIff

EndIff

RETURN

Применение переменных в указанной программе повышает ее гибкость, однако, при их большой величине может привести к ошибкам из-за недостатка памяти в окружении. И, хотя расход памяти окружения программой жестко лимитируется (команды unset удаляют даже переменную CmdLine), назначаемую NDOS по умолчанию величину окружения (512 байт), лучше увеличить параметром /E:1024 в команде вызова или параметром Environment=1024 в файле NDOS.ini.

Это одна строка

В виду конфликта русской кодировки ASCII и ANSI, командная строка (а стало быть, и адреса с именами) не должны содержать русских символов.

В виду неспособности консольной версии WinRar работать в DOS, при отсутствии Rar для DOS, следует избегать резервации системных файлов в этом формате - если что-то случится с Windows, извлечь их оттуда, будет нечем.


Русификация MS-DOS

При запуске, локализованная версия Windows автоматически устанавливает динамические драйвера обеспечивающие работу с символами кириллицы, однако, многим утилитам, для их правильной работы этого недостаточно, поэтому, русификация MS-DOS (установка русифицирующих драйверов реального режима) требуется, не зависимо от того, предполагается работа в нем или нет.

Русификация производится в несколько этапов, следующих друг за другом в определенной очередности, хотя, некоторое ее изменение все же допускается.

Устанавливаемый в Config.sys строкой:

device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)

драйвер Display.sys обеспечивает возможность вывода на экран символов кириллицы.

Устанавливаемый в Config.sys строкой:

Country=007,866,C:\WINDOWS\COMMAND\country.sys

Драйвер Country.sys, обеспечивает возможность работы с файлами и папками имеющими русские имена, и работу с русским форматом дат.

Устанавливаемый в Autoexec.bat строкой:

mode con codepage prepare=((866) C:\WINDOWS\COMMAND\ega3.cpi)

файл Ega3.cpi содержит переведенный в машинный код русифицированный экранный шрифт (кодовую страницу), необходимый для драйвера Display.sys и тем самым, подготавливает возможность перехода на его отображение.

Устанавливаемый в Autoexec.bat строкой:

mode con codepage select=866

код страны приводит систему к переводу на режим отображения подготовленный драйвером Display.sys и шрифтом Ega3.cpi.

Устанавливаемая в Autoexec.bat строкой:

keyb ru,,C:\WINDOWS\COMMAND\keybrd3.sys

команда настройки клавиатуры, ссылаясь на адаптированный для использования русского шрифта файл ее описания Keybrd3.sys, обеспечивает возможность переключения раскладки клавиатуры с помощью клавиш CTRL+SHIFT (русская раскладка запускается Ctrl с правым Shifh, английская – с левым).


Системный реестр.

Системный реестр является универсальной базой данных обеспечивающей взаимодействие всех установленных на компьютере программ и состоящей из двух файлов – User.dat и System.dat – находящихся в папке Windows.

Первый из файлов реестра, как видно уже из названия (данные пользователя), содержит настройки зарегистрированных на компьютере пользователей. При чем, если компьютер настроен на многопользовательский режим, каждому пользователю назначается собственный User.dat, хранящейся в соответствующей папке C:\Windows\Profiles\ИМЯ. При выборе пользователя, этот User.dat копируется в папку Windows, заменяя, находившийся там ранее и, тем самым, определяя конфигурацию текущего сеанса.

Второй файл (системные настройки), содержит универсальные данные, присущие всей системе и независящие от выбора пользователя.

Для ускорения обработки, файлы реестра записаны в двоичном коде, вследствие чего, просмотр и коррекция реестра возможна только с помощью специальных программ. Например, с помощью редактора реестра RegEdit, входящего в состав операционной системы.

Если коррекция реестра специальным редактором неудобна, определенный раздел (или весь реестр), через меню редактора “Файл\Экспорт” можно экспортировать в Reg-файл для обработки в обычном текстовом редакторе, а затем импортировать обратно (например, двойным щелчком по файлу). Такое редактирование позволяет изменить имеющиеся данные, но не удалить их, поскольку Reg-файл только лишь добавляется к реестру, изменяя значения при совпадении параметров. Для того чтобы на реестре отразилось и удаление, произведенное в Reg-файле, после экспорта, экспортированный фрагмент необходимо удалить из реестра; тогда, после возвращения экспортированного фрагмента, в нем останется лишь то, что осталось в Reg-файле.

Во многих случаях реестр не требует ручной коррекции, поскольку корректируется любым изменением системных настроек, но иногда, изменение настроек удобней производить непосредственно в реестре, к тому же, некоторые изменения, иным способом могут оказаться неосуществимы .

Ручное редактирование реестра удобно для исправления ошибочных ссылок на удаленные или перемещенные файлы (хотя, во многом, эту обязанность берет на себя программа WinDoctor), а так же, для изменения свойств типа файлов, в частности, исключения конкретного расширения из общего типа, с целью назначения ему самостоятельных свойств. Кроме того, коррекция реестра полезна для “обмана” условно-бесплатных программ, через месяц после установки, начинающих кричать о необходимости регистрации. Простое удаление этих программ, с последующей переустановкой, ничего не дает, поскольку в реестре остаются ссылки, по которым программа определяет, когда была установлена впервые. Удаление этих ссылок, позволяет заставить программу, после переустановки, отсчитывать срок регистрации заново и, до поры – до времени, не надоедать (это вполне законно, хотя и не достаточно порядочно).

Да мало ли еще, зачем может потребоваться коррекция реестра? Удаление программ не удаляет все имеющиеся на них ссылки. Обычно такие ссылки безвредны и не вызывают ошибок (а следовательно и претензий со стороны программы WinDoctor). Но в связи с их накоплением, реестр разрастается как снежный ком, усложняя поиск ссылок и, таким образом, замедляя работу компьютера.

При просмотре в программе RegEdit, реестр представляется иерархической структурой, сходной со структурой каталогов и состоящей из множества вложенных друг в друга подчиненных разделов (HKEY). Только вместо файлов, в разделах содержатся параметры (которые и обрабатываются аналогично файлам – двойной щелчок и т. д.), информация которых определяет их значение .

При этом параметр, называемый “по умолчанию”, означает, отсутствие какого-то ни было параметра, а фраза “значение не присвоено” означает отсутствие значения (свойственно отсутствующим параметрам).

Основа реестра – шесть верховных (корневых) разделов:

HKEY_CLASSES_ROOT (раздел стандартных установок) – содержит ассоциации, связывающие файлы с конкретными программами и значками (файловые ассоциации), необходимые для их запуска, выбора значков и вывода контекстного меню.

HKEY_CURRENT_USER (раздел выбранного пользователя) – содержит настройки текущего пользователя.

HKEY_LOCAL_MACHINE (раздел данного компьютера) – содержит профили оборудования и данные о програмном обеспечении.

HKEY_USERS (раздел пользователей) – содержит информацию обо всех зарегистрированных на компьютере пользователях, передаваемую, по необходимости, в раздел CURRENT_USER.

HKEY_CURRENT_CONFIG (раздел выбранной конфигурации) – содержит текущую конфигурацию оборудования, определяя, какие устройства из всех имеющихся и зарегистрированных в подразделе CONFIG, раздела LOCAL_MACHINE, в нее включены, а какие, нет.

HKEY_DYN_DATA (раздел динамических данных) – содержит динамически обновляемые данные о производительности оборудования, используемые программами типа Системный монитор.

Некоторые из подразделов реестра могут вызывать наибольший интерес:

NKEY_CURRENT_USER\Control Panel содержит пользовательские настройки свойств экрана (например, параметр “Window”, определяет цвет фона окон).

HKEY_CURRENT_USER\Software содержит настройки приложений, конкретные разделы которых, начинаются с названий фирм-производителей.

HKEY_LOCAL_MACHINE\Software\Microsoft\CurrentVersion\UnInstall содержит ссылки на программы деинсталляции. Если после удаления приложения, ссылка на нее не удалилась из программы “Установка и удаление программ”, значит, остался неудаленным и его деинсталлятор. По указанию в этом разделе, его можно найти и удалить (после чего имеет смысл очистить реестр от всех лишних ссылок).

Дальнейшее перечисление конкретных подразделов утомительно и бессмысленно. Если человек приходит к выводу о необходимости корректировать реестр, то он, как правило, знает, что собирается делать. Однако некоторые изменения полезно внести в любой реестр (сотрудники Microsoft упустили это из виду):

Предлогаемый .Reg-файл вносит в контекстное меню папки очень полезный пункт "Открыть в окне DOS".

REGEDIT4

[HKEY_CLASSES_ROOT\Directory\shell\DOS]

@="О&ткрыть в окне DOS"

[HKEY_CLASSES_ROOT\Directory\shell\DOS\Command]

@="C:\\Command.com /k cd %1"

Следущий .Reg-файл вносит в контекстное меню всех файлов не менее полезный пункт "Открыть с помощью".

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\CLASSES\*\Shell]

[HKEY_LOCAL_MACHINE\Software\CLASSES\*\Shell\OpenWith]

@="О&ткрыть в ..."

[HKEY_LOCAL_MACHINE\Software\CLASSES\*\Shell\OpenWith\Command]

@="C:\\WINDOWS\\rundll32.exe shell32.dll,OpenAs_RunDLL %1"

Третий .Reg-файл меняет редактор пакетных файлов с Блокнота на более подходящий Edit (Edit использует одинаковую с ними кодировку, но для англоязычных народов это не имеет значения).

REGEDIT4

[HKEY_CLASSES_ROOT\batfile\shell\edit]

@="&Изменить"

[HKEY_CLASSES_ROOT\batfile\shell\edit\command]

@="C:\\WINDOWS\\COMMAND\\edit.com %1"

Подобные изменения можно произвести не только с помощью Reg-файлов, но и непосредственным добавлением (коррекцией) разделов и ключей в редакторе реестра, а так же (не считая последнего), отредактировав зарегистрированные типы файлов в свойствах папки. Изменения, вносимые данной коррекцией, вступают в силу без перезагрузки.

К сожалению, стандартный RegEdit не имеет стека для запоминания вносимых изменений и для получения возможности их отмены (можно ведь, по ошибке удалить не тот раздел или, вместо "скопировать", выдать команду "вставить"), следует иметь резервную копию реестра. Однако это не вполне удобно: ошибка может произойти после нескольких правильных изменений, а отменить, в случае чего, придется все. Более удобно, перед каждым изменением (по крайней мере, удалением), делать копию редактируемого подраздела, экспортируя его в Reg-файл. Еще удобней, использовать в работе с реестром редактор из нортоновских утилит. При наличии апплетов Registry Tracker и File Compare, он позволяет находить изменения и отменять нежелательные.

Есть у стандартного редактора реестра и свои преимущества: он работает не только в среде Windows, но и в DOS, хотя и ограничивается в таком случае только экспортно-импортными операциями. Эту возможность можно использовать, если вследствие изменений реестра, Windows отказывается загружаться (впрочем, он и сам неплохо зализывает свои раны).

Вызывается ДОС-режим, командой "Regedit" с одним из обязательных параметров. При этом, если каталог с реестром не является текущим, перед их вводом требуется явное указание пути к файлам реестра.

Ключ /L: указывает на файл System.dat

Ключ /R: указывает на файл User.dat

Обязательных параметров всего четыре:

ФАЙЛ – указывает файлы которые необходимо добавить в реестр.

/C ФАЙЛ – указывает файл из которого необходимо создать реестр (резервная копия реестра в формате Reg, перед преобразованием которой, производится удаление файлов реестра).

/E ФАЙЛ – указывает файл для экспорта. Если экспортировать следует не весь реестр, то через пробел после имени файла, указывается желаемый подраздел (весть реестр слишком велик и, его не сможет редактировать даже редактор Edit).

/D РАЗДЕЛ – удаляет указанный подраздел.

Например: Regedit /L:windows\System.dat /R:windows\User.dat /E C:\моидок~1\Reg.reg

Следует обратить внимание на синтаксис команды: в параметрах, имя файла (раздела) отделяется от ключевого символа пробелом, но в указании пути к файлам реестра пробел недопустим – вместо него ставится двоеточие.

Следует учитывать, что основное считывание реестра происходит только при запуске компьютера и, иногда, для вступления новых настроек в силу, компьютер следует перегрузить (для обновления, отображаемого редактором, содержимого реестра, перезапуск не требуется: достаточно нажать клавишу F5).

Поиск ссылок, при этом, производится через “Правка\Найти” или клавишу F3. Искать можно либо конкретные ссылки, либо каталоги, ранее содержавшие перемещенные файлы.

Значения делятся на три типа:

Строковые – представленные обычным текстом

DWORD (Double Word) – обычные числа

Двоичные – данные, записанные в машинном коде.


Создание загрузочных дискет.

Действуя в рамках закона об авторских правах, корпорация MicroSoft не может включить в аварийный комплект программы сторонних разработчиков. Поэтому, загрузочная дискета, автоматически создаваемая Windows, удовлетворяет лишь тех, кто не разбирается ни в системе команд MS-DOS, ни в ее программах и драйверах.

Дискеты создаваемые программами типа Rescue создаются на основе имеющейся конфигурации компьютера и в большей степени соответствуют запросам пользователя, но и они не безупречны.

Неплохой заменой загрузочных дискет служат пиратские загрузочные CDROM на 650 мегабайтах которых, с лихвой умещаются любые программы необходимые для восстановления работоспособности компьютера, не взирая на авторские права разработчиков (что очень удобно для пользователя). Но они тоже не панацея. В частности, на них нельзя зарезервировать данные CMOS и другую эксклюзивную информацию, а стремление создать нечто супер универсальное, нередко приводит к недопустимой перегруженности основной памяти. Кроме того, не смотря на огромный выбор программ, на диске может не оказаться именно той, которая нужна в данном случае: никто не способен учесть интересы конкретного пользователя в той мере, в которой их может учесть он сам. Только конкретный пользователь может определить набор данных, драйверов и программ должных присутствовать на загрузочной дискете. Конечно, компоненты нехватающие стандартному загрузочному набору всегда можно подкачать с обычной дискеты, на которой были зарезервированы, но уж коли такая дискета создается, почему бы ее заодно не сделать загрузочной? В таком случае отпадет необходимость работы сразу с несколькими съемными носителями, одни из которых применяются как загрузочные, а другие служат источниками информации и дополнительных программ. Отпадает и проблема памяти.

Загрузочные дискеты нужны и, создавать их лучше самому. В жизни всякое случается и если не предусмотреть возможность спасения компьютера и хранящейся на нем информации, в один, отнюдь не прекрасный, день, всю ее можно потерять. Аварийный комплект нужен, даже если компьютер не содержит ничего ценного: восстановление его нормальной работы программами Rescue, AVP, UnFormat и другими, в сотни раз быстрее, чем переустановка операционной системы и всех желаемых программ.

При создании загрузочной дискеты необходимо отдавать себе отчет в том, что место на ней предельно ограничено и для помещения на нее всего необходимого, требуется избавить ее от всего лишнего, а для этого требуется точно определить, что именно должно на ней содержатся.

Выбор содержимого.

Прежде всего, на дискете должны содержатся системные файлы и некоторые другие вещи, необходимые для обеспечения нормальной загрузки. К ним относятся:

Io.sys

MSDOS.sys

Command.com

Config.sys

Autoexec.bat

При чем, первые два переносятся на дискету не вручную, а в процессе ее форматирования или после него, выдачей команды SYS A: (если на компьютере не используются сжатые диски, драйвер сжатия, так же переносимый автоматически, следует удалить – нечего место занимать).

Дальнейшие компоненты зависят от конкретной ситуации, под которую готовится дискета (полезно иметь несколько дискет, предназначенных для решения определенного круга задач – это полезно еще и для подстраховки, на случай если одна дискета выйдет из строя). Для большей вместимости дискет, файлы, запуск которых происходит после запуска Command.com можно предварительно сжать Zip-архиватором, однако для их распаковки, необходимо найти и скопировать на дискету программу PkUnZip.exe. Программы внешних команд MS-DOS, размещать на дискете, в любом случае не стоит – их лучше заменить программой-оболочкой типа Norton Commander, например, Volcov Commander , или, на худой конец оболочкой NDOS, входящей в состав нортоновских утилит для MS-DOS (последнюю следует помещать не в придачу, а вместо Command.com, командой SHELL, в Config.sys).

Volcov Commander

Программа Volcov Commander, безусловно, гениальна. По сути – это полноценная операционная система (при добавлении ядра). И это притом, что на обычной дискете их умещается, чуть ли не двадцать штук! Ее основные компоненты, которые желательно перенести на дискету:

Vc.com – собственно программа

Vc.ini – файл настройки

Vc.ext – файл, определяющий, какие действия будут производиться при двойном щелчке мыши (например, включение в него строки “zip: pkunzip -vbn !.! | more” приведет к тому что, при двойном щелчке на файле с расширением Zip программа PkUnZip прочтет оглавление содержащегося в нем архива и передаст полученные сведенья программе More для постраничного вывода на экран).

Vc.mnu – меню пользователя, позволяющее автоматизировать некоторые стандартные процедуры.

Norton Commander

При желании, на дискету можно перенести и сам Norton Commander, хотя и в несколько сокращенной версии:

ARCVIEW.EXE – программа просмотра содержимого архива, удобна для поиска текстовой информации в упакованных файлах.

NC.INI – обязательный файл настройки

NC.EXE – обязательный стартовый модуль

NC.HLP – файл справки

NC.MSG – файл, содержащий сообщения, выводимые при ошибке выполнения каких-либо операций (его наличие очень желательно)

NCEDIT.EXT – файл, определяющий редактор, вызываемый нажатием F4

NCEDIT.MSG – фай сообщений запуска редактора

NCFF.EXE – программа, автоматизирующая поиск файлов

NCFF.HLP – ее справочная система

NCFF.MSG – ее сообщения

NCMAIN.EXE – обязательный компонент, собственно и являющийся оболочкой и, вызываемый стартовым модулем

NCZIP.EXE – программа работы с архивами в оболочке Norton Commander, что удобней, чем обычным PkZip и PkUnZip.

NCZIP.MSG – ее сообщения

NORTON.INI – файл интеграции необходимый для объединения разрозненных программ в единое целое

TOOLS.MNU – файл автоматизации стандартных процедур (аналог меню пользователя)

Дополнительную информацию о компонентах программы можно получить из Readme.txt, находящимся в каталоге ее содержащем.

Вместо редактора NcEdit.exe лучше использовать более совершенный и более компактный Edit.exe из Windows (NCEDIT.EXT в таком случае содержит строчку “*.*: edit !.!”). Тем не менее, в некоторых случаях, может быть полезен и NcEdit.exe. При его наличии, щелчек мыши в низу панели состояния приводит к редактированию или созданию файла DirInfo, а при наличии файлов Ansi2866.set и 8662ansi.srt, в NcEdit возможны редактирование и просмотр файлов не только в DOS-кодировке, но и в кодировке Windows (клавиатурное сочетание ALT+F1). Очень большую и не очень нужную программу NcSi.exe предоставляющую информацию о системе лучше заменить входящей в состав Windows программой Mem.exe (если таковая вообще нужна).

Основные файлы.

К основным файлам относятся те, ради которых создаются дискеты. На разных дискетах их вариации различны, но некоторые из них наиболее употребимы:

1. Драйвера CDROM, без которых дискету не назвать полноценной, так как в случае чего, без них не удастся даже установить Windows, если его дистрибутивная копия не содержится на жестком диске или содержится, но повреждена.

2. Русификаторы шрифтов и системы в целом, без которых многие операции окажутся невозможными. Комплект русификаторов от Microsoft - файлы Ega3.cpi, Display.sys, Keybrd3.sys, Keyb.com и Mode.com - лучше заменить компактной и предоставляющей большие возможности програмой KeyRus.com (не удаляя при этом, драйвер Country.sys).

3. Иногда очень полезна программа More.com

4. Антивирусы

5. Восстановители

К группе восстановителей относятся:

1. Scandisk и Ndd – эти программы могут не только исправить ошибки, препятствующие нормальной работе компьютера, но и восстановить доступ к диску, если он исчез по причине наличия ошибок. При чем, из-за значительной разницы в размерах, предпочтительней первая из них. Для большей экономии, файл ее настройки (Scandisc.ini) можно в несколько раз сократить MS-DOS-редактором, удалив из него описание команд конфигурации.

2. Rescue – без нее, и без подготовленных ее Windows-версией файлов CmosInfo.dat, BootInfo.dat и PartInfo.dat (имеется в виду Rescue из нортоновских утилит: у аналогичных ей программ фирмы Quarterdeck и других, названия могут отличаться) для восстановления работоспособности, вообще может потребоваться разборка компьютера на запчасти и отправка их в мастерскую.

3. Sys.com, Format.com, Fdisk.com – в определенных случаях они не заменимы ни чем.

4. UnErase.exe и UnFormat.exe, если их нет на CDROM в готовом к применению виде (кроме всего прочего, последовательное применение Format и UnFormat позволяет восстановить FAT, если ее не удается восстановить программой Scandisk).

Примеры загрузочных дискет.

Антивирусная дискета (лечащие модули AdInf, AVP Inspector и переименованная DrWeb).

A:\Ansi.sys

A:\Autoexec.Bat

A:\Command.Com

A:\Config.Sys

A:\Country.Sys

A:\Dialogue.©

A:\Display.Sys

A:\Emm386.Exe

A:\Findramd.Exe

A:\Himem.Sys

A:\Io.Sys

A:\Msdos.Sys

A:\Oakcdrom.Sys

A:\Ramdrive.Sys

A:\Setramd.Bat

A:\Adinfext\Adinfext.Shl

A:\Adinfext\Adinfext.Exe

A:\Adinfext\Curetest.Shl

A:\Adinfext\Switcher.Shl

A:\Block\Drweb.Pgp

A:\Block\Pkunzip.Exe

A:\Block\Restart.Com

A:\Block\Tes40501.Vdb

A:\Block\Tes40502.Vdb

A:\Block\Tes40503.Vdb

A:\Block\Tes40504.Vdb

A:\Block\Tes40505.Vdb

A:\Block\Tes40506.Vdb

A:\Block\Tes40507.Vdb

A:\Block\Test.Exe

A:\Block\Test.Hl1

A:\Block\Test.Ini

A:\Block\Testbase.Vdb

A:\Block\Arhiv.Zip\Avpicmd.Exe

A:\Block\Arhiv.Zip\Avpicmd.Lng

A:\Block\Arhiv.Zip\Catalog.txt

A:\Block\Arhiv.Zip\Ega3.Cpi

A:\Block\Arhiv.Zip\Keyb.Com

A:\Block\Arhiv.Zip\Keybrd3.Sys

A:\Block\Arhiv.Zip\Mode.Com

A:\Block\Arhiv.Zip\More.Com

A:\Block\Arhiv.Zip\Mouse.Com

A:\Block\Arhiv.Zip\Mouse.Ini

A:\Block\Arhiv.Zip\Mscdex.Exe

A:\Block\Arhiv.Zip\Sys.Com

A:\Block\Arhiv.Zip\Vc.Com

A:\Block\Arhiv.Zip\Vc.Ext

A:\Block\Arhiv.Zip\Vc.Ini

A:\Block\Arhiv.Zip\Vc.Mnu

Vc.mnu имеет следующий набор команд:

1: Проверка на вирусы

Test !.! /cl /nm /upn /rv /ha

pause

2: Распаковка

PkUnZip -d !.!

3: Перенос системных

sys A: C:

4: Модуль AVP

avpicmd.exe C:\PROGRA~1\ANTIVI~1\INSPEC~1 AVPICMD.LNG

5: Дополнительные A.V.P.

Test.bat !.!

Pause

6: Перезапуск

Restart

Где пятый пункт предназначен для запуска AVP и Navdx содержащихся на отдельных дискетах вместе с файлами Test.bat, определяющими параметры их запуска (в том числе параметры типа %1 позволяющие введение дополнительных параметров), а !.! – специфическая команда Volcov Commander означающая введение выбранного файла (папки) в качестве дополнительного параметра вызываемой программы (удобно для точечной обработки подозрительных объектов).

Восстановительная дискета.

A:\Ansi.Sys

A:\Autoexec.Bat

A:\Command.Com

A:\Config.Sys

A:\Country.Sys

A:\Display.Sys

A:\Emm386.Exe

A:\Findramd.Exe

A:\Himem.Sys

A:\Io.Sys

A:\Oakcdrom.Sys

A:\Msdos.Sys

A:\Ramdrive.Sys

A:\Setramd.Bat

A:\Block\Pkunzip.Exe

A:\Block\Arhiv.Zip\Bootinfo.Dat

A:\Block\Arhiv.Zip\Catalog.txt

A:\Block\Arhiv.Zip\Cmosinfo.Dat

A:\Block\Arhiv.Zip\Cpuid.Exe

A:\Block\Arhiv.Zip\Ega3.Cpi

A:\Block\Arhiv.Zip\Fdisk.Exe

A:\Block\Arhiv.Zip\Format.Com

A:\Block\Arhiv.Zip\Keyb.Com

A:\Block\Arhiv.Zip\Keybrd3.Sys

A:\Block\Arhiv.Zip\Mode.Com

A:\Block\Arhiv.Zip\Mouse.Com

A:\Block\Arhiv.Zip\Mouse.Ini

A:\Block\Arhiv.Zip\Mscdex.Exe

A:\Block\Arhiv.Zip\Partinfo.Dat

A:\Block\Arhiv.Zip\Pkzip.Exe

A:\Block\Arhiv.Zip\Rescue.Exe

A:\Block\Arhiv.Zip\Rescued.Hlp

A:\Block\Arhiv.Zip\Scandisk.Exe

A:\Block\Arhiv.Zip\Scandisk.Ini

A:\Block\Arhiv.Zip\Symcfg.Bin

A:\Block\Arhiv.Zip\Sys.Com

A:\Block\Arhiv.Zip\Vc.Com

A:\Block\Arhiv.Zip\Vc.Ini

A:\Block\Arhiv.Zip\Edit.Hlp

A:\Block\Arhiv.Zip\Edit.Com

A:\Block\Arhiv.Zip\Dirinfo

A:\Block\Arhiv.Zip\Unformat.Exe

A:\Block\Arhiv.Zip\Unformat.Hlp

A:\Block\Arhiv.Zip\Restart.Com

A:\Block\Arhiv.Zip\Choice.Com

A:\Block\Arhiv.Zip\Vc.Ext

A:\Block\Arhiv.Zip\More.Com

A:\Block\Arhiv.Zip\Vc.Mnu

Имеется, так же, файл с несколько непривычным названием: A:\Block\Arhiv.Zip\{1092EB28-619D-11D3-A686-A601C782F80A} – создаваемый программой Rescue.

Универсальная дискета

Эта дискета сочетает в себе некоторые возможности первых двух. Тем, кому нужна некая простенькая дискета на все случаи жизни, возможно нечто подобное и подойдет.

A:\Autoexec.Bat

A:\Command.Com

A:\Config.Sys

A:\Country.Sys

A:\Emm386.Exe

A:\Findramd.Exe

A:\Himem.Sys

A:\Io.Sys

A:\MSDOS.Sys

A:\Oakcdrom.Sys

A:\Ramdrive.Sys

A:\Setramd.Bat

A:\Display.Sys

A:\Block\Pkunzip.Exe

A:\Block\Drweb.Pgp

A:\Block\Test.Ini

A:\Block\Test.Exe

A:\Block\Test.Hl1

A:\Block\Tes40501.Vdb

A:\Block\Tes40502.Vdb

A:\Block\Tes40503.Vdb

A:\Block\Tes40504.Vdb

A:\Block\Tes40505.Vdb

A:\Block\Tes40506.Vdb

A:\Block\Tes40507.Vdb

A:\Block\Testbase.Vdb

A:\Block\Arhiv.Zip\Catalog.txt

A:\Block\Arhiv.Zip\Ega3.Cpi

A:\Block\Arhiv.Zip\Fdisk.Exe

A:\Block\Arhiv.Zip\Format.Com

A:\Block\Arhiv.Zip\Keyb.Com

A:\Block\Arhiv.Zip\Keybrd3.Sys

A:\Block\Arhiv.Zip\Mode.Com

A:\Block\Arhiv.Zip\More.Com

A:\Block\Arhiv.Zip\Mouse.Com

A:\Block\Arhiv.Zip\Mscdex.Exe

A:\Block\Arhiv.Zip\Restart.Com

A:\Block\Arhiv.Zip\Scandisk.Exe

A:\Block\Arhiv.Zip\Scandisk.Ini

A:\Block\Arhiv.Zip\Sys.Com

A:\Block\Arhiv.Zip\Vc.Com

A:\Block\Arhiv.Zip\Vc.Ini

A:\Block\Arhiv.Zip\Vc.Mnu

A:\Block\Arhiv.Zip\Vc.Ext

Дополнительно

Вместо архивов распаковываемых PkUnZip можно применять самораспаковывающиеся MS-DOS-архивы Rar, которые, несмотря на содержание модуля распаковки, занимают места ничуть не больше обычного зипа, да еще и позволяют сэкономить, удалив или заархивировав PkUnZip. Они предельно просты в применении и исполняются сразу после ввода их названия, более того, выводят отчет на русском языке (русскоязычная версия). Но распаковываются, только в папку их содержащую, и это ничем не изменить.

PkUnZip они не заменят, поскольку применимы только к самим себе, но если все архивы – MS-DOS Rar-Self-Extracting, о нем можно не беспокоится.

Для предварительного осмотра оглавления архива применяется параметр “-v”, например:

Arhiv –v

А чтобы просмотр был постраничным, сообщения архиватора (как и у PkUnZip), передают программе More.

Arhiv –v | more

Rar Sfx не панацея. Информация может быть сжата и в обычный Rar, со словарем в 1024 килобайт, а вкачестве распаковщика применен UnRar. Кроме того, можно воспользоватся, упаковщиками исполняемых файлов и драйверов, типа DIET. При творческом подходе, на одну загрузочную дискету можно уместить не только драйвера мыши, CDROM, дисплея и клавиатуры; программы Format.com, Fdisk.exe, Sys.com и файловый менеджер, но и весь набор Нортоновских утилит, вместе со справочной системой.

Запуск программы-оболочки не следует включать в Autoexec.bat, поскольку, запущенная в рамках пакетного файла, она может некорректно работать с некоторыми командами меню пользователя и меню утилит (Tools.mnu).


Создание логических разделов и форматирование жестких дисков.

Ситуации, в которых требуется передел диска.

Для ускорения выполнения служебных процедур, типа дефрагментации и проверки диска, установленный в системный блок, жесткий диск полезно разделить на несколько логических. Размер каждого, в отдельности взятого, логического диска (раздела), меньше общего размера жесткого диска, и потому, даже при том же количестве содержащейся информации, на обработку одного логического диска уходит меньше времени. Кроме того, дополнительная экономия времени обработки достигается за счёт разделения хранимой информации между логическими разделами. Организованные таким образом разделы можно по очереди, между делом, обрабатывать хоть каждый день; в то время как, обработка единого большёго диска, происходит слишком долго, и выполнить её между делом просто невозможно. Ну а поскольку обработка диска, не совместима ни с какими другими операциями, до её проведения часто не доходят руки.

Однако, удобство обслуживания малых дисков далеко не главная причина их создания. До появления Windows 98 их создание, зачастую происходило вынуждено. Процедура создания кластеров и структура их расположения FAT 16 применяемая до его появления, не признавала разделов более двух гигабайт и, при наличии большего диска, его приходилось делить на меньшие уже хотя бы, для того чтобы получить возможность с ним работать . Теперь эта проблема разрешена: FAT 32 поддерживает работу с дисками размером до 4 тысяч гигабайт, и необходимость деления диска отпала (покажите мне человека, который встречал диск хотя бы в одну тысячу). Но это вовсе не означает, что физический диск не следует делить.

Сегодня главным аргументом в поддержку создания логических разделов является возможность раздельного хранения информации. Вероятность одновременного повреждения сразу нескольких дисков практически равна нолю, а значит, информация, размещённая на одном диске, стопроцентно защищена от любых катастроф другого. Особенно очевидно это, в отношении логических ошибок.

С этой точки зрения, наличие двух дисков не менее целесообразно, чем наличие запасного колеса в багажнике машины. На первом диске – основном, располагается операционная система и прикладные программы Windows, на втором – резервные копии и документы.

Перемещение прикладных программ на резервный диск не имеет смысла, поскольку они интегрируются в систему, забрасывая в неё часть файлов и организовывая многочисленные ссылки в системном реестре. При удалении системы (здесь не имеется в виду её переустановка, когда одни системные файлы замещаются другими, перенимающими бразды правления над программами), даже если её, затем, установить заново, они уже никогда не заработают. Лишь некоторые простейшие приложения Windows могут работать автономно (естественно, при наличии необходимой им операционной среды); такие приложения не предусматривают процедуру инсталляции (Setup) и не обмениваются файлами с Windows.

Однако и им не место на запасном диске.

Основное вирусное заражение программ, происходит при их исполнении и, чем меньше с запасного диска запускается программ, тем меньше вероятность, что туда переберется вирус. Даже инсталляцию приложений, в идеале, следует проводить непосредственно с основного диска, предварительно скопировав ее дистрибутив из архива, чтобы не заразить инсталлятор (но это уже похоже на манию преследования вирусами). Поэтому, на запасном диске стоит размещать только программы, не используемые в повседневной жизни, например, копии дистрибутивов, программы облегающие восстановление компьютера из руин, но не вмещающихся на дискету (таких как Norton Commander) и документы (для большей надёжности, копии документов следует держать ещё и на съемных носителях).

Хранение на резервном диске, наряду с неиспользуемыми программами, еще и периодически используемых документов, в отличие от хранения программ, имеет определенный резон: поступающие иначе и лишь резервирующие документы на запасном диске в конце дня, рискуют поместить в резерв версии уже поврежденные вирусами или дисковыми ошибками. Если документы сохранять там сразу, вероятность повреждения окажется гораздо ниже, хотя создание еще одной копии (на том же диске и, тем более, на съемном носителе), полезно не только на случай сбоя, но и на случай правки, которую уже невозможно отменить, но, которая оказалась ошибочной.

Наличие запасного диска, содержащего резервный комплект, позволяет во всеоружии встретить любые неожиданности, и потопу, создание раздельных дисков и разделение их функций так же разумно, как отделение кухни от туалета. Кроме того, при необходимости форматирования, существует возможность временной эвакуации имеющихся данных с одного диска на другой. Ситуации, в которых возникает необходимость форматирования всех дисков, крайне редки.

Производится разделение диска программой Fdisk.exe.

Работа с Fdisk.

Эта программа предназначена для работы в MS-DOS, и потому, для её применения необходимо загрузится в режиме командной строки, а при переделе системного диска, загрузится с загрузочной дискеты, на которой эта программа обязана присутствовать.

Но прежде чем приступать к работе с ней, следует чётко разобраться в применяемой ей терминологии.

Классификация дисков, или терминология с точки зрения FDISK.

ДИСКОМ называется физическое устройство, вставленное в системный блок компьютера.

РАЗДЕЛОМ называется обособленная часть дисковой памяти. При работе Fdisk делает специальную запись (главная загрузочная запись) указывающую кластеры, пространство между которыми будет считаться отдельным диском.

Раздел, в котором располагаются системные файлы MS-DOS или Windows (в состав последнего входят слегка модернизированные системные файлы первого), называется основным (primari DOS patrition), в нем должны находится системные файлы Io.sys и MsDos.sys.

Раздел, не содержащий системных файлов MS-DOS, называется дополнительным (extended DOS patrition). Для эксплуатации пространства выделенного под дополнительный раздел, это пространство должно быть идентифицировано как логический диск (или логические диски).

ЛОГИЧЕСКИЙ ДИСК – это на самом деле не то же самое, что и раздел. Логический диск – это часть дополнительного раздела, идентичная ему только в том случае, если занимает весь дополнительный раздел. Логические диски создаются в дополнительном разделе и имеют собственную логическую структуру, что позволяет, во первых, использовать их как самостоятельные физические (с тем только ограничением, что их нельзя вынуть из компьютера), а во вторых, использовать физические диски с объемом превосходящим возможности используемой системы адресации файлов (FAT).

Наличие логического диска является необходимым условием эксплуатации дополнительного раздела.

АКТИВНЫЙ РАЗДЕЛ – это основной раздел, с которого происходит загрузка компьютера. На компьютере может содержаться несколько основных разделов с собственной операционной системой. При этом, загрузка происходит именно с того основного раздела, который в данный момент является активным.

РАЗДЕЛЫ ОПЕРАЦИОННЫХ СИСТЕМ, НЕ СОДЕРЖАЩИХ MS-DOS – это часть дисковой памяти, не включённая ни в основной раздел MS-DOS, ни в дополнительный, ради размещения в ней операционной системы иного типа, например, OS/2, прозванной полуОSью.

Только усвоив эти детали, стоит браться за Fdisk, иначе не трудно лишится того, чего не предполагалось лишаться.

Параметры FDISC.

Если при вызове программы задать параметр /status, введённый через один интервал после названия программы, она ограничится выводом сообщения о количестве физических дисков, разделов на них, их объемов и, в процентном отношении, суммы занимаемой разделами памяти. При вызове статуса дисков стоит обратить внимание именно на проценты: может статься, что часть диска вообще не используется.

Если вызвать программу без дополнительных параметров, она предложит создать поддержку больших разделов (организовать файловую структуру FAT32) или отказаться от этой поддержки (принять структуру FAT16). В зависимости от намерений, пользователь нажимает Y (да) для включения FAT32 или N (нет).

После выбора варианта FAT-таблици и нажатия Enter появляется главное меню:

Пункт первый позволяет войти в подменю создания раздела MS-DOS или его логического диска, где, на выбор, предлагается либо создать основной раздел MS-DOS, либо добавить, к уже имеющемуся основному, дополнительный, либо разделить, уже имеющийся дополнительный, на несколько логических дисков. Если под основной и дополнительный раздел выделить не всю ёмкость диска, то на оставшейся территории можно поместить вторую операционную систему.

Второй пункт – выбор активного раздела – предназначен для тех, кто имеет несколько операционных систем и, позволяет выбрать систему, активируемую при включении компьютера. Имеющие одну систему, основанную на MS-DOS, делают активным основной раздел MS-DOS, одновременно с его созданием.

Третий пункт позволяет удалять разделы и диски. Имеющим несколько операционных систем, перед удалением основного раздела одной из них (если таковое требуется), следует сделать активным основной раздел другой, чтобы получить возможность загружаться с него.

Четвертый, по сути, аналогичен вызову Fdisk с параметром /status.

Пятый пункт – выбор текущего диска – появляется только при наличии второго физического диска и предназначен для выбора диска над которым будут проводится операции.

Порядок работы

Создавать диски и разделы можно только на свободном пространстве, поэтому, перед их созданием, в большинстве случаев, на имеющемся физическом диске требуется освободить место путём удаления ненужных логических дисков и разделов.

Удаление происходит с конца, что не всегда удобно, поскольку, например, для удаления основного раздела требуется удалить и весь остальной диск, уничтожив хранимую на нём информацию. Если же в переделе нуждается только последний диск дополнительного раздела, остальное можно оставить в покое.

Созидание происходит с начала. Первым создаётся основной раздел MS-DOS, если он ещё не создан, затем дополнительный, после чего, в дополнительном разделе, создаётся нужное количество логических дисков. Размеры разделов и дисков указываются либо в мегабайтах, либо в процентах.

В случае необходимости не-MS-DOS системы, дополнительному разделу отдаётся не всё пространство, оставшееся после создания основного. Однако если не-MS-DOS система не будет установлена, это пространство так и останется неиспользованным, пока весь дополнительный раздел не будет удалён и воссоздан заново, охватывая весь свободный объем.

Противники деления физических дисков аргументируют свою позицию возможностью ситуации, когда общего свободного места хватает на установку новой программы, а на каждом отдельном диске его не достаточно, но их аргументы, по меньшей мере, необдуманны. Конечно, не возможно разделить файл между двумя-тремя дисками так, чтобы он остался годен к применению, невозможно уговорить программу установки нового приложения размещать его компоненты на разных дисках. Но всегда можно освободить достаточное место на желаемом диске, перенеся часть хранящихся там файлов на другой. Даже если при этом окажется расчленена на части какая-то ранее установленная программа – не беда, программы типа Нортоновского WinDoctor фирмы Symantec, найдут неправильные ссылки в регистре Windows и сами предложат заменить ссылки, поставив в них новые адреса файлов, чтобы использующие их программы могли исправно работать. Так что диск можно делить как угодно, лишь бы не запутаться, что на каком диске находится.

При работе с Fdisk, как и при работе со многими другими программами MS-DOS, клавиатура должна быть переключена на английскую раскладку. Желаемое действие выбирается из списка меню нажатием соответствующей буквы или цифры и приводится в исполнение после нажатия ENTER.

Выход из подменю, а так же, выход из программы, при нахождении в главном меню, как и указанно в каждом меню Fdisk, осуществляется нажатием клавиши Escape.

Действие программы Fdisk заключается создании (или изменении) главной загрузочной записи и, поскольку ее чтение происходит только при загрузке компьютера (даже при загрузке с дискеты, главная загрузочная запись считывается, чтобы определить какие еще диски имеются в наличии), для вступление этих изменений в силу, компьютер требуется перезагрузить. Но, до тех пор, пока вновь созданные диски и разделы не будут подготовлены к работе программой FORMAT.COM, их использование невозможно.

Форматирование жестких дисков.

Операция форматирования жестких дисков настолько проста и быстра, что иногда её применяют для расчистки дискового пространства, вместо операции DELETE – удаления файлов (особенно часто, с этой целью, её применяли во времена господства MS-DOS, в котором удаление, даже небольших программ, длится столько же, сколько длилась “Санта Барбара”). Программа Format.com предназначена для работы в системе MS-DOS и, к тому же, отказывается обрабатывать диск, на котором запущенна хотя бы одна программа. По этому, как правило, её применяют, загружаясь с дискеты.

Вызывают программу командой "Format".

Поставленная через один пробел буква с двоеточием (например, Format C:) указывает, какой диск следует форматировать.

При форматировании основного раздела MS-DOS, в его корневой каталог должны быть перенесены системные файлы Io.sys и Msdos.sys, для чего через пробел после указания диска, задаётся ключ /s (например, Format C: /S) . Тот же перенос системных файлов можно выполнить после форматирования с помощью программы Sys.com для чего достаточно набрать её имя и указать будущий системный диск (Sys С:). По окончании переноса системных файлов, соответствующее сообщение появится на экране.

В процессе форматирования диска программа Format выдаёт запрос о назначении метки создаваемого тома. Эта метка заносится в корневой каталог и помогает пользователю ориентироваться в назначении данного диска. Она же может привести к ошибкам при переносе системных файлов, должных занимать строго соответствующие кластеры, если эти файлы ещё не перенесены или для них не зарезервировано место ключом (параметром) /B. Поэтому, при форматировании основного раздела, от назначения метки, до переноса системных файлов, следует воздержаться. Создать или изменить метку никогда не поздно средствами Windows, путём открытия свойств выбранного диска. Этот способ назначения метки является наиболее корректным.

Отформатировав системный диск (основной раздел MS-DOS) и отправив на него указанные файлы, перезапустив компьютер, можно загружаться с него.

После форматирования системного диска, требуется не только заново установить операционную систему, но так же инсталлировать саундкарту, видеокарту и прочие дополнительные устройства. Драйвера основных устройств (например, гибкого и жесткого диска), содержатся в BIOS и новой установке не нуждаются.

Дело в том, что IBM, а точнее, Intel совместимые компьютеры (поскольку дело не в домашнем конструкторе выдуманном на IBM, а в применяемом на подобных машинах процессоре фирмы Intel и заложенных в него командах), с их программной средой основанной на всевозможных DOS, считывают информацию секторами не более 32 килобайт, а шестнадцати битная система адресации FAT16 позволяет создать не более 65536 адресов (столько значений можно закодировать с помощью шестнадцати бит). При таком количестве и величине секторов суммарный объем диска не может превышать 2147483648 байт.

При этом так же может потребоваться коррекция Ini-файлов, переносимой программы.

Делать это вручную очень хлопотно, поскольку не известны ни адреса требуемых кластеров, ни способы отправки файлов именно по ним.


Установка операционной системы.

ЗАГРУЗКА MS-DOS

Загрузка MS-DOS возможна тремя способами:

1. Удерживанием клавиши Ctrl при запуске компьютера, для того чтобы, войдя, твким образом, в меню загрузки Windows 98 (клавиша F8 остаётся в силе, но поскольку при загрузке Windows98 не выдаётся сообщение "Starting Windows98", подобное которому выдаётся Windows95, определять время её нажатия приходится наугад), выбрать режим "command promt only" (только командная строка). Сделать выбор необходимо не более чум за 30 секунд, иначе загрузка автоматически продолжится по сценарию Windows.

2. Загрузкой с системной дискеты, для чего, если загрузка компьютера происходит, прежде всего, с жёсткого диска, после сканирования памяти при запуске компьютера (первый экран) и выдачи сообщения “Hit <DEL> if you want to run setup” (нажмите DEL, если хотите вызвать процедуру Setup) потребуется, нажатием клавиши “Del”, войти в BIOS для изменения способа загрузки. Выйдя в BIOS (синий экран с таблицей), курсорными клавишами следует выбрать BIOS FEATURES SETUP и нажать Enter, чтобы выйти в его опции. В данной ситуации значение имеют лишь две из них:

VIRUS WARNING если включен (Enabled), сканирует систему на вирусы. Перед переустановкой операционной системы его лучше отключить.

BOOT SEQUENCE определяет порядок загрузки. Для загрузки с системной дискеты, требуется, чтобы загрузка происходила в первую очередь с дискеты (обычно это диск А).

Переключение опций производится клавишами Page Up и Page Dawn.

Установив параметры, нужно, с помощью клавиши Esc, вернутся в меню BIOS и, если требуется, сохранить произведённые изменения, нажать клавишу F10, в противном случае, ещё раз нажать Esc. На запрос, желаете ли вы вернутся к загрузке (выйти из BIOS), появляющейся в небольшой табличке, в обоих случаях последовательно нажимают “Y” и Enter. Если нажать “N” и Enter, возвращение к загрузке не произойдёт.

3. Путём пошаговой загрузки, если загрузка некоторых драйверов нежелательна. Для этого через Ctrl при загрузке компьютера выходят в меню запуска и выбирают режим “Step by step”, затем отвечают “Yes” за запросы загрузки необходимых драйверов. Загрузку драйвера Himem.sys открывающего DOS доступ к большему количеству оперативной памяти желательно разрешить.

УСТАНОВКА WINDOWS 98

В любом случае она заключается в запуске Setup из директории (папки) содержащий его дистрибутив (не распакованную версию). Лучше, если этот дистрибутив скопирован на жёсткий диск.

Процедура установки определяется интерфейсом и в зависимости от операционной системы отличается лишь способом подачи команд.

Нижеприведенные инструкции предназначены для новичков:

Из MS-DOS:

Если дистрибутивная копия Windows еще не перенесена на жесткий диск, следует убедиться, что устройство чтения компакт-дисков доступно. Если же оно недоступно значит драйвера доступа к компакт-диску в реальном режиме (в режиме MS-DOS) не установлены и перед продолжением работы следует их установить. Для этого, если программа установки Windows 98 уже запускалась, и ей была создана загрузочная (системная) дискета, можно воспользоваться находящимися на ней драйверами, (при загрузке с нее и выборе первого пункта загрузочного меню, эти драйверы запускаются автоматически). При отсутствии системной дискеты, следует запустить программу установки, поставлявшуюся с устройством чтения компакт-дисков.

Обеспечив доступ к компакт-диску, следует освободить на жестком диске дополнительно 120 Мбайт дискового пространства, кроме того, которое требуется для установки (обычно для установки Windows 98 в режиме обновления Windows 95 требуется 195 Мбайт).

На диске с достаточным количеством свободного места следует создать папку для копирования установочных файлов, для чего следует перейти на выбранный диск и ввести команду создания каталога, например:

MD Win98tmp.

Затем следует перейти в папку, содержащую установочные файлы Windows 98, введя:

буква диска:\название папки (например, D:\Win98).

и скопировать установочные файлы Windows 98 в созданный временный каталог, введя команду:

Copy *.* буква диска:\Win98tmp

После того, как все файлы будут скопированы, лучше всего перезагрузить компьютер в режиме Safe mode command prompt only, поскольку с некоторыми драйверами Config.sys при установке Windows может произойти конфликт.

После перезагрузки следует перейти во временный каталог, куда были скопированы установочные файлы, (введя команду CD Win98tmp) и запустить программу установки, введя:

SETUP

Перед установкой, Windows запустит программу Scandisk для проверки диска. Эта версия программы не исправляет ошибки, а только обнаруживает их и выдает сигнал программе Setup о прекращении установки Windows. Чтобы продолжить установку в случае наличия ошибок на диске, придется запустить нормальную версию Scandisk (она содержится в папке, содержащей дистрибутив Windows) или другую подобную программу, для их исправления.

Из Windows

Из WINDOWS переустановка WINDOWS заключается в запуске Setup; перед этим папку дистрибутива желательно перетащить на жесткий диск.

Удаление лишних файлов

На разных стадиях установки, Windows записывает несколько протоколов в корневой каталог: BootLog.txt, DetLog.txt, SetupLog.txt и Detcrash.log. Они необходимы только для нормального продолжения установки в случае зависания и, после ее окончания, их можно смело удалить.

Так же, можно удалить файл C:\System.1st являющийся точной копией System.dat (часть системного реестра), резервируемой Windows на случай неисправимого сбоя во время установки (если сбой все же произошел, этим файлом следует заменить System.dat, вернув ему настоящее имя). Хранить его на диске не имеет смысла, так как уже через несколько дней имеющиеся в нем данные безнадежно устаревают.

Кроме того, в корневом каталоге могут остаться файлы Io.dos, Msdos.dos, Command.dos, Config.dos и Autoexec.dos необходимые только при наличии нескольких операционных систем (при выборе другой системы из загрузочного меню Windows, они автоматически меняют расширение на Sys, Com и Bat). Если на компьютере установлена только Windows, эти файлы подлежат удалению.

Предлогаемая расчистка освободит, по крайней мере, три мегабайта дискового пространства, да и облегчит, при необходимости, восстановление корневого каталога.

Иногда после установки множества программ, в системе систематически возникают ошибки. В этой ситуации не стоит изводить нервы и мучить компьютер Scandiskом: переустановка Windows, даже если он только вчера был установлен, во многих случаях способна решить эту проблему, вызванную подменой, устанавливаемыми программами, некоторых динамических библиотек, на более старые, непригодные для свежих программных продуктов.

Если перезагрузка не производилась, переход в каталог с установочными файлами осуществляется командой:

C:\win98tmp


Файлы конфигурации.

К файлам конфигурации Windows относятся находящиеся в корневом каталоге Aunoexec.bat, Config.sys и, находящиеся в папке Windows, файлы Sistem.ini и Win.ini. Эти файлы представляют собой обычные текстовые файлы, которые могут быть открыты, отредактированы и воссозданы с помощью любого текстового редактора. Каждая из записанных в них строчек является командой по настройке операционной системы; их изменение, приводит к соответствующему изменению в работе компьютера. Файлы Win.ini и Sistem.ini, появившиеся в операционных системах разрабатываемых Microsoft только с появлением Windows, не требуют вмешательства пользователя. Их изменение происходит автоматически при изменении режимов работы программ и устройств (можно, например, для автоматического запуска какой-либо программы при включении компьютера, открыть файл Win.ini и в разделе [Windows] записать строку “Run=”, с последующим указанием командной строки запускающей эту программу, или “Load=”, для ее запуска в свернутом виде, но проще сделать это, поместив ярлык, данной программы в папку автозагрузки, и откорректировав при желании, тип открываемого программой окна, в его свойствах). Доставшиеся Windows в наследство от MS-DOS, файлы Autoexec.bat и Config.sys, в отличаи от них, хотя и корректируются некоторыми программами автоматически, в большинстве случаев требуют ручной настройки (например, команду проверки системных файлов при загрузке компьютера, русифицированный Norton Antivirus помещает в первую строчку файла Autuexec.bat, опережая команду подключения русифицированных экранных шрифтов, в результате чего, выдаваемые им сообщения невозможно разобрать).

Просмотр и некоторая правка конфигурационных файлов удобна с помощью пункта “Программа настройки системы” меню “Сервис” программы “Сведенья о системе” (MsInfo). Не менее удобен для этой цели редактор SysEdit находящийся в папке Windows\System.

Особенности файла Config.sys

Файл Config.sys содержит информацию о подключаемых дополнительных драйверах (основные содержатся в BIOS), служащих посредниками между всевозможными устройствами и обращающимися к ним программами, а так же, может содержать параметры настройки операционной системы, без которых она работает в стандартном режиме, называемом “по умолчанию”. С помощью файла Io.sys, являющегося дополнением BIOS, он обрабатывается входящим в BIOS интерпретатором BASIC, вследствие чего:

1. Используемые в нем команды отличаются от команд используемых операционной системой

2. Их исполнение требует запуска входящей в BIOS программы SETUP и возможно только на первоначальной стадии загрузки, а поэтому, изменения вносимые в файл Config.sys вступают в силу только после перезапуска компьютера.

Особенности файла Autoexec.bat

Файл Autoexec.bat, может содержать набор команд по настройке системы и команды загрузки некоторых (как правило – резидентных, исполняемых в фоновом режиме) программ и, подобно другим файлам с расширением .bat, представляет собой пакет команд операционной системы предназначенных для автоматического исполнения. Он обрабатывается интерпретатором команд Command.com, доставшимся операционной системе Windows от операционной системы MS-DOS, вследствие чего:

1. В файле Autoexec.bat (и других файлах с этим расширением), применяются те же команды, что и при вводе из командной строки, хотя некоторые из команд .Bat-файлов, вводить в командную строку нецелесообразно (например, команду Echo off указывающую не выводить исполняемые команды на экран, нецелесообразно выдавать при ручном вводе команд, поскольку они именно с экрана и вводятся, но, тем не менее, ее ввод может иметь смысл перед исполнением .bat-файла ее не содержащего).

2. Autoexec и другие .bat-файлы являются полноценными программами, отличающимися от других программ лишь тем что, не были предварительно переведены на язык машинного кода с помощью программ-компиляторов и нуждаются в обработке интерпретаторов, входящих в состав операционной системы, вследствие чего, уступают откомпилированным программам в скорости исполнения. И, хотя при загрузке компьютера, файл Autoexec.bat исполняется автоматически, как и любые другие программы, все .bat-файлы могут быть приведены в исполнение в любой момент, по желанию пользователя.

3. Двойной щелчок мышью приводит любой Bat-файл к исполнению. Открытие Bat-файла для изменения производится либо через контекстное меню, либо отправкой на ярлык какого-нибудь текстового редактора.